python-dns-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. Name: python-dns
  2. Version: 2.0.0
  3. Release: 1%{?_dist_release}
  4. Summary: DNS toolkit for Python
  5. Summary(ja): Python 用 DNS ツールキット
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: MIT
  10. URL: http://www.dnspython.org/
  11. Source0: https://github.com/rthalley/dnspython/archive/v%{version}.tar.gz#/dnspython-%{version}.tar.gz
  12. BuildArch: noarch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python3-rpm-macros
  16. BuildRequires: python3-setuptools
  17. BuildRequires: python3-devel
  18. %description
  19. dnspython is a DNS toolkit for Python. It supports almost all record
  20. types. It can be used for queries, zone transfers, and dynamic
  21. updates. It supports TSIG authenticated messages and EDNS0.
  22. dnspython provides both high and low level access to DNS. The high
  23. level classes perform queries for data of a given name, type, and
  24. class, and return an answer set. The low level classes allow direct
  25. manipulation of DNS zones, messages, names, and records.
  26. %package -n python3-dns
  27. Summary: DNS toolkit for Python 3
  28. Group: programming
  29. %{?python_provide:%python_provide python3-dns}
  30. Requires: python3-idna
  31. Requires: python3-cryptography
  32. %description -n python3-dns
  33. dnspython3 is a DNS toolkit for Python 3. It supports almost all
  34. record types. It can be used for queries, zone transfers, and dynamic
  35. updates. It supports TSIG authenticated messages and EDNS0.
  36. dnspython3 provides both high and low level access to DNS. The high
  37. level classes perform queries for data of a given name, type, and
  38. class, and return an answer set. The low level classes allow direct
  39. manipulation of DNS zones, messages, names, and records.
  40. %prep
  41. %setup0 -q -n dnspython-%{version}
  42. # strip executable permissions so that we don't pick up dependencies
  43. # from documentation
  44. find examples -type f | xargs chmod a-x
  45. %build
  46. %py3_build
  47. %install
  48. rm -rf %{buildroot}
  49. %py3_install
  50. #%check
  51. #%{__python3} setup.py test
  52. %clean
  53. rm -rf %{buildroot}
  54. %files -n python3-dns
  55. %defattr(-,root,root,-)
  56. %license LICENSE
  57. %doc README* examples
  58. %{python3_sitelib}/*egg-info
  59. %{python3_sitelib}/dns
  60. %changelog
  61. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1
  62. - new upstream release.
  63. - built with python3 only.
  64. * Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  65. - new upstream release.
  66. - added python3 support.
  67. * Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
  68. - rebuild with VineSeed environment
  69. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  70. - add BR: python-devel, python
  71. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  72. - new upstream release
  73. * Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
  74. - initial build for Vine Linux
  75. * Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
  76. -
  77. - dnspython 1.9.4 has been released and is available at
  78. - http://www.dnspython.org/kits/1.9.4/
  79. -
  80. - There is no new functionality in this release; just a few bug fixes
  81. - in RRSIG and SIG code.
  82. -
  83. - I will be eliminating legacy code for earlier versions of DNSSEC in a
  84. - future release of dnspython.
  85. * Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
  86. -
  87. - New since 1.9.2:
  88. -
  89. - A boolean parameter, 'raise_on_no_answer', has been added to
  90. - the query() methods. In no-error, no-data situations, this
  91. - parameter determines whether NoAnswer should be raised or not.
  92. - If True, NoAnswer is raised. If False, then an Answer()
  93. - object with a None rrset will be returned.
  94. -
  95. - Resolver Answer() objects now have a canonical_name field.
  96. -
  97. - Rdata now have a __hash__ method.
  98. -
  99. - Bugs fixed since 1.9.2:
  100. -
  101. - Dnspython was erroneously doing case-insensitive comparisons
  102. - of the names in NSEC and RRSIG RRs.
  103. -
  104. - We now use "is" and not "==" when testing what section an RR
  105. - is in.
  106. -
  107. - The resolver now disallows metaqueries.
  108. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  110. * Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
  111. - It's brown paper bag time :) The fix for the import problems was
  112. - actually bad, but didn't show up in testing because the test suite's
  113. - conditional importing code hid the problem.
  114. -
  115. - Any, 1.9.2 is out.
  116. -
  117. - Sorry for the churn!
  118. * Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
  119. - New since 1.9.0:
  120. -
  121. - Nothing.
  122. -
  123. - Bugs fixed since 1.9.0
  124. -
  125. - The dns.dnssec module didn't work with DSA due to namespace
  126. - contamination from a "from"-style import.
  127. -
  128. - New since 1.8.0:
  129. -
  130. - dnspython now uses poll() instead of select() when available.
  131. -
  132. - Basic DNSSEC validation can be done using dns.dnsec.validate()
  133. - and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
  134. - later installed. Complete secure resolution is not yet
  135. - available.
  136. -
  137. - Added key_id() to the DNSSEC module, which computes the DNSSEC
  138. - key id of a DNSKEY rdata.
  139. -
  140. - Added make_ds() to the DNSSEC module, which returns the DS RR
  141. - for a given DNSKEY rdata.
  142. -
  143. - dnspython now raises an exception if HMAC-SHA284 or
  144. - HMAC-SHA512 are used with a Python older than 2.5.2. (Older
  145. - Pythons do not compute the correct value.)
  146. -
  147. - Symbolic constants are now available for TSIG algorithm names.
  148. -
  149. - Bugs fixed since 1.8.0
  150. -
  151. - dns.resolver.zone_for_name() didn't handle a query response
  152. - with a CNAME or DNAME correctly in some cases.
  153. -
  154. - When specifying rdata types and classes as text, Unicode
  155. - strings may now be used.
  156. -
  157. - Hashlib compatibility issues have been fixed.
  158. -
  159. - dns.message now imports dns.edns.
  160. -
  161. - The TSIG algorithm value was passed incorrectly to use_tsig()
  162. - in some cases.
  163. * Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
  164. - Add a patch from upstream to fix a Python 2.7 issue.
  165. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
  166. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  167. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
  168. - Fix error
  169. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
  170. - New since 1.7.1:
  171. -
  172. - Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
  173. - hmac-sha512 has been contributed by Kevin Chen.
  174. -
  175. - The tokenizer's tokens are now Token objects instead of (type,
  176. - value) tuples.
  177. -
  178. - Bugs fixed since 1.7.1:
  179. -
  180. - Escapes in masterfiles now work correctly. Previously they were
  181. - only working correctly when the text involved was part of a domain
  182. - name.
  183. -
  184. - When constructing a DDNS update, if the present() method was used
  185. - with a single rdata, a zero TTL was not added.
  186. -
  187. - The entropy pool needed locking to be thread safe.
  188. -
  189. - The entropy pool's reading of /dev/random could cause dnspython to
  190. - block.
  191. -
  192. - The entropy pool did buffered reads, potentially consuming more
  193. - randomness than we needed.
  194. -
  195. - The entropy pool did not seed with high quality randomness on
  196. - Windows.
  197. -
  198. - SRV records were compared incorrectly.
  199. -
  200. - In the e164 query function, the resolver parameter was not used.
  201. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  203. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
  204. - New since 1.7.0:
  205. -
  206. - Nothing
  207. -
  208. - Bugs fixed since 1.7.0:
  209. -
  210. - The 1.7.0 kitting process inadventently omitted the code for the
  211. - DLV RR.
  212. -
  213. - Negative DDNS prerequisites are now handled correctly.
  214. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
  215. - New since 1.6.0:
  216. -
  217. - Rdatas now have a to_digestable() method, which returns the
  218. - DNSSEC canonical form of the rdata, suitable for use in
  219. - signature computations.
  220. -
  221. - The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
  222. -
  223. - An entropy module has been added and is used to randomize query ids.
  224. -
  225. - EDNS0 options are now supported.
  226. -
  227. - UDP IXFR is now supported.
  228. -
  229. - The wire format parser now has a 'one_rr_per_rrset' mode, which
  230. - suppresses the usual coalescing of all RRs of a given type into a
  231. - single RRset.
  232. -
  233. - Various helpful DNSSEC-related constants are now defined.
  234. -
  235. - The resolver's query() method now has an optional 'source' parameter,
  236. - allowing the source IP address to be specified.
  237. -
  238. - Bugs fixed since 1.6.0:
  239. -
  240. - On Windows, the resolver set the domain incorrectly.
  241. -
  242. - DS RR parsing only allowed one Base64 chunk.
  243. -
  244. - TSIG validation didn't always use absolute names.
  245. -
  246. - NSEC.to_text() only printed the last window.
  247. -
  248. - We did not canonicalize IPv6 addresses before comparing them; we
  249. - would thus treat equivalent but different textual forms, e.g.
  250. - "1:00::1" and "1::1" as being non-equivalent.
  251. -
  252. - If the peer set a TSIG error, we didn't raise an exception.
  253. -
  254. - Some EDNS bugs in the message code have been fixed (see the ChangeLog
  255. - for details).
  256. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
  257. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  258. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
  259. - Rebuild for Python 2.6
  260. * Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
  261. - fix license tag
  262. * Tue Dec 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
  263. - Update to 1.6.0
  264. * Tue Oct 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
  265. - Follow new Python egg packaging specs
  266. * Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
  267. - Update to 1.5.0
  268. * Fri Dec 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
  269. - Bump release for rebuild with Python 2.5
  270. * Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
  271. - No longer ghost *.pyo files, thus further simplifying the files section.
  272. * Sat Aug 5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
  273. - Update to 1.4.0
  274. - Remove unneeded python-abi requires
  275. - Remove unneeded python_sitearch macro
  276. * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
  277. - First version for Fedora Extras