python-django-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179
  1. Summary: A high-level Python Web framework
  2. Summary(ja): Python の高度なウェブフレームワーク
  3. Name: python-django
  4. Version: 1.3
  5. Release: 3%{?_dist_release}
  6. Group: Development/Languages
  7. BuildArch: noarch
  8. License: BSD
  9. URL: http://www.djangoproject.com/
  10. Source0: Django-%{version}.tar.gz
  11. Source1: simplejson-init.py
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: python-devel
  14. BuildRequires: python-sphinx
  15. Requires: python-simplejson
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: owa, munepi
  19. %description
  20. Django is a high-level Python Web framework that encourages rapid
  21. development and a clean, pragmatic design. It focuses on automating as
  22. much as possible and adhering to the DRY (Don't Repeat Yourself)
  23. principle.
  24. %description -l ja
  25. Django はハイレベルな Python Web フレームワークであり、素早い開発と
  26. クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
  27. 無駄な繰返しを徹底的に排除することに注目しています。
  28. %package docs
  29. Summary: Documentation for Django
  30. Group: Documentation
  31. Requires: %{name} = %{version}-%{release}
  32. %description docs
  33. This package contains the documentation for the Django high-level
  34. Python Web framework.
  35. %prep
  36. %setup -q -n Django-%{version}
  37. # remove bundled simplejson
  38. cd django/utils/simplejson/
  39. %__rm -rf *
  40. # and put the replacement stub in place
  41. %__cp -p %{SOURCE1} __init__.py
  42. %build
  43. %{__python} setup.py build
  44. %install
  45. %__rm -rf $RPM_BUILD_ROOT
  46. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  47. # Permission fixes
  48. pushd $RPM_BUILD_ROOT%{python_sitelib}/django
  49. chmod +x conf/project_template/manage.py*
  50. chmod +x contrib/admin/media/js/compress.py*
  51. chmod +x bin/profiling/gather_profile_stats.py*
  52. #chmod +x bin/compile-messages.py*
  53. chmod +x bin/daily_cleanup.py*
  54. chmod +x bin/django-admin.py*
  55. #chmod +x bin/make-messages.py*
  56. chmod +x bin/unique-messages.py*
  57. popd
  58. # Fix items in %{_bindir}
  59. %__mv $RPM_BUILD_ROOT%{_bindir}/django-admin.py $RPM_BUILD_ROOT%{_bindir}/django-admin
  60. # install man pages
  61. %__mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  62. %__cp -p docs/man/* $RPM_BUILD_ROOT%{_mandir}/man1/
  63. # Handling locale files
  64. # This is adapted from the %%find_lang macro, which cannot be directly
  65. # used since Django locale files are not located in %%{_datadir}
  66. #
  67. # The rest of the packaging guideline still apply -- do not list
  68. # locale files by hand!
  69. %__rm -f %{name}.lang
  70. (cd $RPM_BUILD_ROOT && find . -name 'django*.mo') | %{__sed} -e 's|^.||' | %{__sed} -e \
  71. 's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
  72. >> %{name}.lang
  73. find $RPM_BUILD_ROOT -name "*.po" | xargs %__rm -f
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %files -f %{name}.lang
  77. %defattr(-,root,root,-)
  78. %doc AUTHORS LICENSE README
  79. %{_bindir}/django-admin
  80. %{_mandir}/man1/*
  81. %{python_sitelib}/django/bin/*.py*
  82. %{python_sitelib}/django/bin/profiling/
  83. # Include everything but the locale data ...
  84. %{python_sitelib}/django/db/
  85. %{python_sitelib}/django/*.py*
  86. %{python_sitelib}/django/shortcuts/
  87. %{python_sitelib}/django/utils/
  88. %{python_sitelib}/django/dispatch/
  89. %{python_sitelib}/django/template/
  90. %{python_sitelib}/django/views/
  91. %{python_sitelib}/django/contrib/
  92. %{python_sitelib}/django/forms/
  93. %{python_sitelib}/django/templatetags/
  94. %{python_sitelib}/django/core/
  95. %{python_sitelib}/django/http/
  96. %{python_sitelib}/django/middleware/
  97. %{python_sitelib}/django/test/
  98. %{python_sitelib}/django/conf/*.py*
  99. %{python_sitelib}/django/conf/project_template/*.py*
  100. %{python_sitelib}/django/conf/app_template/
  101. %{python_sitelib}/django/conf/urls/
  102. %{python_sitelib}/django/conf/locale/*/*.py*
  103. %{python_sitelib}/django/conf/locale/*.py*
  104. %{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
  105. %files docs
  106. %defattr(-,root,root,-)
  107. %doc docs/*
  108. %changelog
  109. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-3
  110. - rebuild with VineSeed environment
  111. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-2
  112. - rebuild with python-2.7.2
  113. * Mon May 02 2011 Shu KONNO <owa@bg.wakwak.com> 1.3-1
  114. - updated Django to 1.3
  115. * Wed Feb 16 2011 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
  116. - updated Django to 1.2.5 (include CVE-2011-0696, CVE-2011-0697)
  117. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.3-1
  118. - updated Django to 1.2.3
  119. - dropt Django-hash-compat-13310.patch
  120. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-2
  121. - added simplejson-init.py: removed bundled simplejson, and put the __init__.py
  122. - added Django-hash-compat-13310.patch: http://code.djangoproject.com/changeset/13310 per BZ#601212
  123. - added BR: python-devel python-sphinx
  124. - added RQ: python-simplejson
  125. - removed po files (per BZ#529188)
  126. - install man1
  127. (merged from 'Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - Django-1.2.1-1')
  128. * Sun Aug 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-1
  129. - updated Django to 1.2.1
  130. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
  131. - rebuild with python-2.6
  132. * Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
  133. - updated Django to 1.1.1
  134. * Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
  135. - updated Django to 1.1
  136. - added japanese description
  137. * Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  138. - updated Django to 1.0.2-final
  139. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
  140. - packaged new