python-asn1crypto-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. # Created by pyp2rpm-3.2.2
  2. %global pypi_name asn1crypto
  3. %bcond_without python2
  4. %bcond_without python3
  5. %{!?python3_pkgversion:%global python3_pkgversion 3}
  6. Summary: Fast Python ASN.1 parser and serializer
  7. Name: python-%{pypi_name}
  8. Version: 1.4.0
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: MIT
  14. URL: https://github.com/wbond/asn1crypto
  15. Source0: https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  16. BuildArch: noarch
  17. %if 0%{?with_python2}
  18. BuildRequires: python-rpm-macros
  19. BuildRequires: python-devel
  20. BuildRequires: python-setuptools
  21. %{?python_provide:%python_provide python2-%{pypi_name}}
  22. %endif
  23. %if 0%{?with_python3}
  24. BuildRequires: python%{python3_pkgversion}-rpm-macros
  25. BuildRequires: python%{python3_pkgversion}-devel
  26. BuildRequires: python%{python3_pkgversion}-setuptools
  27. %endif
  28. %description
  29. Fast ASN.1 parser and serializer with definitions for private keys,
  30. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  31. PKCS#12, PKCS#5, X.509 and TSP.
  32. %if 0%{?with_python3}
  33. %package -n python%{python3_pkgversion}-%{pypi_name}
  34. Summary: %{summary}
  35. %{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
  36. %description -n python%{python3_pkgversion}-%{pypi_name}
  37. Fast ASN.1 parser and serializer with definitions for private keys,
  38. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  39. PKCS#12, PKCS#5, X.509 and TSP.
  40. %endif
  41. %prep
  42. %autosetup -n %{pypi_name}-%{version}
  43. # Remove bundled egg-info
  44. rm -rf %{pypi_name}.egg-info
  45. %build
  46. %if 0%{?with_python2}
  47. %py2_build
  48. %endif
  49. %if 0%{?with_python3}
  50. %py3_build
  51. %endif
  52. %install
  53. %if 0%{?with_python2}
  54. %py2_install
  55. %endif
  56. %if 0%{?with_python3}
  57. %py3_install
  58. %endif
  59. %check
  60. # asn1crypto source distribution doesn't come with tests
  61. # {__python2} setup.py test
  62. %if 0%{?with_python3}
  63. # {__python3} setup.py test
  64. %endif
  65. %if 0%{?with_python2}
  66. %files
  67. %license LICENSE
  68. %doc readme* changelog*
  69. %{python2_sitelib}/%{pypi_name}
  70. %{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
  71. %endif
  72. %if 0%{?with_python3}
  73. %files -n python%{python3_pkgversion}-%{pypi_name}
  74. %license LICENSE
  75. %doc readme* changelog*
  76. %{python3_sitelib}/%{pypi_name}
  77. %{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
  78. %endif
  79. %changelog
  80. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.0-1
  81. - new upstream release.
  82. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-6
  83. - initial build for Vine Linux.
  84. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-5
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  86. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-4
  87. - Rebuilt for Python 3.7
  88. * Tue Jun 19 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-3
  89. - Build Python 2 package conditionally
  90. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-2
  91. - Rebuilt for Python 3.7
  92. * Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-1
  93. - New upstream release 0.24.0
  94. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.0-2
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  96. * Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 0.23-1
  97. - New upstream release 0.23.0
  98. * Fri Aug 04 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-5
  99. - Use python2-setuptools, add with_python3
  100. * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-4
  101. - Modernize spec
  102. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  104. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-2
  105. - Address rpmlint issues
  106. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-1
  107. - Initial package.