pyparted-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. Summary: Python module for GNU parted
  2. Summary(ja): parted の python モジュール
  3. Name: pyparted
  4. Version: 3.11.4
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://github.com/dcantrell/pyparted
  11. Source0: https://github.com/dcantrell/pyparted/releases/download/v%{version}/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: python-rpm-macros
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python2-rpm-macros
  17. BuildRequires: python-six
  18. BuildRequires: python3-devel
  19. BuildRequires: python3-setuptools
  20. BuildRequires: python3-rpm-macros
  21. BuildRequires: python3-six
  22. BuildRequires: parted-devel >= 3.2
  23. Requires: parted >= 3.2
  24. %description
  25. Python modules for the parted library. It is used for manipulation
  26. partition tables.
  27. %package -n python3-pyparted
  28. Summary: Python 3 module for GNU parted
  29. Summary(ja): parted の python モジュール
  30. Group: System Environment/Libraries
  31. %description -n python3-pyparted
  32. Python 3 modules for the parted library. It is used for manipulation
  33. partition tables.
  34. %prep
  35. %setup -q
  36. rm -rf %{py3dir}
  37. mkdir -p %{py3dir}
  38. cp -a . %{py3dir}
  39. %build
  40. PYTHON=python make %{?_smp_mflags}
  41. pushd %{py3dir}
  42. PYTHON=python3 make %{?_smp_mflags}
  43. popd
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. PYTHON=python %__make install DESTDIR=$RPM_BUILD_ROOT
  47. pushd %{py3dir}
  48. PYTHON=python3 %__make install DESTDIR=$RPM_BUILD_ROOT
  49. popd
  50. %check
  51. PYTHON=python make test
  52. pushd %{py3dir}
  53. PYTHON=python3 make test
  54. popd
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %files
  58. %defattr(-,root,root,-)
  59. %license COPYING
  60. %doc AUTHORS NEWS README TODO
  61. %{python_sitearch}/parted
  62. %{python_sitearch}/*.egg-info
  63. %{python_sitearch}/*.so
  64. %files -n python3-pyparted
  65. %license COPYING
  66. %doc AUTHORS NEWS README TODO
  67. %{python3_sitearch}/_ped.*.so
  68. %{python3_sitearch}/parted
  69. %{python3_sitearch}/%{name}-%{version}-*.egg-info
  70. %changelog
  71. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.4-1
  72. - new upstream release: the latest version with python2 support.
  73. * Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.2-1
  74. - new upstream release.
  75. - added python3 support.
  76. - imported Patch0 from upstream.
  77. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-4
  78. - rebuild with VineSeed environment
  79. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
  80. - rebuild with parted-3.1
  81. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
  82. - rebuild with python-2.7.2
  83. * Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
  84. - new upstream release
  85. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
  86. - rebuild with parted-2.3
  87. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
  88. - rebuilt with python-2.6.4
  89. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
  90. - new upstream release
  91. - build with parted-1.8.8
  92. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
  93. - rebuilt with python-2.5.2
  94. - added pyexeclib macro
  95. - applied new versioning policy and spec in utf-8
  96. * Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
  97. - rebuilt for VineSeed with parted-1.8.1 and python-2.4
  98. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
  99. - rebuild for python 2.5
  100. * Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
  101. - Rebuild for GNU parted-1.8.1
  102. * Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
  103. - Determine Python version to use in %%build so the source RPM is more
  104. easily moved between distribution releases.
  105. * Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
  106. - Bump version to 1.8.0 and require parted >= 1.8.0
  107. - Remove python-abi Requires line since rpm handles that automatically
  108. * Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
  109. - Include parted/constraint.h in required header files
  110. * Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
  111. - Require parted-1.7.1 or higher
  112. * Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
  113. - Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
  114. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
  115. - rebuild
  116. * Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
  117. - Bump version to 1.7.1 and require parted >= 1.7.1
  118. * Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
  119. - Bump version to 1.7.0 and require parted >= 1.7.0
  120. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  121. - rebuilt
  122. * Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
  123. - rebuild for new parted.
  124. - add debugging options for make so debuginfo isn't useless
  125. * Wed Nov 9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
  126. - rebuild for new parted
  127. * Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
  128. - Rebuilt for new parted library.
  129. * Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
  130. - Updated for gcc4 and python2.4. Fixed build warnings.
  131. * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
  132. - add support for sx8 devices
  133. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
  134. - rebuild for python 2.4
  135. * Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
  136. - #135100 req python-abi (Robert Scheck)
  137. * Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
  138. - update for new parted ABI
  139. - device -> heads, sectors, cylinders now refer to the bios geometry
  140. - require parted >= 1.6.12
  141. * Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
  142. - build on ppc64 again
  143. * Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
  144. - fix build for newer versions of gcc (fix from Jeff Law)
  145. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
  146. - fix PARTITION_PROTECTED definition (#118451)
  147. * Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
  148. - Initial build split out into separate source from the parted package.
  149. - Don't build on ppc64 right now due to parted build problems (#118183)