pylint-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201
  1. Name: pylint
  2. Version: 1.0.0
  3. Release: 1%{?_dist_release}
  4. Summary: Analyzes Python code looking for bugs and signs of poor quality
  5. Group: Development/Debuggers
  6. License: GPLv2+
  7. URL: http://www.logilab.org/projects/pylint
  8. Source0: ftp://ftp.logilab.org/pub/pylint/pylint-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  11. BuildRequires: python-devel python-setuptools python-unittest2
  12. BuildRequires: python-logilab-astng >= 0.22.0
  13. Requires: python-logilab-astng >= 0.22.0
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. Pylint is a python tool that checks if a module satisfy a coding standard.
  18. Pylint can be seen as another PyChecker since nearly all tests you can do
  19. with PyChecker can also be done with Pylint. But Pylint offers some more
  20. features, like checking line-code's length, checking if variable names are
  21. well-formed according to your coding standard, or checking if declared
  22. interfaces are truly implemented, and much more. The big advantage with
  23. Pylint is that it is highly configurable, customizable, and you can easily
  24. write a small plugin to add a personal feature.
  25. %package gui
  26. Summary: Graphical Interface tool for Pylint
  27. Group: Development/Debuggers
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: tkinter
  30. %description gui
  31. This package provides a gui tool for pylint written in tkinter.
  32. %prep
  33. %setup -q
  34. %build
  35. %{__python} setup.py build
  36. %install
  37. rm -rf $RPM_BUILD_ROOT
  38. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  39. rm -rf $RPM_BUILD_ROOT%{_python_sitelib}/pylint/test
  40. mkdir -pm 755 $RPM_BUILD_ROOT%{_mandir}/man1
  41. install -pm 644 man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  42. %clean
  43. rm -rf $RPM_BUILD_ROOT
  44. %files
  45. %defattr(-,root,root,-)
  46. %doc README ChangeLog examples elisp COPYING
  47. %{python_sitelib}/pylint*
  48. %{_bindir}/*
  49. %{_mandir}/man?/*
  50. %exclude %{python_sitelib}/pylint/gui.py*
  51. %exclude %{_bindir}/pylint-gui
  52. %files gui
  53. %defattr(-,root,root,-)
  54. %doc COPYING
  55. %{python_sitelib}/pylint/gui.py*
  56. %{_bindir}/pylint-gui
  57. %changelog
  58. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  59. - new upstream release
  60. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25.1-1
  61. - initial build for Vine Linux
  62. * Wed Mar 14 2012 Brian C. Lane <bcl@redhat.com> 0.25.1-1
  63. - Upstream 0.25.1
  64. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-2
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  66. * Fri Nov 18 2011 Brian C. Lane <bcl@redhat.com> - 0.25.0-1
  67. - Upstream 0.25.0
  68. * Fri Jul 29 2011 Brian C. Lane <bcl@redhat.com> - 0.24.0-1
  69. - Upstream 0.24.0
  70. * Mon Mar 28 2011 Brian C. Lane <bcl@redhat.com> - 0.23-0.1
  71. - Upstream 0.23.0
  72. - Add unit tests to spec
  73. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22.0-3
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  75. * Mon Dec 06 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-2
  76. - Add version to requirement for python-logilab-astng so that updates will
  77. work correctly.
  78. * Mon Nov 29 2010 Brian C. Lane <bcl@redhat.com> - 0.22.0-1
  79. - Upstream 0.22.0
  80. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.21.1-2
  81. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  82. * Thu Jul 08 2010 Brian C. Lane <bcl@redhat.com> - 0.21.1-1
  83. - Upstream 0.21.1
  84. - Removed patch for 500272, fixed upstream - http://www.logilab.org/ticket/22962
  85. * Mon Apr 05 2010 Brian C. Lane <bcl@redhat.com> - 0.20.0-2
  86. - Added patch for bug 500272 (exception with --disable-msg-cat)
  87. * Fri Mar 26 2010 Brian C.Lane <bcl@redhat.com> - 0.20.0-1
  88. - Upstream 0.20.0
  89. - Added python-setuptools to BuildRequires
  90. * Sun Aug 30 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.1-1
  91. - Upstream 0.18.1 (bugfixes and small enhancements)
  92. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18.0-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  94. * Wed Jun 17 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.18.0-1
  95. - Upstream 0.18.0 (bugfixes and minor feature updates)
  96. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.0-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  98. * Wed Jan 28 2009 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.16.0-1
  99. - Upstream 0.16.0
  100. * Tue Dec 30 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.15.2-1
  101. - Upstream 0.15.2
  102. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.14.0-2
  103. - Rebuild for Python 2.6
  104. * Thu Jan 17 2008 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.14.0-1
  105. - Upstream 0.14.0
  106. - Package the .egg-info files.
  107. * Mon Dec 24 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.2-1
  108. - Upstream 0.13.2
  109. - Adjust license to a more precise version
  110. - Fix docs to be valid utf-8
  111. * Sun Apr 01 2007 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.13.1-1
  112. - Upstream 0.13.1
  113. * Sun Dec 17 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.2-1
  114. - Upstream 0.12.2
  115. - Add COPYING to -gui
  116. * Tue Sep 26 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.12.1-1
  117. - Upstream 0.12.1
  118. - Require the renamed python-logilab-astng
  119. * Mon May 01 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.11.0-0
  120. - Version 0.11.0
  121. * Sun Mar 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.10.0-1
  122. - Version 0.10.0
  123. * Thu Jan 12 2006 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.9.0-1
  124. - Version 0.9.0
  125. - Add COPYING to docs
  126. * Sun Nov 13 2005 Konstantin Ryabitsev <icon@fedoraproject.org> - 0.8.1-1
  127. - Version 0.8.1
  128. - Add dependency on python-astng
  129. - Drop artificial version requirement on python-logilab-common
  130. * Mon Jun 13 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.7.0-1
  131. - Version 0.7.0
  132. - No longer in the logilab subdir
  133. - Disttagging
  134. * Mon May 09 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-4
  135. - Install the pylint.1 manfile.
  136. - Add examples and elisp dirs to docs.
  137. * Thu May 05 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-3
  138. - Only doc the .txt files.
  139. - Don't buildrequire python-logilab-common
  140. - Fix paths.
  141. * Tue Apr 26 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-2
  142. - Ghost .pyo files.
  143. - Remove the test dir, as it doesn't do anything.
  144. - Separate the gui package, which depends on tkinter.
  145. - Don't own site-packages/logilab, which is owned by
  146. python-logilab-common.
  147. * Fri Apr 22 2005 Konstantin Ryabitsev <icon@linux.duke.edu> - 0.6.4-1
  148. - Initial packaging.