pygtk2-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
  3. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  4. Summary: Python bindings for the GTK+ widget set.
  5. Summary(ja): GTK+ ウィジットセットの Python 実装
  6. Name: pygtk2
  7. Version: 2.24.0
  8. Release: 4%{?_dist_release}
  9. Group: Development/Languages
  10. License: LGPLv2
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Buildrequires: python-devel >= 2.5
  14. Buildrequires: libglade2-devel >= 2.5.0
  15. BuildRequires: gtk2-devel >= 2.16.0
  16. BuildRequires: pygobject-devel >= 2.16.0
  17. BuildRequires: pycairo-devel >= 1.8.2
  18. BuildRequires: python-numeric
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: libxslt
  21. Buildrequires: automake >= 1.6.3-5
  22. Requires: pygobject
  23. Requires: pycairo
  24. Requires: python-numeric
  25. Obsoletes: pygtk
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. PyGTK is an extension module for python that gives you access to the GTK+
  30. widget set. Just about anything you can write in C with GTK+ you can write
  31. in python with PyGTK (within reason), but with all the benefits of python.
  32. %description -l ja
  33. PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
  34. です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
  35. けます。 python のおかげでもあります。
  36. %package libglade
  37. Summary: A wrapper for the libglade library for use with PyGTK
  38. Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
  39. Group: Development/Libraries
  40. Requires: pygtk2 = %{version}
  41. %description libglade
  42. This module contains a wrapper for the libglade library. Libglade allows
  43. a program to construct its user interface from an XML description, which
  44. allows the programmer to keep the UI and program logic separate.
  45. %description -l ja libglade
  46. このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
  47. プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
  48. ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
  49. %package devel
  50. Summary: files needed to build wrappers for GTK+ addon libraries
  51. Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
  52. Group: Development/Libraries
  53. Requires: pygtk2 = %{version}
  54. Requires: pygobject-devel >= 2.12.0
  55. Requires: gtk2-devel
  56. %description devel
  57. This package contains files required to build wrappers for GTK+ addon
  58. libraries so that they interoperate with pygtk.
  59. %description -l ja devel
  60. このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
  61. みます。これらは PyGTK との仲介をします。
  62. %prep
  63. %setup -q -n pygtk-%{version}
  64. %build
  65. [ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
  66. #aclocal && automake && autoconf
  67. %configure --enable-thread --enable-numpy
  68. export tagname=CC
  69. make LIBTOOL=/usr/bin/libtool
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. export tagname=CC
  73. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
  74. find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %files
  78. %defattr(-,root,root)
  79. %doc AUTHORS NEWS README MAPPING ChangeLog
  80. %doc examples
  81. %dir %{python_sitearch}/gtk-2.0
  82. %dir %{python_sitearch}/gtk-2.0/gtk
  83. %{python_sitearch}/gtk-2.0/gtk/*.py*
  84. %dir %{_libdir}/pygtk
  85. %dir %{_libdir}/pygtk/2.0
  86. %{_libdir}/pygtk/2.0/*
  87. %{_bindir}/pygtk-demo
  88. %{python_sitearch}/gtk-2.0/atk.so
  89. %{python_sitearch}/gtk-2.0/pango.so
  90. %{python_sitearch}/gtk-2.0/gtk/_gtk.so
  91. %{python_sitearch}/gtk-2.0/gtkunixprint.so
  92. %{python_sitearch}/gtk-2.0/pangocairo.so
  93. %if %{buildglade}
  94. %files libglade
  95. %defattr(-,root,root,-)
  96. %{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
  97. %endif
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %dir %{_includedir}/pygtk-2.0
  101. %dir %{_includedir}/pygtk-2.0/pygtk
  102. %{_includedir}/pygtk-2.0/pygtk/*.h
  103. %{_libdir}/pkgconfig/pygtk-2.0.pc
  104. %dir %{_datadir}/pygtk
  105. %dir %{_datadir}/pygtk/2.0
  106. %dir %{_datadir}/pygtk/2.0/defs
  107. %{_datadir}/pygtk/2.0/defs/*.defs
  108. %{_datadir}/pygtk/2.0/defs/pangocairo.override
  109. %{_datadir}/gtk-doc/html/pygtk
  110. %{_bindir}/pygtk-codegen-2.0
  111. %changelog
  112. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-4
  113. - fix spec file
  114. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-3
  115. - rebuild with VineSeed environment
  116. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-2
  117. - rebuild with python-2.7.2
  118. * Tue Jun 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  119. - new upstream release
  120. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-2
  121. - add Requires: gtk2-devel (-devel package)
  122. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  123. - new upstream release
  124. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  125. - new upstream release
  126. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  127. - new upstream release
  128. - rebuild with python-2.6
  129. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  130. - new upstream release
  131. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
  132. - rebuilt with python-2.5.2
  133. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
  134. - rebuilt with python-2.4.5
  135. - used %%{?_dist_release} macro
  136. * Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
  137. - new upstream release
  138. * Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
  139. - new upstream release
  140. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
  141. - new upstream release
  142. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
  143. - added Requires pygobject-devel to devel package
  144. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
  145. - new upstream release
  146. - add Requires/BuildRequires pygobject,pycairo
  147. * Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
  148. - new upstream release 2.8.6
  149. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
  150. - new upstream release 2.8.4
  151. - added japanese summary and description
  152. * Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
  153. - new upstream release 2.8.2
  154. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  155. - new upstream release 2.8.1
  156. - added %clean sectioin
  157. * Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
  158. - new upstream release 2.8.0
  159. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
  160. - new upstream release 2.6.1
  161. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
  162. - rebuild with python-2.4.1-0vl1
  163. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  164. - new upstream release
  165. * Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
  166. - updated to 2.2.0
  167. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
  168. - rebuild with python-2.3.3-0vl1
  169. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
  170. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  171. * Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
  172. - added missing %%defattr
  173. * Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
  174. - added Provides and Obsoletes pygtk
  175. * Tue Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
  176. - new upstream release (based on Redhat Rawhide 2.0.0-1)
  177. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
  178. - Fix libtool
  179. * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
  180. - part of the fixnew patch wasn't applied upstream, apply it (#99400)
  181. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
  182. - new upstream release
  183. - build for Vine Linux
  184. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  185. - rebuild for multilib
  186. - use %%configure
  187. * Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
  188. - fix pixbuf leaks (#72137)
  189. - five more pixbuf leaks plugged
  190. * Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
  191. - remover Packager tag
  192. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  193. - add binding for gdk_atom_intern
  194. * Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
  195. - 0.99.12
  196. * Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
  197. - new version from CVS
  198. * Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
  199. - Fix bug #65770.
  200. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  201. - automated rebuild
  202. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  203. - new version from CVS
  204. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  205. - automated rebuild
  206. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  207. - 1.99.10
  208. * Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
  209. - 1.99.8
  210. * Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
  211. - added atkmodule.so to file list
  212. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  213. - fix devel filelist to match new header location
  214. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  215. - get the headers from their new version-specific location
  216. * Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
  217. - fixed typo in devel filelist
  218. - added macro that tests to see if we have libglade2, make the
  219. filelist a condition of that
  220. - changed name to 'pygtk2' to avoid name conflict with pygtk