pygame-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. Name: pygame
  3. Version: 1.9.1
  4. Release: 3%{?_dist_release}
  5. Summary: Python modules for writing games
  6. Summary(ja): ゲームを書くための Python モジュール
  7. Group: Development/Languages
  8. License: LGPLv2+
  9. URL: http://www.pygame.org
  10. Source0: http://pygame.org/ftp/%{name}-%{version}release.tar.gz
  11. Patch0: %{name}-1.9.1-config.patch
  12. # porttime is part of libportmidi.so, there's no libporttime in Fedora
  13. Patch1: pygame-1.9.1-porttime.patch
  14. Patch2: pygame-1.9.1-no-test-install.patch
  15. # patch backported from upstream repository, V4L has been remove in linux-2.6.38
  16. # http://svn.seul.org/viewcvs/viewvc.cgi?view=rev&root=PyGame&revision=3077
  17. Patch3: pygame-remove-v4l.patch
  18. Patch4: MMX.diff
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: python-devel numpy
  21. BuildRequires: SDL_image-devel SDL_mixer-devel SDL_ttf-devel
  22. BuildRequires: SDL-devel
  23. BuildRequires: libpng-devel libjpeg-turbo-devel libX11-devel smpeg-devel
  24. #BuildRequires: portmidi-devel
  25. Requires: numpy
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. Pygame is a set of Python modules designed for writing games. It is
  30. written on top of the excellent SDL library. This allows you to create
  31. fully featured games and multimedia programs in the python language.
  32. Pygame is highly portable and runs on nearly every platform and
  33. operating system.
  34. %package devel
  35. Summary: Files needed for developing programs which use pygame
  36. Summary(ja): pygame を使用するプログラム開発に必要なファイル
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: SDL_ttf-devel SDL_mixer-devel
  40. Requires: python-devel
  41. %description devel
  42. This package contains headers required to build applications that use
  43. pygame.
  44. %prep
  45. %setup -qn %{name}-%{version}release
  46. %patch0 -p1
  47. %patch1 -p1
  48. %patch2 -p1
  49. %patch3 -p1
  50. %patch4 -p1
  51. # rpmlint fixes
  52. find examples/ -type f -print0 | xargs -0 chmod -x
  53. find docs/ -type f -print0 | xargs -0 chmod -x
  54. find src/ -type f -name '*.h' -print0 | xargs -0 chmod -x
  55. chmod -x README.txt WHATSNEW
  56. iconv -f iso8859-1 -t utf-8 WHATSNEW > WHATSNEW.conv && mv -f WHATSNEW.conv WHATSNEW
  57. iconv -f iso8859-1 -t utf-8 README.txt > README.txt.conv && mv -f README.txt.conv README.txt
  58. # These files must be provided by pygame-nonfree(-devel) packages on a
  59. # repository that does not have restrictions on providing non-free software
  60. rm -f src/ffmovie.[ch]
  61. %build
  62. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  66. # Fix permissions
  67. chmod 755 $RPM_BUILD_ROOT%{python_sitearch}/%{name}/*.so
  68. %check
  69. # base_test fails in mock, unable to find soundcard
  70. PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/base_test.py || :
  71. PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/image_test.py
  72. PYTHONPATH="$RPM_BUILD_ROOT%{python_sitearch}" %{__python} test/rect_test.py
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root,-)
  77. %doc docs/ README.txt WHATSNEW
  78. #%dir %{python_sitearch}/%{name}
  79. %{python_sitearch}/%{name}*
  80. %files devel
  81. %defattr(-,root,root,-)
  82. %doc examples/
  83. %dir %{_includedir}/python*/%{name}
  84. %{_includedir}/python*/%{name}/*.h
  85. %changelog
  86. * Fri Jul 18 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.1-3
  87. - rebuilt with libpng-1.6.12
  88. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.9.1-2
  89. - rebuild with VineSeed environment
  90. * Fri Jul 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.1-1
  91. - initial build for VineSeed
  92. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-8
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  94. * Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.9.1-7
  95. - Rebuild for new libpng
  96. * Thu Jun 23 2011 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-6
  97. - Removed V4L support because V4L has been deprecated from the Linux
  98. kernel as of 2.6.38
  99. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  101. * Mon Aug 16 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-4
  102. - fix #607753 - Do not install tests
  103. * Thu Aug 12 2010 Jan Kaluza <jkaluza@redhat.com> - 1.9.1-3
  104. - fix #585526 - add MIDI support
  105. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.9.1-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  107. * Thu Oct 08 2009 Jon Ciesla <limb@jcomserv.net> - 1.9.1-1
  108. - New upstream release, BZ 526365.
  109. - Updated config_unix patch for 1.9.1.
  110. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-7
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  112. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-6
  113. - Dropped f2py deps, unneeded now that numpy is fixed: BZ 496277.
  114. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.8.1-5
  115. - Add dep for numpy-f2py to fix broken games, BZ 496218.
  116. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-4
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  118. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.8.1-3
  119. - Rebuild for Python 2.6
  120. * Wed Sep 17 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-2
  121. - Bump release to trump F9 version.
  122. * Tue Aug 26 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.1-1
  123. - Update to new upstream version.
  124. - rpmlint fixes
  125. * Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-3
  126. - Rebase config patch for 1.8.0
  127. - Need to specify BR: SDL-devel
  128. * Mon Aug 25 2008 Robin Norwood <robin.norwood@gmail.com> 1.8.0-2
  129. - Change from requiring python-numeric to numpy
  130. - rhbz#457074
  131. * Thu May 22 2008 Christopher Stone <chris.stone@gmail.com> 1.8.0-1
  132. - Upstream sync
  133. - Remove Obsolets/Provides (been around since FC-4)
  134. - Remove no longer needed 64bit patch
  135. - Remove %%{version} macro from Patch0 definition
  136. - Add png, jpeg, and X11 libraries to BuildRequires
  137. - Simplify %%files section
  138. - Fix up some rpmlint warnings
  139. * Thu Feb 21 2008 Christopher Stone <chris.stone@gmail.com> 1.7.1-16
  140. - Add egginfo file to %%files
  141. - Update %%license
  142. - Fix permissions on .so files
  143. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.7.1-15
  144. - Autorebuild for GCC 4.3
  145. * Tue May 15 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-14
  146. - Add one more bit to 64-bit patch
  147. * Sat May 12 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-13
  148. - Apply 64-bit patch for python 2.5 (bz #239899)
  149. - Some minor spec file cleanups
  150. * Mon Apr 23 2007 Christopher Stone <chris.stone@gmail.com> 1.7.1-12
  151. - Revert back to version 1.7.1-9
  152. * Mon Dec 11 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-11
  153. - Remove all Obsolete/Provides
  154. - Remove Requires on all devel packages
  155. * Sun Dec 10 2006 Christopher Stone <chris.stone@gmail.som> 1.7.1-10
  156. - Remove macosx examples
  157. - Move header files into main package
  158. - Move examples into examples subpackage
  159. - python(abi) = 0:2.5
  160. * Wed Sep 06 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-9
  161. - No longer %%ghost pyo files. Bug #205396
  162. * Sat Sep 02 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-8
  163. - FC6 Rebuild
  164. * Wed Jun 28 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7.fc6.1
  165. - Rebuild bump
  166. * Wed May 03 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-7
  167. - Fix Obsolete/Provides of python-pygame-doc
  168. * Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-6
  169. - Bump release for new build on devel
  170. * Wed Apr 26 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-5
  171. - Add Obsolete/Provides tags for python-pygame-docs
  172. - Add Obsolete/Provides tags for python-pygame-devel to devel package
  173. - Hopefully this fixes Bugzilla bug #189991
  174. * Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-4
  175. - Add Requires to -devel package
  176. - Remove ffmovie.h from -devel package since it requires smpeg-devel
  177. * Fri Apr 21 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-3
  178. - Obsolete linva python-pygame package
  179. - Added Provides for python-pygame
  180. - Fix equal sign in devel requires
  181. * Thu Apr 20 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-2
  182. - Added a patch to clean up some warnings on 64 bit compiles
  183. * Tue Apr 18 2006 Christopher Stone <chris.stone@gmail.com> 1.7.1-1
  184. - Initial RPM release