pyOpenSSL-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259
  1. %define pkg_release 1%{?_dist_release}
  2. Summary: Python wrapper module around the OpenSSL library
  3. Summary(ja): OpenSSL ライブラリの Python ラッパーモジュール
  4. Name: pyOpenSSL
  5. Version: 18.0.0
  6. Release: %{pkg_release}
  7. Source0: https://files.pythonhosted.org/packages/source/p/pyOpenSSL/pyOpenSSL-%{version}.tar.gz
  8. License: LGPLv2+
  9. Group: Development/Libraries
  10. URL: https://pyopenssl.readthedocs.org/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: openssl-devel
  16. BuildRequires: python-devel
  17. BuildRequires: python3-devel
  18. BuildRequires: python-rpm-macros
  19. BuildRequires: python3-rpm-macros
  20. BuildRequires: python-setuptools
  21. BuildRequires: python3-setuptools
  22. BuildRequires: python-cryptography
  23. BuildRequires: python3-cryptography
  24. #BuildRequires: latex2html
  25. %description
  26. High-level wrapper around a subset of the OpenSSL library, includes
  27. * SSL.Connection objects, wrapping the methods of Python's portable
  28. sockets
  29. * Callbacks written in Python
  30. * Extensive error-handling mechanism, mirroring OpenSSL's error codes
  31. ... and much more ;)
  32. %package -n python-pyOpenSSL
  33. Summary: Python2 wrapper module around the OpenSSL library
  34. Obsoletes: pyOpenSSL < %{version}-%{release}
  35. Provides: pyOpenSSL = %{version}-%{release}
  36. Requires: python-cryptography
  37. %{?python_provide:%python_provide python-pyOpenSSL}
  38. %description -n python-pyOpenSSL
  39. High-level wrapper around a subset of the OpenSSL library, includes among others
  40. * SSL.Connection objects, wrapping the methods of Python's portable
  41. sockets
  42. * Callbacks written in Python
  43. * Extensive error-handling mechanism, mirroring OpenSSL's error codes
  44. %package -n python3-pyOpenSSL
  45. Summary: Python 3 wrapper module around the OpenSSL library
  46. Requires: python3-cryptography
  47. %{?python_provide:%python_provide python3-pyOpenSSL}
  48. %description -n python3-pyOpenSSL
  49. High-level wrapper around a subset of the OpenSSL library, includes among others
  50. * SSL.Connection objects, wrapping the methods of Python's portable
  51. sockets
  52. * Callbacks written in Python
  53. * Extensive error-handling mechanism, mirroring OpenSSL's error codes
  54. %prep
  55. %setup -q
  56. %build
  57. %py_build
  58. %py3_build
  59. %install
  60. %{__rm} -rf %{buildroot}
  61. %py_install
  62. %py3_install
  63. %clean
  64. %{__rm} -rf %{buildroot}
  65. %files -n python-pyOpenSSL
  66. %license LICENSE
  67. %doc README* CHANGELOG*
  68. %{python_sitelib}/OpenSSL/
  69. %{python_sitelib}/pyOpenSSL-*.egg-info
  70. %files -n python3-pyOpenSSL
  71. %license LICENSE
  72. %doc README* CHANGELOG*
  73. %{python3_sitelib}/OpenSSL/
  74. %{python3_sitelib}/pyOpenSSL-*.egg-info
  75. %changelog
  76. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 18.0.0-1
  77. - new upstream release.
  78. - dropped Patch2-3.
  79. - changed name to python{,3}-pyOpenSSL.
  80. - added python3 support.
  81. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  82. - new upstream release
  83. - remove Patch0 (pyOpenSSL-0.7-openssl.patch)
  84. - remove Patch4 (pyOpenSSL-threadsafe.patch)
  85. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-4
  86. - rebuild with python-2.7.2
  87. * Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7-3
  88. - rebuilt with openssl-1.0.0c
  89. - remove BuildRequires: tetex
  90. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.7-2
  91. - rebuilt with python-2.6.4
  92. * Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.7-1
  93. - initial build for Vine Linux based on fedora package
  94. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7-3
  95. - Rebuild for Python 2.6
  96. * Fri Sep 19 2008 Dennis Gilmore <dennis@ausil.us> - 0.7-2
  97. - update threadsafe patch
  98. - bug#462807
  99. * Mon Sep 15 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 0.7-1
  100. - bump to new release
  101. - the inevitable patch fixes
  102. * Wed Mar 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6-4
  103. - fix horrific release tag
  104. - fix license tag
  105. - add egg-info
  106. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6-3.p24.9
  107. - Autorebuild for GCC 4.3
  108. * Wed Dec 5 2007 Jeremy Katz <katzj@redhat.com> - 0.6-2.p24.9
  109. - rebuild for new openssl
  110. * Mon Dec 11 2006 Paul Howarth <paul@city-fan.org> - 0.6-1.p24.9
  111. - add missing buildreq latex2html, needed to build HTML docs
  112. - rewrite to be more in line with Fedora python spec template and use
  113. %%{python_sitearch} rather than a script-generated %%files list
  114. - package is not relocatable - drop Prefix: tag
  115. - buildreq perl not necessary
  116. - fix permissions for files going into debuginfo package
  117. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.8
  118. - rebuild for python 2.5
  119. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.2
  120. - rebuild
  121. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2.1
  122. - bump again for double-long bug on ppc(64)
  123. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6-1.p24.7.2
  124. - rebuilt for new gcc4.1 snapshot and glibc changes
  125. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  126. - rebuilt
  127. * Wed Nov 9 2005 Mihai Ibanescu <misa@redhat.com> - 0.6-1.p24.7
  128. - rebuilt against newer openssl
  129. * Wed Aug 24 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1.p24.6
  130. - add dcbw's patch to fix some threading problems
  131. * Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 0.6-1.p24.5
  132. - current rpm creates .pyo files, include them in filelist
  133. * Thu Mar 17 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.4
  134. - rebuilt
  135. * Mon Mar 14 2005 Mihai Ibanescu <misa@redhat.com> 0.6-1.p24.3
  136. - rebuilt
  137. * Mon Mar 7 2005 Tomas Mraz <tmraz@redhat.com> 0.6-1.p23.2
  138. - rebuild with openssl-0.9.7e
  139. * Tue Nov 9 2004 Nalin Dahyabhai <nalin@redhat.com> 0.6-1.p23.1
  140. - rebuild
  141. * Fri Aug 13 2004 Mihai Ibanescu <misa@redhat.com> 0.6-1
  142. - 0.6 is out
  143. * Tue Aug 10 2004 Mihai Ibanescu <misa@redhat.com> 0.6-0.90.rc1
  144. - release candidate
  145. * Thu Jun 24 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-24
  146. - rebuilt
  147. * Mon Jun 21 2004 Mihai Ibanescu <misa@redhat.com> 0.5.1-23
  148. - rebuilt
  149. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  150. - rebuilt
  151. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  152. - rebuilt
  153. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  154. - rebuilt
  155. * Wed Nov 5 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-20
  156. - rebuilt against python 2.3.2
  157. * Fri Aug 8 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-12
  158. - lynx no longer supported, using elinks instead (patch from
  159. Michael Redinger <michael.redinger@uibk.ac.at>, bug #101947 )
  160. * Wed Jun 4 2003 Elliot Lee <sopwith@redhat.com> 0.5.1-11
  161. - Rebuilt
  162. * Wed Jun 4 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-10.7.x
  163. - Built on 7.x
  164. * Mon Mar 3 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-9
  165. - bug #73967: Added Requires: python
  166. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  167. - rebuilt
  168. * Fri Feb 21 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-7
  169. - bug #84803: Added patch to expose more flags
  170. * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 0.5.1-5
  171. - installing to %%{_libdir}
  172. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  173. - rebuilt
  174. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-3
  175. - rebuild
  176. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  177. - Add -I and -L flags for finding Kerberos headers and libraries, in case
  178. they're referenced
  179. * Tue Dec 3 2002 Mihai Ibanescu <misa@redhat.com>
  180. - Fix for bug 73967: site-packages/OpenSSL not owned by this package
  181. - Adding hacks around the lack of latex2html on ia64
  182. * Tue Sep 24 2002 Mihai Ibanescu <misa@redhat.com>
  183. - 0.5.1
  184. * Thu Aug 29 2002 Mihai Ibanescu <misa@redhat.com>
  185. - Building 0.5.1rc1 with version number 0.5.0.91 (this should also fix the big
  186. error of pushing 0.5pre previously, since it breaks rpm's version comparison
  187. algorithm).
  188. - We use %%{__python}. Too bad I can't pass --define's to distutils.
  189. * Fri Aug 16 2002 Mihai Ibanescu <misa@redhat.com>
  190. - Building 0.5
  191. * Fri Jun 14 2002 Mihai Ibanescu <misa@redhat.com>
  192. - Added documentation