pvm-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318
  1. Summary: Libraries for distributed computing.
  2. Summary(ja): 分散計算ライブラリ
  3. Name: pvm
  4. Version: 3.4.3
  5. Release: 24vl2
  6. License: freely distributable
  7. Group: Development/Libraries
  8. Source0: http://www.netlib.org/pvm3/pvm3.4.3.tgz
  9. Source1: http://www.netlib.org/pvm3/xpvm/XPVM.src.1.2.5.tgz
  10. Source2: xpvm.sh
  11. Source3: pvmd.init
  12. Source4: pvm.sh
  13. Source5: pvm_init.sh
  14. Source6: pvm_init.csh
  15. Source7: xpvm_init.sh
  16. Source8: xpvm_init.csh
  17. Source9: README.RedHat
  18. Patch0: xpvm-tcltk.patch
  19. Patch1: pvm3-vaargfix.patch
  20. Patch2: pvm-s390.patch
  21. URL: http://www.epm.ornl.gov/pvm/pvm_home.html
  22. BuildRoot: %{_tmppath}/pvm-root
  23. Excludearch: ia64
  24. Requires: initscripts >= 5.52, bash >= 2
  25. %package gui
  26. Requires: pvm
  27. Summary: TCL/TK graphical frontend to monitor and manage a PVM cluster.
  28. Summary(ja): PVMクラスタのモニタ・管理のためのTCL/TK グラフィカル・フロントエンド
  29. Group: Applications/System
  30. %description
  31. PVM3 (Parallel Virtual Machine) is a library and daemon that allows
  32. distributed processing environments to be constructed on heterogeneous
  33. machines and architectures.
  34. %description gui
  35. Xpvm is a TCL/TK based tool that allows full manageability of the PVM cluster
  36. as well as the ability to monitor cluster performance.
  37. %prep
  38. %setup -q -T -c -n pvm
  39. cp %SOURCE9 .
  40. chmod 0644 README.RedHat
  41. rm -rf $RPM_BUILD_ROOT
  42. mkdir -p $RPM_BUILD_ROOT/usr/share/
  43. cd $RPM_BUILD_ROOT/usr/share
  44. tar -xzf %{SOURCE0}
  45. cd pvm3
  46. tar -xzf %{SOURCE1}
  47. %patch0 -p0
  48. %patch1 -p1
  49. %patch2 -p1
  50. cp conf/LINUX.def conf/LINUXS390.def
  51. cp conf/LINUX.m4 conf/LINUXS390.m4
  52. %build
  53. PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
  54. PVM_DPATH=$RPM_BUILD_ROOT/usr/share/pvm3/lib/pvmd \
  55. make -C $RPM_BUILD_ROOT/usr/share/pvm3
  56. PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
  57. XPVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3/xpvm \
  58. make -C $RPM_BUILD_ROOT/usr/share/pvm3/xpvm
  59. %install
  60. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,3}
  61. install -m 644 $RPM_BUILD_ROOT/usr/share/pvm3/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
  62. install -m 644 $RPM_BUILD_ROOT/usr/share/pvm3/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
  63. mkdir -p $RPM_BUILD_ROOT/usr/bin
  64. install -m 0755 $RPM_SOURCE_DIR/xpvm.sh $RPM_BUILD_ROOT/usr/bin/xpvm
  65. PVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3 \
  66. XPVM_ROOT=$RPM_BUILD_ROOT/usr/share/pvm3/xpvm \
  67. make -C $RPM_BUILD_ROOT/usr/share/pvm3/xpvm install
  68. strip $RPM_BUILD_ROOT/usr/share/pvm3/bin/*/*
  69. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  70. install -m 0755 $RPM_SOURCE_DIR/pvmd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/pvmd
  71. mkdir -p $RPM_BUILD_ROOT/usr/bin
  72. install -m 0755 $RPM_SOURCE_DIR/pvm.sh $RPM_BUILD_ROOT/usr/bin/pvm
  73. # Move the documentation the directory RPM thinks it's using, so we
  74. # can classify it as documentation files
  75. mv $RPM_BUILD_ROOT/usr/share/pvm3/doc/* $RPM_BUILD_DIR/pvm/
  76. rmdir $RPM_BUILD_ROOT/usr/share/pvm3/doc
  77. # Use /var/run/pvm for state files
  78. mkdir -p $RPM_BUILD_ROOT/var/run/pvm3
  79. # build the file list
  80. find $RPM_BUILD_ROOT -type f -o -type l | \
  81. sed -e "s|$RPM_BUILD_ROOT||g" | \
  82. grep -v -i win32 | \
  83. grep -v "/pvm3/man/man" | \
  84. grep -v "usr/man" | \
  85. grep -v "xpvm" | \
  86. grep -v "example" | \
  87. grep -v "conf/" | \
  88. grep -v "etc/rc.d/init.d" | \
  89. grep -v "\.o$" > files.list
  90. find $RPM_BUILD_ROOT -type f -o -type l | \
  91. sed -e "s|$RPM_BUILD_ROOT||g" | \
  92. grep "conf/LINUX" >> files.list
  93. find $RPM_BUILD_ROOT -type f -o -type l | \
  94. grep example | \
  95. sed -e "s|$RPM_BUILD_ROOT|%doc |g" >> files.list
  96. find $RPM_BUILD_ROOT/usr/share/pvm3 -type d | \
  97. sed -e "s|$RPM_BUILD_ROOT|%dir |g" | \
  98. grep -v "xpvm" >> files.list
  99. # Remove man pages from list
  100. grep -v "%{_mandir}" files.list > files.list2
  101. mv files.list2 files.list
  102. #install init files
  103. mkdir -p $RPM_BUILD_ROOT/etc/profile.d
  104. install -m 755 %SOURCE5 $RPM_BUILD_ROOT/etc/profile.d/pvm.sh
  105. install -m 755 %SOURCE6 $RPM_BUILD_ROOT/etc/profile.d/pvm.csh
  106. install -m 755 %SOURCE7 $RPM_BUILD_ROOT/etc/profile.d/xpvm.sh
  107. install -m 755 %SOURCE8 $RPM_BUILD_ROOT/etc/profile.d/xpvm.csh
  108. #Fix a broken man page
  109. rm $RPM_BUILD_ROOT%{_mandir}/man1/PVM.1
  110. ln -sf pvm_intro.1 $RPM_BUILD_ROOT%{_mandir}/man1/PVM.1
  111. %clean
  112. rm -rf $RPM_BUILD_ROOT
  113. rm -f files.list
  114. %pre
  115. /usr/sbin/groupadd -g 24 -r -f pvm > /dev/null 2>&1 ||:
  116. /usr/sbin/useradd -u 24 -g 24 -d /usr/share/pvm3 -r -s /bin/bash pvm > /dev/null 2>&1 ||:
  117. %preun
  118. if [ $1 -eq 0 ]; then
  119. /sbin/chkconfig --del pvmd
  120. fi
  121. %post
  122. /sbin/chkconfig --add pvmd
  123. %postun
  124. if [ $1 -ge 1 ]; then
  125. service pvmd condrestart >/dev/null 2>&1
  126. fi
  127. if [ $1 = 0 ] ; then
  128. /usr/sbin/userdel pvm > /dev/null 2>&1
  129. fi
  130. %files -f files.list
  131. %defattr(-,root,root)
  132. %config /etc/rc.d/init.d/pvmd
  133. %doc arches bugreport example.pvmrc release-notes README.RedHat
  134. %{_mandir}/*/*
  135. /etc/profile.d/pvm*
  136. %dir %attr(755,pvm,pvm) /var/run/pvm3
  137. %files gui
  138. %defattr(-,root,root)
  139. %dir /usr/share/pvm3/xpvm
  140. /etc/profile.d/xpvm*
  141. /usr/share/pvm3/bin/*/xpvm
  142. /usr/bin/xpvm
  143. /usr/share/pvm3/xpvm/*
  144. %changelog
  145. * Tue Feb 5 2002 Jun Nishii <jun@vinelinux.org> 3.4.3-24vl2
  146. - change version dependency of initscripts
  147. * Thu Jan 31 2002 Jun Nishii <jun@vinelinux.org> 3.4.3-24vl1
  148. - added Japanese summary
  149. * Sat Jan 27 2001 Karsten Hopp <karsten@redhat.de>
  150. - added s390 patch
  151. - FIXME: tmpnam is used at several functions, better
  152. use mkstemp
  153. * Tue Jan 23 2001 Trond Eivind Glomsr <teg@redhat.com>
  154. - change gettextizing
  155. * Wed Jan 17 2001 Trond Eivind Glomsr <teg@redhat.com>
  156. - gettextize
  157. * Fri Oct 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  158. - LINUX isn't LINUX on Alpha, it's LINUXALPHA (#19389)
  159. * Fri Aug 18 2000 Trond Eivind Glomsr <teg@redhat.com>
  160. - add README.RedHat for setup instructions - some
  161. enviroment variables need to be set for pvm to work
  162. * Tue Aug 15 2000 Trond Eivind Glomsr <teg@redhat.com>
  163. - use /var/run/pvm3 for state files (#16217) for a long
  164. and healthy life, uninterrupted by tmpwatch
  165. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  166. - condrestart fixes
  167. * Mon Jul 17 2000 Trond Eivind Glomsr <teg@redhat.com>
  168. - move back to /etc/rc.d/init.d
  169. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  170. - automatic rebuild
  171. * Thu Jul 06 2000 Trond Eivind Glomsr <teg@redhat.com>
  172. - "Prereq:", not "Requires:" for /etc/init.d
  173. * Thu Jul 06 2000 Trond Eivind Glomsr <teg@redhat.com>
  174. - require /etc/init.d
  175. * Mon Jun 26 2000 Trond Eivind Glomsr <teg@redhat.com>
  176. - really move the initscript, not just the paths inside it
  177. * Mon Jun 26 2000 Trond Eivind Glomsr <teg@redhat.com>
  178. - add conditional restart to initscripts and specfile
  179. - move initscript to /etc/init.d
  180. * Wed Jun 14 2000 Trond Eivind Glomsr <teg@redhat.com>
  181. - Added patch to make compile with new tool chain
  182. - use %%{_tmppath}, %%{_mandir}
  183. * Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  184. - added handling of arguments to pvm.sh/xpvm.sh
  185. * Fri Apr 28 2000 Trond Eivind Glomsr <teg@redhat.com>
  186. - added some extra initialization
  187. - removed gzipping - handled automatically
  188. * Thu Apr 27 2000 Trond Eivind Glomsr <teg@redhat.com>
  189. - added URL
  190. - changed source location - use netlib
  191. - fix location of documentation files
  192. * Mon Apr 17 2000 Trond Eivind Glomsr <teg@redhat.com>
  193. - fixed a problem with the PVM man page
  194. - gzip the man pages
  195. - should now be able to compile with several tcl/tk versions
  196. without problems
  197. * Mon Mar 06 2000 Mike Wangsmo <wanger@redhat.com>
  198. - fixed the useradd failure mode when user already exists
  199. - finally, the init script seems to behave nicely as user pvm
  200. * Sun Mar 05 2000 Mike Wangsmo <wanger@redhat.com>
  201. - fixed quirk in init script to allow PVMD_NOHOLD=ON to be honored
  202. * Fri Feb 18 2000 Mike Wangsmo <wanger@redhat.com>
  203. - added env. variable to make pvmd background when started
  204. - fixed init script killproc errors
  205. - moved to 3.4.3 proper
  206. * Tue Feb 15 2000 Mike Wangsmo <wanger@redhat.com>
  207. - fixed up some group ID stuff
  208. * Mon Feb 14 2000 Mike Wangsmo <wanger@redhat.com>
  209. - added pvm user to package
  210. * Wed Feb 09 2000 Mike Wangsmo <wanger@redhat.com>
  211. - added sparc64 identifier to pvmgetarch
  212. - configured pvmd within the init script to run as user pvm
  213. * Sat Feb 05 2000 Mike Wangsmo <wanger@redhat.com>
  214. - changed pvm-gui group
  215. - set chkconfig to be off in all run levels as the default
  216. * Thu Feb 04 2000 Mike Wangsmo <wanger@redhat.com>
  217. - added sysV init script
  218. - added a shell wrapper in /usr/bin for the pvm shell
  219. - moved up to 3.4.2pl4
  220. * Wed Feb 02 2000 Mike Wangsmo <wanger@redhat.com>
  221. - added some missing files for xpvm to work
  222. * Mon Jan 24 2000 Mike Wangsmo <wanger@redhat.com>
  223. - dropped all non-linux stuff
  224. - split the packages up
  225. - added xpvm
  226. - "fixed" Sparc
  227. * Mon Nov 29 1999 Tim Powers <timp@redhat.com>
  228. - updated to 3.4.2
  229. * Sun Sep 5 1999 Tim Powers <timp@redhat.com>
  230. - excludearch sparc
  231. * Wed Jul 28 1999 Tim Powers <timp@redhat.com>
  232. - update to 3.4.1
  233. - comment out the patches in %prep section, will test, if it works then it
  234. stays commented
  235. * Wed May 05 1999 Bill Nottingham <notting@redhat.com>
  236. - update to 3.4.0 final
  237. * Tue Oct 27 1998 Cristian Gafton <gafton@redhat.com>
  238. - added a patch for the SIGCLD -> SIGCHLD rename
  239. - fixed the incredibly stupid spec file to have a much shorter %files list
  240. * Tue Oct 12 1998 Michael Maher <mike@redhat.com>
  241. - updated pacakge for 5.2 powertools.
  242. * Sat Jun 06 1998 Michael Maher <mike@redhat.com>
  243. - updated source
  244. - changed spec file for all archs
  245. * Wed Dec 03 1997 Mike Wangsmo <wanger@redhat.com>
  246. - fixed patches to cleanly build on glibc
  247. - corrected alpha inuendos
  248. * Wed Dec 3 1997 Otto Hammersmith <otto@redhat.com>
  249. - snagged Wanger's package.
  250. - moved buildroot from /var/tmp to /var/tmp/pvm-root