pth-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181
  1. Summary: The GNU Portable Threads library
  2. Summary(ja): GNU ポータブルスレッドライブラリ
  3. Name: pth
  4. Version: 2.0.7
  5. Release: 9%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://www.gnu.org/software/pth/
  9. Source: ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz
  10. Source1: ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz.sig
  11. Patch1: pth-2.0.7-dont-remove-gcc-g.patch
  12. Patch2: pth-2.0.7-config-script.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. %description
  15. Pth is a very portable POSIX/ANSI-C based library for Unix platforms
  16. which provides non-preemptive priority-based scheduling for multiple
  17. threads of execution ("multithreading") inside server applications.
  18. All threads run in the same address space of the server application,
  19. but each thread has it's own individual program-counter, run-time
  20. stack, signal mask and errno variable.
  21. %package devel
  22. Summary: Development headers and libraries for GNU Pth
  23. Summary(ja): GNU Pth の開発用ヘッダファイル及びライブラリ
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. Development headers and libraries for GNU Pth.
  28. %prep
  29. %setup -q
  30. %patch1 -p1 -b .dont-remove-gcc-g
  31. %patch2 -p1 -b .config-script
  32. %build
  33. %configure --disable-static ac_cv_func_sigstack='no'
  34. # Work around multiarch conflicts in the pth-config script in order
  35. # to complete patch2. Make the script choose between /usr/lib and
  36. # /usr/lib64 at run-time.
  37. if [ "%_libdir" == "/usr/lib64" ] ; then
  38. if grep -e '^pth_libdir="/usr/lib64"' pth-config ; then
  39. sed -i -e 's!^pth_libdir="/usr/lib64"!pth_libdir="/usr/lib"!' pth-config
  40. else
  41. echo "ERROR: Revisit the multiarch pth_libdir fixes for pth-config!"
  42. exit 1
  43. fi
  44. fi
  45. if grep -e "$RPM_OPT_FLAGS" pth-config ; then
  46. # Remove our extra CFLAGS from the pth-config script, since they
  47. # don't belong in there.
  48. sed -i -e "s!$RPM_OPT_FLAGS!!g" pth-config
  49. else
  50. echo "ERROR: Revisit the multiarch CFLAGS fix for pth-config!"
  51. exit 1
  52. fi
  53. # this is necessary; without it make -j fails
  54. make pth_p.h
  55. make %{?_smp_mflags}
  56. %check
  57. make test
  58. l=$($(pwd)/pth-config --libdir)
  59. %ifarch x86_64 ppc64
  60. [ "$l" == "/usr/lib64" ]
  61. %endif
  62. %install
  63. rm -rf $RPM_BUILD_ROOT
  64. make DESTDIR=${RPM_BUILD_ROOT} install
  65. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %post -p /sbin/ldconfig
  69. %postun -p /sbin/ldconfig
  70. %files
  71. %defattr(-,root,root,-)
  72. %doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS PORTING README
  73. %doc SUPPORT TESTS THANKS USERS
  74. %{_libdir}/*.so.*
  75. %files devel
  76. %defattr(-,root,root,-)
  77. %doc HACKING
  78. %{_bindir}/*
  79. %{_includedir}/*
  80. %{_libdir}/*.so
  81. %{_mandir}/*/*
  82. %{_datadir}/aclocal/*
  83. %changelog
  84. * Mon Jan 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.7-9
  85. - rebuilt on current VineSsed
  86. * Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.7-8
  87. - rebuild with Vine6 environment
  88. * Wed Sep 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.7-7
  89. - initial build for VineSeed
  90. * Sat May 31 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-7
  91. - Drop "|| :" from check section. It failed to build for mdomsch
  92. in Rawhide today.
  93. * Fri Feb 08 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-6
  94. - rebuilt for GCC 4.3 as requested by Fedora Release Engineering
  95. * Sun Oct 21 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-5
  96. - Patch pth-config.
  97. This shall fix the multiarch conflict in pth-devel (#342961).
  98. It must not return -I/usr/include and -L/usr/{lib,lib64} either,
  99. since these are default search paths already.
  100. - Replace the config.status CFLAGS sed expr with a patch.
  101. * Tue Aug 21 2007 Michael Schwendt <mschwendt@fedoraproject.org>
  102. - rebuilt
  103. * Thu Aug 2 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-2
  104. - Clarify licence (LGPLv2+).
  105. * Sat Nov 25 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-1
  106. - Update to 2.0.7 (very minor maintenance updates only).
  107. * Mon Aug 28 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-3
  108. - rebuilt
  109. * Mon May 22 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-2
  110. - Insert -g into CFLAGS after configure script removes it.
  111. - Disable configure check for obsolete sigstack(), which segfaults.
  112. * Thu Feb 16 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-1
  113. - Update to 2.0.6.
  114. * Fri Oct 7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.5-1
  115. - Update to 2.0.5.
  116. - Don't build static archive.
  117. * Fri May 13 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-3
  118. - rebuilt
  119. * Thu Apr 7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-2
  120. - rebuilt
  121. * Thu Feb 24 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.4-1
  122. - Update to 2.0.4.
  123. - Remove ancient changelog entries which even pre-date Fedora.
  124. * Tue Dec 14 2004 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.3-1
  125. - Update to 2.0.3, minor and common spec adjustments + LGPL, %%check,
  126. use URLs for official GNU companion sites.
  127. * Thu Oct 07 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.2
  128. - iconv-ing spec to utf8
  129. * Wed Oct 06 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.1
  130. - Update to 2.0.2 and current Fedora guidelines.
  131. - added workaround for make -j problem
  132. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.0.0-0.fdr.1
  133. - Update to 2.0.0 and current Fedora guidelines.
  134. - Exclude %%{_libdir}/*.la
  135. * Fri Feb 7 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1.fedora.1
  136. - First Fedora release, based on Ryan Weaver's work.
  137. - Move (most of) docs to main package.