proftpd-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558
  1. %bcond_with systemd
  2. %if %{with systemd}
  3. %define rundir /run
  4. %else
  5. %define rundir /var/run
  6. %endif
  7. %define _prefix /usr
  8. %define _localstatedir %{rundir}
  9. %define _sysconfdir /etc
  10. %define _rundir %{rundir}/proftpd
  11. %define tarballversion 1.3.7a
  12. %define origversion 1.3.7a
  13. Summary: ProFTPd -- Professional FTP Server.
  14. Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
  15. Name: proftpd
  16. Epoch: 1
  17. Version: %{origversion}
  18. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  19. Group: servers,internet
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. License: GPL
  23. URL: http://www.proftpd.org/
  24. Source0: https://github.com/proftpd/proftpd/archive/v%{origversion}.tar.gz#/%{name}-%{origversion}.tar.gz
  25. Source1: proftpd.vine.conf
  26. Source2: ftpusers.vine
  27. Source3: proftpd.init
  28. Source5: welcome.msg
  29. # upstream bug fixes & security fixes
  30. # auth
  31. Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
  32. # fix build on recent kernel headers
  33. # Patch400: proftpd-1.3.1-umode.patch
  34. # security fix
  35. # nothing..
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. BuildRequires: pam-devel, openldap-devel, openssl-devel
  38. BuildRequires: ncurses-devel, libcap-devel, libacl-devel
  39. BuildRequires: e2fsprogs-devel
  40. Requires: pam > 0.59
  41. Obsoletes: wu-ftpd, anonftp
  42. Provides: ftpserver
  43. %description
  44. ProFTPd is an enhanced FTP server with a focus toward simplicity,
  45. security, and ease of configuration. It features a very Apache-like
  46. configuration syntax, and a highly customizable server infrastructure,
  47. including support for multiple 'virtual' FTP servers, anonymous FTP,
  48. and permission-based directory visibility.
  49. %description -l ja
  50. ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
  51. FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
  52. anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
  53. 高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
  54. %package utils
  55. Summary: ProFTPD - Additional utilities
  56. Group: admin-tools
  57. Requires: %{name} = %{epoch}:%{version}-%{release}
  58. %description utils
  59. This package contains additional utilities for monitoring and configuring the
  60. ProFTPD server:
  61. * ftpasswd: generate passwd(5) files for use with AuthUserFile
  62. * ftpcount: show the current number of connections per server/virtualhost
  63. * ftpmail: monitor transfer log and send email when files uploaded
  64. * ftpquota: manipulate quota tables
  65. * ftptop: show the current status of FTP sessions
  66. * ftpwho: show the current process information for each FTP session
  67. %debug_package
  68. %prep
  69. %setup -q -n %{name}-%{tarballversion}
  70. find . -type d -name CVS | xargs -r rm -frv
  71. # upstream fixes
  72. ## patches from mdk
  73. # use system-auth instead of pam_pwdb
  74. %patch201 -p1
  75. # fix build on recent kernel headers
  76. # %patch400 -p0
  77. # security fixes
  78. %build
  79. # Disable stripping in order to get useful debuginfo packages
  80. %{__perl} -pi -e 's|"-s"|""|g' configure
  81. %configure \
  82. --libexecdir="%{_libexecdir}/proftpd" \
  83. --localstatedir="%{rundir}/proftpd" \
  84. --disable-strip \
  85. --enable-ctrls \
  86. --enable-facl \
  87. --enable-dso \
  88. --enable-nls \
  89. --enable-ipv6 \
  90. --enable-openssl \
  91. --disable-pcre \
  92. --disable-redis \
  93. --enable-shadow \
  94. --with-modules=mod_readme:mod_auth_pam:mod_tls:\
  95. mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
  96. --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
  97. # It seems that with _smp_mflags -lsupp tries to get linked before being built
  98. # (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
  99. %{__make}
  100. %install
  101. %{__rm} -rf %{buildroot}
  102. %{__make} install DESTDIR=%{buildroot} \
  103. rundir="%{rundir}/proftpd" \
  104. INSTALL_USER=`id -un` \
  105. INSTALL_GROUP=`id -gn`
  106. # auth
  107. mkdir -p %{buildroot}%{_sysconfdir}/pam.d
  108. %{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
  109. # logrotate
  110. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  111. %{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
  112. %{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
  113. %{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
  114. %{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
  115. touch %{buildroot}%{_sysconfdir}/ftpusers
  116. %if %{with systemd}
  117. install -D -p -m 644 contrib/dist/rpm/proftpd.service \
  118. %{buildroot}%{_unitdir}/proftpd.service
  119. install -D -p -m 644 contrib/dist/systemd/proftpd.socket \
  120. %{buildroot}%{_unitdir}/proftpd.socket
  121. install -D -p -m 644 contrib/dist/systemd/proftpd@.service \
  122. %{buildroot}%{_unitdir}/proftpd@.service
  123. install -d -m 755 %{buildroot}%{_tmpfilesdir}
  124. install -p -m 644 contrib/dist/rpm/proftpd-tmpfs.conf \
  125. %{buildroot}%{_tmpfilesdir}/proftpd.conf
  126. %else
  127. # init.d
  128. %{__install} -D -p -m 0755 %{SOURCE3} \
  129. %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
  130. %endif
  131. rm contrib/README.* || :
  132. # eliminate executable bit in %doc
  133. find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
  134. # remove .{la,a}
  135. rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
  136. # remove development files (headers and pkgconfig file)
  137. # who need these files?
  138. rm -rf %{buildroot}%{_includedir}/proftpd
  139. rm -rf %{buildroot}%{_libdir}/pkgconfig
  140. # Find translations
  141. %find_lang proftpd
  142. %clean
  143. rm -rf %{buildroot}
  144. %preun
  145. %if %{with systemd}
  146. if [ $1 -eq 0 ]; then
  147. systemctl --no-reload disable proftpd.service &>/dev/null || :
  148. systemctl stop proftpd.service &>/dev/null || :
  149. fi
  150. %else
  151. if [ $1 = 0 -o -x /bin/systemctl ] ; then
  152. /sbin/service proftpd stop &>/dev/null || :
  153. /sbin/chkconfig --del proftpd || :
  154. fi
  155. %endif
  156. if [ -d %{_rundir} ] ; then
  157. rm -rf %{_rundir}/*
  158. fi
  159. %postun
  160. %if %{with systemd}
  161. systemctl daemon-reload &>/dev/null || :
  162. if [ $1 -ge 1 ]; then
  163. systemctl try-restart proftpd.service &>/dev/null || :
  164. fi
  165. %else
  166. if [ $1 -ge 1 ]; then
  167. /sbin/service proftpd condrestart
  168. fi
  169. %endif
  170. %post
  171. %if %{with systemd}
  172. systemctl daemon-reload &>/dev/null || :
  173. systemctl preset proftpd.service &>/dev/null || :
  174. %else
  175. /sbin/chkconfig --add proftpd
  176. %endif
  177. %files -f proftpd.lang
  178. %defattr(-,root,root)
  179. %license COPYING
  180. %doc CREDITS INSTALL NEWS
  181. %doc README.{md,LDAP,modules}
  182. %doc doc/*
  183. %doc contrib/README contrib/xferstats.holger-preiss
  184. %doc sample-configurations/
  185. %{_sbindir}/*
  186. %{_bindir}/ftpdctl
  187. %{_bindir}/prxs
  188. %{_mandir}/man5/proftpd.conf.5*
  189. %{_mandir}/man5/xferlog.5*
  190. %{_mandir}/man8/ftpdctl.8*
  191. %{_mandir}/man8/ftpscrub.8*
  192. %{_mandir}/man8/ftpshut.8*
  193. %{_mandir}/man8/proftpd.8*
  194. %{_var}/ftp/welcome.msg
  195. %dir %{_libexecdir}/proftpd/
  196. %{_libexecdir}/proftpd/mod_*
  197. %dir %{_var}/ftp
  198. %if %{with systemd}
  199. %{_unitdir}/proftpd.service
  200. %{_unitdir}/proftpd.socket
  201. %{_unitdir}/proftpd@.service
  202. %{_tmpfilesdir}/proftpd.conf
  203. %else
  204. %config %{_sysconfdir}/rc.d/init.d/proftpd
  205. %dir %{_rundir}
  206. %endif
  207. %config(noreplace) %{_sysconfdir}/pam.d/ftp
  208. %config(noreplace) %{_sysconfdir}/proftpd.conf
  209. %config(noreplace) %{_sysconfdir}/ftpusers
  210. %config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
  211. %files utils
  212. %doc contrib/xferstats.holger-preiss
  213. %{_bindir}/ftpasswd
  214. %{_bindir}/ftpcount
  215. %{_bindir}/ftpmail
  216. %{_bindir}/ftpquota
  217. %{_bindir}/ftptop
  218. %{_bindir}/ftpwho
  219. %{_mandir}/man1/ftpasswd.1*
  220. %{_mandir}/man1/ftpcount.1*
  221. %{_mandir}/man1/ftpmail.1*
  222. %{_mandir}/man1/ftpquota.1*
  223. %{_mandir}/man1/ftptop.1*
  224. %{_mandir}/man1/ftpwho.1*
  225. %changelog
  226. * Thu Dec 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7a-1
  227. - new upstream release.
  228. - added systemd support (disabled as default).
  229. - dropped Patch300.
  230. * Sat Feb 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6c-1
  231. - new upstream release.
  232. * Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6b-1
  233. - new upstream release.
  234. * Fri Mar 16 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.5e-1
  235. - new upstream release.
  236. - remake patch24 for 1.3.5e
  237. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.5b-1
  238. - new upstream release.
  239. - removed Patch14, Patch23 and Patch25 (no longer needed).
  240. - updated Patch300.
  241. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-2
  242. - fix util package dependency
  243. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-1
  244. - new upstream release
  245. - util tools in util subpackage
  246. - update patch300 to fit new version
  247. - add patch14, 23, 24, 25 from fc18 (thanks to fc team)
  248. - add enable-nls in configure
  249. * Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
  250. - new upstream release
  251. - update patch300 to fit new version
  252. - drop patch1000 (is included in new release)
  253. - add BR: e2fsprogs-devel
  254. * Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
  255. - rebuild with openssl-1.0.0c
  256. * Fri Nov 5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
  257. - new upstream release
  258. - add patch1000 for CVE-2010-4221 (TELNET_IAC)
  259. - add BRs: ncurses-devel, libcap-devel, libacl-devel
  260. * Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
  261. - new upstream release with security fix (CVE-2009-3555)
  262. * Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
  263. - new upstream release with security fix (NULL char in X.509 certificate)
  264. - add chkconfig --add in post script
  265. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
  266. - remove .{la,a}
  267. - remove headers and pkgconfig file
  268. * Mon Jul 6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
  269. - update Source1 (sample config file for vine)
  270. set default char set to UTF-8
  271. * Fri Jul 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
  272. - new upstream release
  273. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
  274. - rebuild with openldap-2.4.11
  275. * Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
  276. - built with openssl-0.9.8k
  277. * Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
  278. - new upstream release
  279. - add configure option to activate new modules
  280. - drop patch400
  281. * Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
  282. - built with openssl-0.9.8j
  283. * Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
  284. - built with openssl-0.9.8i
  285. * Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
  286. - add Patch400 to fix build failure at least on i386
  287. - spec in UTF-8
  288. * Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
  289. - built with openssl-0.9.8h
  290. * Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
  291. - update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
  292. * Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
  293. - new upstream release
  294. - drop old patches which are included in new release
  295. - update patch201, 300
  296. - build under new versioning policy
  297. * Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
  298. - new upstream release
  299. - built with openssl098
  300. - drop old (for 1.2.10) patches
  301. - Patch100-150 from FC8 package
  302. - Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
  303. - update patch300 for 1.3.0
  304. - change configure option refer to FC8
  305. - add process reboot with message output when package is upgraded
  306. - docfiles list update
  307. - fix changelog ver number typo
  308. * Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
  309. - add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
  310. (<WISHES:15>)
  311. - add Vendor/Distribution tag
  312. - add patch104 for fix pr_ctrls_recv_request issue
  313. - add patch103 for fix CVE-2006-6170
  314. - add patch102 for fix CVE-2006-5815
  315. - add patch101 for fix CVE-2006-6171
  316. * Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
  317. - rebuilt with openldap-2.3.27-0vl
  318. * Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
  319. - rebuilt with openldap-2.3.24-0vl1
  320. * Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
  321. - add patch300 for iconv patch
  322. * Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
  323. - enable mod_ldap
  324. - add BuildRequires: openldap-devel, openssl-devel
  325. - add Patch200 from MDK to support ldap
  326. - add Patch201 from MDK to use system-auth instead of pam_pwdb
  327. (pam_pwdb is now obsolete, and will be removed in the future pam version)
  328. * Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  329. - 1.2.10-0vl1.1
  330. - add patch100 for fix CAN-2005-2390
  331. * Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
  332. - new upstream release
  333. * Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
  334. - new upstream release (1.2.10rc3)
  335. - build for Vine Linux 3.0
  336. * Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
  337. - new upstream release
  338. - fix security issue: http://secunia.com/advisories/11527/
  339. * Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
  340. - new upstream release
  341. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
  342. - new upstream release
  343. - fix security issue: http://xforce.iss.net/xforce/alerts/id/154
  344. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  345. - new upstream release
  346. * Fri Dec 6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  347. - new upstream release 1.2.7
  348. - add logrotate config file.
  349. - move ftp home directory from /home/ftp to /var/ftp
  350. * Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
  351. - new upstream release 1.2.6
  352. * Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
  353. - new upstream release 1.2.5 (stable release version)
  354. * Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  355. - new upstream release 1.2.5-rc3
  356. * Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
  357. - eliminate executable bit in %doc (requierment for /usr/bin/perl)
  358. - put files in sample-configurations/ to the according directory
  359. - remove unnecessary README.* files
  360. * Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
  361. - updated to 1.2.5rc1 for problems in file globbing
  362. * Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
  363. - 1.2.4-0vl1
  364. * Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
  365. - 1.2.3-0vl1
  366. * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
  367. - 1.2.2-0vl1: update to 1.2.2 release
  368. - added more documents
  369. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
  370. - update to 1.2.2rc3
  371. - use macros
  372. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  373. - 1.2.1-0vl3
  374. - rebuilt for VineSeed
  375. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
  376. - update to 1.2.1
  377. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
  378. - build for VineSeed
  379. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
  380. - update to 1.2.0
  381. - set Epoch 1 to update from pre* and rc* version
  382. * Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  383. - 1.2.0rc3-0vl3
  384. - removed PreReq and postun about /etc/ftpusers stuff
  385. * Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
  386. - remove setup of /etc/ftpusers in %%pre script
  387. - add ftpusers.vine insted of the %%pre script
  388. - remove contrib/README.* frpm %%files
  389. - add BuildRequires: pam-devel
  390. * Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
  391. - rebuild for VineSeed
  392. * Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
  393. - update to 1.2.0rc3
  394. - add 'TimesGMT FALSE' in default configuration file
  395. - build on Vine 2.1
  396. * Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  397. - modified pre script to make it run by bash2 and added PreReq
  398. - remove /etc/ftpusers after uninstall
  399. * Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  400. - 1.2.0rc2-0vl8
  401. - rebuilt on VineSeed
  402. * Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
  403. - remove patch from CVS to avoid 'after 5min data brake'
  404. - add passive patch insted of abobe CVS patch
  405. - revival contribute's proftpd.init.d
  406. * Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
  407. - fixed %pre script and remove /etc/ftpusers from files
  408. - modify Japanese summary and descriptions
  409. * Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  410. - actually fixed to make the package relocatable.
  411. - non-root build failure by broken %prein, which should be %pre.
  412. - dont include CVS directory in doc
  413. - add %config /etc/rc.d/init.d/proftpd
  414. * Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
  415. - correct config directive of the init.d script
  416. * Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
  417. - adopt current patch from CVS to avoid the 'put on passive mode' probrem
  418. * Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
  419. - 1.2.0rc2-0vl1
  420. - obsoletes anonftp
  421. - do not chkconfig --add in %post
  422. - requires: pam
  423. - added proftpd.vine.conf
  424. * Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  425. - libtoolize for alpha
  426. * Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  427. - [1.2.0rc2]
  428. * Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  429. - repackaging for VineLinux
  430. * Sun Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
  431. - Multi package creation.
  432. Created core, standalone, inetd (&doc) package creations.
  433. Added startup script for init.d
  434. Need to make the "standalone & inetd" packages being created as "noarch"
  435. - Added URL.
  436. - Added prefix to make the package relocatable.
  437. * Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
  438. - Corrected inetd.conf line addition/change logic.
  439. * Sat Jul 24 1999 MacGyver <macgyver@tos.net>
  440. - Initial import of spec.