procps-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453
  1. %bcond_with systemd
  2. %define origname procps-ng
  3. Summary: System and process monitoring utilities.
  4. Summary(ja): システムやプロセスのモニタリングユーティリティ
  5. Name: procps
  6. Version: 3.3.16
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: Applications/System
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. Packager: daisuke
  12. License: GPL
  13. Url: https://gitlab.com/procps-ng/procps
  14. # alternative: http://sourceforge.net/projects/procps-ng/
  15. Source: https://downloads.sourceforge.net/project/procps-ng/Production/%{origname}-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Requires(post): /sbin/ldconfig, /bin/rm
  18. Requires(postun): /sbin/ldconfig
  19. Obsoletes: procps-X11, pgrep
  20. # Vine source/patches
  21. Source10: procps-ng-3.3.10-ja.po
  22. BuildRequires: ncurses-devel
  23. %if %{with systemd}
  24. BuildRequires: systemd-devel
  25. %else
  26. BuildRequires: elogind-devel
  27. %endif
  28. %description
  29. The procps package contains a set of system utilities that provide
  30. system information. Procps includes ps, free, skill, snice, tload,
  31. top, uptime, vmstat, w, and watch. The ps command displays a snapshot
  32. of running processes. The top command provides a repetitive update of
  33. the statuses of running processes. The free command displays the
  34. amounts of free and used memory on your system. The skill command
  35. sends a terminate command (or another specified signal) to a specified
  36. set of processes. The snice command is used to change the scheduling
  37. priority of specified processes. The tload command prints a graph of
  38. the current system load average to a specified tty. The uptime command
  39. displays the current time, how long the system has been running, how
  40. many users are logged on, and system load averages for the past one,
  41. five, and fifteen minutes. The w command displays a list of the users
  42. who are currently logged on and what they are running. The watch
  43. program watches a running program. The vmstat command displays virtual
  44. memory statistics about processes, memory, paging, block I/O, traps,
  45. and CPU activity.
  46. %description -l ja
  47. システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
  48. 可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
  49. %package devel
  50. Summary: System and process monitoring utilities
  51. Summary(ja): procpsを利用した開発に必要なファイル
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. System and process monitoring utilities development headers
  56. %description devel -l ja
  57.  このパッケージにはprocpsを利用した開発に必要なヘッダ・ライブラリファイル
  58. が収録されています。
  59. %prep
  60. %setup -q -n %{origname}-%{version}
  61. # vine
  62. cp -f %{SOURCE10} po/ja.po
  63. #echo "ja" > po/LINGUAS
  64. %build
  65. autoreconf --verbose --force --install
  66. ./configure --prefix=/ \
  67. --bindir=%{_bindir} \
  68. --sbindir=%{_syssbindir} \
  69. --libdir=%{_libdir} \
  70. --datadir=%{_datadir} \
  71. --localedir=%{_datadir}/locale \
  72. --mandir=%{_mandir} \
  73. --includedir=%{_includedir} \
  74. --sysconfdir=%{_sysconfdir} \
  75. --docdir=/unwanted \
  76. --disable-static \
  77. --disable-w-from \
  78. --disable-kill \
  79. --enable-watch8bit \
  80. --enable-skill \
  81. --enable-sigwinch \
  82. --disable-libselinux \
  83. %if %{with systemd}
  84. --with-systemd
  85. %else
  86. --without-systemd \
  87. --with-elogind
  88. %endif
  89. make CFLAGS="%{optflags}"
  90. sed -i -e 's|/procps-ng-.*-dirty/|/|' po/Makefile
  91. sed -i -e 's|^procps-ng-.*-dirty/||' po/POTFILES.in
  92. make -C po update-po
  93. make -C po ja.gmo
  94. %install
  95. make DESTDIR=%{buildroot} install
  96. make DESTDIR=%{buildroot} -C po install
  97. mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
  98. # for compatibility
  99. mkdir -p %{buildroot}%{_sysbindir}
  100. mv %{buildroot}%{_bindir}/ps %{buildroot}%{_sysbindir}/
  101. ln -sf %{_sysbindir}/ps %{buildroot}%{_bindir}/ps
  102. rm -f %{buildroot}/%{_libdir}/libprocps.la
  103. rm -rf %{buildroot}/unwanted
  104. rm -f %{buildroot}%{_bindir}/pidof
  105. %find_lang procps-ng
  106. %clean
  107. rm -rf %{buildroot}
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %files -f procps-ng.lang
  111. %defattr(-,root,root,-)
  112. %license COPYING COPYING.LIB
  113. %doc AUTHORS NEWS README*
  114. %{_libdir}/libprocps.so.*
  115. %{_bindir}/*
  116. %{_sysbindir}/*
  117. %{_syssbindir}/*
  118. %{_sysconfdir}/sysctl.d
  119. %{_mandir}/man1/*
  120. %{_mandir}/man3/*
  121. %{_mandir}/man8/*
  122. %{_mandir}/man5/*
  123. %files devel
  124. %defattr(-,root,root,-)
  125. %doc COPYING COPYING.LIB
  126. %{_libdir}/libprocps.so
  127. %{_libdir}/pkgconfig/libprocps.pc
  128. %{_includedir}/proc
  129. %changelog
  130. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.16-1
  131. - new upstream release.
  132. - added systemd support (disabled as default).
  133. * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.15-1
  134. - new upstream release.
  135. - enabled elogind.
  136. - added japanese summary.
  137. * Sun Jun 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-2
  138. - fixed Source10.
  139. * Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
  140. - new upstream release.
  141. - updated Source10 and Patch10.
  142. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
  143. - update to forked version of procps 3.3.9
  144. - add minimum ja.po
  145. * Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  146. - update to 3.2.8
  147. - add patch30 to fix top highlight bug
  148. (thanks to <BTS:916>)
  149. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
  150. - spec in utf-8
  151. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
  152. - new upstream release
  153. * Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
  154. - [BTS:205] update ja.po ( in Patch20 )
  155. * Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
  156. - add Obsoletes: pgrep
  157. * Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
  158. - upstream release
  159. - update Patch20
  160. - fix encode of spec file (SJIS -> EUC-JP)
  161. - add pwdx command (new from 3.2.4)
  162. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
  163. - update gettext patch
  164. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
  165. - add gettext patch (Patch20)
  166. still needs more work ( only for "free" and "uptime" )
  167. * Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
  168. - new upstream release
  169. * Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
  170. - modified for Vine
  171. - add obsoletes -X11 package
  172. * Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
  173. - New version from upstream
  174. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  175. - rebuilt
  176. * Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
  177. - Match -Z to --context
  178. * Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
  179. - Add back in -Z support
  180. * Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
  181. - upgrade to procps3
  182. - Some regressions, see bug #114012
  183. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
  184. - Remove LIBCURSES from skill and sysctl
  185. * Wed Dec 10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
  186. - Turn on SELinux
  187. * Mon Dec 8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
  188. - Fix top total percentages (#109484)
  189. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
  190. - Turn off selinux
  191. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
  192. - Fix help message
  193. * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
  194. - Turn on selinux
  195. * Fri Oct 3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
  196. - Update to 2.0.17, drop upstream patches, forward port remaining patches
  197. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
  198. - Turn off selinux
  199. * Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
  200. - Add -Z switch for SELinux
  201. * Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
  202. - Add patch to recognize irq and softirq time accounting in kernels that
  203. support this feature
  204. * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
  205. - rebuild
  206. * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
  207. - Add swapped patch from rik van riel
  208. * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
  209. - rebuild
  210. * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
  211. - Update iowait patch (#101657)
  212. - Add wchan 64bit patch from Mark DeWandel
  213. * Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
  214. - Add SELinux patch
  215. * Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
  216. - display iowait with procps-2.0.13-iowait.patch (#99061)
  217. * Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
  218. - Disable linuxthreads thread hack
  219. * Mon Jul 7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
  220. - rebuild
  221. * Fri Jul 4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
  222. - update to 2.0.13
  223. - Re-merged ntpl patch
  224. - Add hertz fix from Ernie Petrides <petrides@redhat.com>
  225. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  226. - rebuilt
  227. * Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
  228. - Update to 2.0.12
  229. - Add patch to fix segfault on ps axl (#91453)
  230. * Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
  231. - Add patch that fixes negative priorities in top.
  232. * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
  233. - New NPTL patch:
  234. - Added skipthreads optimization to top
  235. - Don't read threads in 'w'
  236. * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
  237. - Update the NPTL patch since the kernel /proc was fixed
  238. - For kernels >= 2.4.20-2.50
  239. * Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
  240. - Update nptl patch to new /proc layout.
  241. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
  242. - rebuilt
  243. * Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
  244. - Created nptl patch after discussion with ingo and arjan
  245. * Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
  246. - Update to 2.0.11
  247. * Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
  248. - Fix %%install in changelog
  249. * Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
  250. - Fix for Hammer
  251. * Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
  252. - Remove uninstalled files in %%install. Add pmap to %%files
  253. * Tue Oct 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
  254. - Update to 2.0.10
  255. - Removed applied patches.
  256. * Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
  257. - Add patch to protect against idle ticks going backwards. Fixes #71237
  258. * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
  259. - Fix saving of sort, fixes #32757
  260. - Fix printing size, fixes #48224
  261. - Fix float decimal point input #58163
  262. * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
  263. - Fix unsigned/signed bug. Closes #60998.
  264. - Update threadbadhack to correctly propagate process time to the main thread.
  265. * Wed Aug 7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
  266. - Don't strip binaries
  267. * Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
  268. - Remove the X11 subpackage
  269. * Mon Jul 1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
  270. - Added patch that fixes #35174
  271. * Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
  272. - New thread badhack patch. Fixes a segfault.
  273. * Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
  274. - New thread badhack. Now enabled by default.
  275. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  276. - automated rebuild
  277. * Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
  278. - Added badhack to support hiding threads
  279. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  280. - automated rebuild
  281. * Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
  282. - add ldconfig in %postun
  283. * Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
  284. - Add ncurses-devel as a build dependency (#49562)
  285. * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
  286. - removed applnk entry, one of the things that's cluttering our menus
  287. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  288. - Bump release + rebuild.
  289. * Thu Apr 5 2001 Jakub Jelinek <jakub@redhat.com>
  290. - fix AIX style user defined formats (#34833)
  291. * Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
  292. - add a '-e' to sysctl to ignore errors (#31852)
  293. * Mon Mar 5 2001 Preston Brown <pbrown@redhat.com>
  294. - bigger buffer for reading /proc/stat fixes segfault (#27840)
  295. * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
  296. - make sysctl return a value when errors occur (#18820).
  297. - support big UIDs (#22683)
  298. * Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
  299. - work-around for negative CPU output (Bug #18380)
  300. * Thu Aug 17 2000 Than Ngo <than@redhat.com>
  301. - fix failing in RPM post script (Bug #16226)
  302. * Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
  303. - Added Jakub's locale patch
  304. * Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
  305. - procps-2.0.7
  306. - integrated all patches except for signames patch, which is broken
  307. and unnecessary
  308. - See NEWS for changes between 2.0.6 and 2.0.7
  309. - Added patch to correctly install desktop file. Oops.
  310. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  311. - automatic rebuild
  312. * Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
  313. - larger buffers for reading /proc/stat
  314. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  315. - FHS paths
  316. * Tue May 30 2000 Preston Brown <pbrown@redhat.com>
  317. - add smp, signal name patches from VA Linux. Thanks guys.
  318. * Mon May 22 2000 Harald Hoyer <harald@redhat.com>
  319. - added sysctl.conf (5) man page
  320. * Wed May 10 2000 Bill Nottingham <notting@redhat.com>
  321. - fix PAGE_SIZE mismatch on ia64
  322. * Sun May 7 2000 Bill Nottingham <notting@redhat.com>
  323. - rebuild with different optimizations for ia64
  324. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  325. - rebuild with current ncurses
  326. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  327. - fix end-of-file behavior in sysctl
  328. * Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
  329. - wmconfig -> desktop
  330. * Mon Feb 7 2000 Jakub Jelinek <jakub@redhat.com>
  331. - don't try to load System.map (and spit error messages if it does not
  332. exist) if ps or top are not going to use it, both to speed things up
  333. and remove the ugly messages when they don't make sense.
  334. - in top, print the possible error messages using standard top SHOWMESSAGE
  335. (because it will be now printed out when already in terminal mode).
  336. * Thu Feb 3 2000 Matt Wilson <msw@redhat.com>
  337. - added patch to prevent divide by zero on UltraSparc
  338. - gzip man pages