postgresql-ruby-vl.spec 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. %define oname ruby-postgres
  2. %define over 0.7.1
  3. Summary: PostgreSQL extension module for programming language Ruby
  4. Name: postgresql-ruby
  5. Version: %{over}
  6. Release: 1%{?_dist_release}
  7. License: distributable
  8. Group: Development/Languages
  9. Source: http://www.postgresql.jp/interfaces/ruby/%{oname}-%{over}.tar.gz
  10. URL: http://www.jp.postgresql.org/interfaces/ruby/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildPreReq: postgresql-devel, ruby, ruby-devel >= 1.8.1-0vl12
  13. Summary(ja): Ruby用のPostgreSQL拡張モジュール
  14. %description
  15. This is the extension library to access a PostgreSQL database from Ruby.
  16. %description -l ja
  17. 本ライブラリは、RubyからPostgreSQLへアクセスするための拡張ライブラリです。
  18. %prep
  19. %setup -q -c
  20. %build
  21. cd %{oname}-%{over}
  22. ruby extconf.rb --with-pgsql-include-dir=%{_includedir}/pgsql
  23. make
  24. cd ..
  25. %install
  26. rm -rf ${RPM_BUILD_ROOT}
  27. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  28. # installing binaries ...
  29. cd %{oname}-%{over}
  30. make install DESTDIR=${RPM_BUILD_ROOT} sitedir=${RPM_BUILD_ROOT}%{_libdir}/ruby
  31. cd ..
  32. (find \
  33. $RPM_BUILD_ROOT%{_libdir} \
  34. -type f -o -type l) |
  35. sort | sed -e "s,^$RPM_BUILD_ROOT,," > postgresql-ruby.files
  36. %clean
  37. rm -rf ${RPM_BUILD_ROOT}
  38. %pre
  39. %post
  40. %files -f postgresql-ruby.files
  41. %defattr(-, root, root)
  42. %doc %{oname}-%{over}/ChangeLog
  43. %doc %{oname}-%{over}/README
  44. %doc %{oname}-%{over}/README.ja
  45. %doc %{oname}-%{over}/doc/*.html
  46. %doc %{oname}-%{over}/sample
  47. %changelog
  48. * Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 0.7.1-1vl5
  49. - applied new versioning policy, spec in utf-8
  50. * Wed Dec 19 2007 Shu KONNO <owa@bg.wakwak.com> 0.7.1-0vl3
  51. - s/Copyright/License/
  52. * Tue Oct 05 2004 Satoshi MACHINO <machino@vinelinux.org> 0.7.1-0vl2
  53. - fixed postgres.so's path
  54. * Tue Oct 05 2004 Satoshi MACHINO <machino@vinelinux.org> 0.7.1-0vl1
  55. - new upstream version (ruby-postgres-0.7.1)
  56. - fixed search path for postgres.so in spec
  57. - changed file name to README.ja
  58. * Wed Jan 09 2002 Satoshi MACHINO <machino@vinelinux.org> 0.6.5-0vl1
  59. - update ruby-postgres-0.6.5
  60. - changed BuildPreReq from BuildRequire, and updated ruby version
  61. * Thu Jul 26 2001 akira yamada <akira@vinelinux.org>
  62. - rebuild with ruby-devel-1.6.4-0vl3.
  63. * Mon Apr 23 2001 akira yamada <akira@vinelinux.org>
  64. - new upstream version, 0.6.3.
  65. * Mon Apr 23 2001 akira yamada <akira@vinelinux.org>
  66. - Initial packaging.