portreserve-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. Summary: TCP port reservation utility
  2. Summary(ja): TCP ポート予約ユーティリティ
  3. Name: portreserve
  4. Version: 0.0.5
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Daemons
  8. URL: http://cyberelk.net/tim/portreserve/
  9. Source0: http://cyberelk.net/tim/data/portreserve/stable/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildRequires: xmlto
  12. %description
  13. The portreserve program aims to help services with well-known ports that
  14. lie in the portmap range. It prevents portmap from a real service's port
  15. by occupying it itself, until the real service tells it to release the
  16. port (generally in the init script).
  17. %prep
  18. %setup -q
  19. %build
  20. %configure --sbindir=/sbin
  21. make
  22. %install
  23. rm -rf %{buildroot}
  24. make DESTDIR=%{buildroot} install
  25. mkdir -p %{buildroot}%{_localstatedir}/run/portreserve
  26. mkdir -p %{buildroot}%{_initrddir}
  27. install -m755 portreserve.init %{buildroot}%{_initrddir}/portreserve
  28. mkdir -p %{buildroot}%{_sysconfdir}/portreserve
  29. mkdir -p %{buildroot}%{_sysconfdir}/tmpfiles.d
  30. cat <<EOF > %{buildroot}%{_sysconfdir}/tmpfiles.d/portreserve.conf
  31. d %{_localstatedir}/run/portreserve 0755 root root 10d
  32. EOF
  33. %clean
  34. rm -rf %{buildroot}
  35. %post
  36. # Do this unconditionally to fix up the initscript's start priority.
  37. # Earlier versions had an incorrect dependency (bug #487250).
  38. /sbin/chkconfig --add portreserve
  39. %preun
  40. if [ "$1" = 0 ]; then
  41. /sbin/service portreserve stop >/dev/null 2>&1
  42. /sbin/chkconfig --del portreserve
  43. fi
  44. %postun
  45. if [ "$1" -ge "1" ]; then
  46. /sbin/service portreserve condrestart >/dev/null 2>&1
  47. fi
  48. %files
  49. %defattr(-,root,root)
  50. %doc ChangeLog README COPYING NEWS
  51. %ghost %dir %{_localstatedir}/run/portreserve
  52. %dir %{_sysconfdir}/portreserve
  53. %config %{_sysconfdir}/tmpfiles.d/portreserve.conf
  54. %attr(755,root,root) %{_initrddir}/portreserve
  55. /sbin/*
  56. %{_mandir}/*/*
  57. %changelog
  58. * Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.5-1
  59. - update to 0.0.5
  60. - remove old patches
  61. * Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.4-1
  62. - initial build for Vine Linux
  63. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-8
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  65. * Thu Dec 2 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-7
  66. - /var/run changes for systemd (bug #656670).
  67. * Thu Nov 18 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-6
  68. - Fixed initscript exit code for "status" action (bug #619089).
  69. * Thu Mar 4 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-5
  70. - Added comments to all patches.
  71. * Fri Jan 22 2010 Tim Waugh <twaugh@redhat.com> 0.0.4-4
  72. - Walk the list of newmaps correctly (bug #557781).
  73. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-2
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  75. * Fri Feb 27 2009 Tim Waugh <twaugh@redhat.com> 0.0.4-1
  76. - 0.0.4:
  77. - Fixed initscript so that it will not be reordered to start after
  78. rpcbind (bug #487250).
  79. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.3-4
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  81. * Wed Feb 4 2009 Tim Waugh <twaugh@redhat.com> 0.0.3-3
  82. - No longer need SELinux policy as it is now part of the
  83. selinux-policy package.
  84. * Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 0.0.3-2
  85. - New selinux sub-package for SELinux policy. Policy contributed by
  86. Miroslav Grepl (thanks!).
  87. * Tue Jul 1 2008 Tim Waugh <twaugh@redhat.com> 0.0.3-1
  88. - 0.0.3:
  89. - Allow multiple services to be defined in a single configuration
  90. file.
  91. - Allow protocol specifications, e.g. ipp/udp.
  92. * Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 0.0.2-1
  93. - 0.0.2.
  94. * Fri May 9 2008 Tim Waugh <twaugh@redhat.com> 0.0.1-2
  95. - More consistent use of macros.
  96. - Build requires xmlto.
  97. - Don't use %%makeinstall.
  98. - No need to run make check.
  99. * Thu May 8 2008 Tim Waugh <twaugh@redhat.com> 0.0.1-1
  100. - Default permissions for directories.
  101. - Initscript should not be marked config.
  102. - Fixed license tag.
  103. - Better buildroot tag.
  104. * Wed Sep 3 2003 Tim Waugh <twaugh@redhat.com>
  105. - Initial spec file.