popt-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: C library for parsing command line parameters
  3. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  4. Name: popt
  5. Version: 1.16
  6. Release: 3%{?_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://www.rpm5.org/
  10. Source0: http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
  11. Patch0: popt-1.16-pkgconfig.patch
  12. Patch1: popt-1.16-execfail.patch
  13. Patch2: popt-1.16-man-page.patch
  14. Patch3: popt-1.16-help.patch
  15. Patch4: popt-1.16-nextarg-memleak.patch
  16. Patch5: popt-1.16-glob-error.patch
  17. BuildRequires: gettext
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. Popt is a C library for parsing command line parameters. Popt was
  23. heavily influenced by the getopt() and getopt_long() functions, but
  24. it improves on them by allowing more powerful argument expansion.
  25. Popt can parse arbitrary argv[] style arrays and automatically set
  26. variables based on command line arguments. Popt allows command line
  27. arguments to be aliased via configuration files and includes utility
  28. functions for parsing arbitrary strings into argv[] arrays using
  29. shell-like rules.
  30. %description -l ja
  31. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  32. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  33. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  34. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  35. ライン引数に基づいて変数を自動的に設定します。
  36. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  37. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  38. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  39. %package devel
  40. Summary: Development files for the popt library
  41. Summary(ja): popt ライブラリの開発ファイル
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. %description devel
  45. The popt-devel package includes header files and libraries necessary
  46. for developing programs which use the popt C library. It contains the
  47. API documentation of the popt library, too.
  48. %package static
  49. Summary: Static library for %{name}
  50. Summary(ja): %{name} のスタティックライブラリ
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. %description static
  54. The %{name}-static package contains the static library for %{name}.
  55. %package -n compat32-%{name}
  56. Summary: A C library for parsing command line parameters.
  57. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. %description -n compat32-%{name}
  61. Popt is a C library for parsing command line parameters. Popt was
  62. heavily influenced by the getopt() and getopt_long() functions, but it
  63. improves on them by allowing more powerful argument expansion. Popt
  64. can parse arbitrary argv[] style arrays and automatically set
  65. variables based on command line arguments. Popt allows command line
  66. arguments to be aliased via configuration files and includes utility
  67. functions for parsing arbitrary strings into argv[] arrays using
  68. shell-like rules.
  69. %description -n compat32-%{name} -l ja
  70. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  71. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  72. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  73. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  74. ライン引数に基づいて変数を自動的に設定します。
  75. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  76. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  77. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  78. %package -n compat32-%{name}-devel
  79. Summary: Development files for the popt library
  80. Summary(ja): popt ライブラリの開発ファイル
  81. Group: Development/Libraries
  82. Requires: compat32-%{name} = %{version}-%{release}
  83. Requires: %{name}-devel = %{version}-%{release}
  84. %description -n compat32-%{name}-devel
  85. The popt-devel package includes header files and libraries necessary
  86. for developing programs which use the popt C library. It contains the
  87. API documentation of the popt library, too.
  88. %prep
  89. %autosetup
  90. sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
  91. %ifarch x86_64
  92. #sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
  93. #sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
  94. %endif
  95. %build
  96. %configure --libdir=/%{_lib}
  97. make %{?_smp_mflags}
  98. %install
  99. rm -rf $RPM_BUILD_ROOT
  100. make DESTDIR=$RPM_BUILD_ROOT install
  101. # Move libpopt.{so,a} to %{_libdir}
  102. rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
  103. pushd $RPM_BUILD_ROOT/%{_lib}
  104. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  105. ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
  106. popd
  107. mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
  108. mv -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}/
  109. # Multiple popt configurations are possible
  110. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
  111. %find_lang %{name}
  112. %check
  113. make check
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %post -p /sbin/ldconfig
  117. %postun -p /sbin/ldconfig
  118. %post -n compat32-%{name} -p /sbin/ldconfig
  119. %postun -n compat32-%{name} -p /sbin/ldconfig
  120. %files -f %{name}.lang
  121. %defattr(-,root,root)
  122. %license COPYING
  123. %doc CHANGES
  124. %{_sysconfdir}/popt.d
  125. /%{_lib}/libpopt.so.*
  126. %files devel
  127. %defattr(-,root,root)
  128. %doc README
  129. %{_libdir}/libpopt.so
  130. %{_libdir}/pkgconfig/popt.pc
  131. %{_includedir}/popt.h
  132. %{_mandir}/man3/popt.3*
  133. %files static
  134. %defattr(-,root,root)
  135. %{_libdir}/libpopt.a
  136. %if %{build_compat32}
  137. %files -n compat32-%{name}
  138. %defattr(-,root,root)
  139. /%{_lib}/libpopt.so.*
  140. %files -n compat32-%{name}-devel
  141. %defattr(-,root,root)
  142. %{_libdir}/libpopt.so
  143. %endif
  144. %changelog
  145. * Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16-3
  146. - imported Patch0-5 from rawhide.
  147. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-2
  148. - rebuild with VineSeed environment
  149. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
  150. - update to 1.16
  151. - create %{name}-static sub package
  152. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
  153. - rebuilt with rpm-4.8.1-3
  154. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
  155. - rebuilt with new toolchain
  156. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
  157. - updated Requires: and %%files section on compat32 subpackages
  158. * Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
  159. - added %%define build_compat32
  160. - fixed compat32 directories
  161. * Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
  162. - initial build for Vine Linux
  163. - splitted out from rpm, based on rpm5.org source.
  164. - move libpopt to /lib[64] from /usr/lib[64]
  165. - initscripts-8 uses libpopt.
  166. * Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
  167. - Solved multilib problems at doxygen generated files (#342921)
  168. * Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
  169. - Revert the broken bind_textdomain_codeset() patch (#433324)
  170. * Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
  171. - Added patch to work around missing bind_textdomain_codeset()
  172. * Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
  173. - Upgrade to 1.13 (#290531, #332201, #425803)
  174. - Solved multilib problems at doxygen generated files (#342921)
  175. * Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
  176. - Added buildrequirement to graphviz (#249352)
  177. - Backported bugfixes from CVS (#102254, #135428 and #178413)
  178. * Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
  179. - Move libpopt to /lib[64] (#249814)
  180. - Generate API documentation, added buildrequirement to doxygen
  181. * Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
  182. - Changes to match with Fedora Packaging Guidelines (#249352)
  183. * Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
  184. - release popt-1.12 through rpm5.org.
  185. * Sat Jun 9 2007 Jeff Johnson <jbj@rpm5.org>
  186. - release popt-1.11 through rpm5.org.
  187. * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
  188. - released 1.2.2; see CHANGES
  189. * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
  190. - added man page to default install
  191. * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
  192. - see CHANGES file for 1.2
  193. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  194. - added ./configure step to spec file