podofo-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196
  1. Name: podofo
  2. Version: 0.9.6
  3. Release: 1%{?_dist_release}
  4. Summary: Tools and libraries to work with the PDF file format
  5. Group: Applications/Publishing
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPLv2+
  9. URL: http://podofo.sourceforge.net
  10. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  11. # Fix failure to detect FreeType
  12. Patch0: podofo-0.9.4-freetype.patch
  13. # Don't attempt to copy non-existing testdata dir
  14. Patch1: podofo_tests.patch
  15. # Fix pkg-config file
  16. Patch2: podofo_pkgconfig.patch
  17. # Backport patch for CVE-2018-5783
  18. # https://sourceforge.net/p/podofo/code/1949
  19. Patch10: podofo_CVE-2018-5783.patch
  20. # Backport patch for CVE-2018-11254
  21. # https://sourceforge.net/p/podofo/code/1941
  22. Patch11: podofo_CVE-2018-11254.patch
  23. # Backport patch for CVE-2018-11255
  24. # https://sourceforge.net/p/podofo/code/1952
  25. Patch12: podofo_CVE-2018-11255.patch
  26. # Backport patch for CVE-2018-11256
  27. # https://sourceforge.net/p/podofo/code/1938
  28. Patch13: podofo_CVE-2018-11256.patch
  29. # Backport patch for CVE-2018-12982
  30. # https://sourceforge.net/p/podofo/code/1948
  31. Patch14: podofo_CVE-2018-12982.patch
  32. # Backport patch for CVE-2018-14320
  33. # https://sourceforge.net/p/podofo/code/1953
  34. Patch15: podofo_CVE-2018-14320.patch
  35. # Backport patch for CVE-2018-19532
  36. # https://sourceforge.net/p/podofo/code/1950
  37. Patch16: podofo_CVE-2018-19532.patch
  38. # Backport patch for CVE-2018-20751
  39. # https://sourceforge.net/p/podofo/code/1954
  40. Patch17: podofo_CVE-2018-20751.patch
  41. # Backport patch for CVE-2019-9199
  42. # https://sourceforge.net/p/podofo/code/1971/
  43. Patch18: podofo_CVE-2019-9199.patch
  44. # Backport patch for CVE-2019-9687
  45. # https://sourceforge.net/p/podofo/code/1969
  46. Patch19: podofo_CVE-2019-9687.patch
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  48. BuildRequires: cmake
  49. BuildRequires: zlib-devel
  50. BuildRequires: libjpeg-turbo-devel
  51. BuildRequires: libtiff-devel
  52. BuildRequires: libpng-devel
  53. BuildRequires: freetype2-devel
  54. BuildRequires: fontconfig-devel
  55. BuildRequires: cppunit-devel
  56. BuildRequires: lua-devel
  57. BuildRequires: doxygen
  58. %description
  59. PoDoFo is a library to work with the PDF file format. The name comes from
  60. the first letter of PDF (Portable Document Format). A few tools to work
  61. with PDF files are already included in the PoDoFo package.
  62. The PoDoFo library is a free, portable C++ library which includes classes
  63. to parse PDF files and modify their contents into memory. The changes can be
  64. written back to disk easily. The parser can also be used to extract
  65. information from a PDF file (for example the parser could be used in a PDF
  66. viewer). Besides parsing PoDoFo includes also very simple classes to create
  67. your own PDF files. All classes are documented so it is easy to start writing
  68. your own application using PoDoFo.
  69. %package libs
  70. Summary: Runtime library for %{name}
  71. Group: System Environment/Libraries
  72. License: LGPLv2+
  73. %description libs
  74. Runtime library for %{name}.
  75. %package devel
  76. Summary: Development files for %{name} library
  77. Group: Development/Libraries
  78. License: LGPLv2+
  79. Requires: %{name}-libs = %{version}-%{release}
  80. %description devel
  81. Development files and documentation for the %{name} library.
  82. %prep
  83. %autosetup -p1
  84. # disable timestamps in docs
  85. echo "HTML_TIMESTAMP = NO" >> Doxyfile
  86. %build
  87. %cmake -DPODOFO_BUILD_SHARED=1 \
  88. %ifarch x86_64 ppc64 s390x sparc64
  89. -DWANT_LIB64=1 \
  90. %endif
  91. .
  92. %__make %{?_smp_mflags}
  93. # build the docs
  94. doxygen
  95. # set timestamps on generated files to some constant
  96. find doc/html -exec touch -r %{SOURCE0} {} \;
  97. %install
  98. %__rm -rf $RPM_BUILD_ROOT
  99. %__make install DESTDIR=$RPM_BUILD_ROOT
  100. %clean
  101. %__rm -rf $RPM_BUILD_ROOT
  102. %post libs -p /sbin/ldconfig
  103. %postun libs -p /sbin/ldconfig
  104. %files
  105. %defattr(-,root,root,-)
  106. %license COPYING
  107. %{_bindir}/%{name}*
  108. %{_mandir}/man1/%{name}*.1*
  109. %files libs
  110. %defattr(-,root,root,-)
  111. %license COPYING.LIB COPYING.exception
  112. %doc AUTHORS ChangeLog FAQ.html README.html TODO
  113. %{_libdir}/*.so.*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %doc doc/html examples
  117. %{_includedir}/%{name}
  118. %{_libdir}/*.so
  119. %{_libdir}/pkgconfig/*
  120. %changelog
  121. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.6-1
  122. - new upstream release.
  123. - dropped Patch0: fixed in upstream.
  124. - dropped Patch1.
  125. - imported Patch0-19 from rawhide.
  126. * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-3
  127. - rebuild with gcc-5.4.0
  128. * Sat Sep 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.1-2
  129. - rebuilt with libpng-1.6.12
  130. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  131. - added Patch1 from Fedora rawhide
  132. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  133. - updated to 0.9.1
  134. * Tue Aug 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.1-1
  135. - initial build based on Fedora development
  136. * Tue Jun 8 2010 Dan Horák <dan[at]danny.cz> 0.8.1-2
  137. - fix building tests
  138. * Mon Jun 7 2010 Dan Horák <dan[at]danny.cz> 0.8.1-1
  139. - updated to 0.8.1
  140. * Thu Apr 29 2010 Dan Horák <dan[at]danny.cz> 0.8.0-1
  141. - updated to 0.8.0
  142. * Tue Feb 16 2010 Dan Horák <dan[at]danny.cz> 0.7.0-4
  143. - set timestamp on generated docs (#565683)
  144. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-3
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  146. * Thu Apr 30 2009 Dan Horák <dan[at]danny.cz> 0.7.0-2
  147. - remove BR: openssl-devel, it could be required in the future (but then
  148. an exception clause will be added to the licenses)
  149. - add missing doc files
  150. * Sun Mar 29 2009 Dan Horák <dan[at]danny.cz> 0.7.0-1
  151. - initial Fedora package