po-mode-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267
  1. %define origname po-mode
  2. Summary: Emacs Lisp for editing po file of gettext
  3. Summary(ja): gettextの po ファイルを編集するための Emacs Lisp
  4. Name: po-mode
  5. Version: 0.19.8.1
  6. Release: 1%{?_dist_release}
  7. License: GPLv3 and LGPLv2+
  8. Group: Applications/Editors/Emacs
  9. URL: http://www.gnu.org/software/gettext/
  10. Source: ftp://ftp.gnu.org/gnu/gettext/gettext-%{version}.tar.xz
  11. Source1: po-mode-init.el
  12. Source3: %{origname}-install.sh
  13. Source4: %{origname}-remove.sh
  14. Source5: vine-default-%{origname}.el
  15. Requires(post): emacsen, emacsen-common >= 0.1
  16. Requires: emacsen
  17. Buildroot: %{_tmppath}/%{name}-%{version}-root
  18. BuildArch: noarch
  19. Packager: iwaim
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. Emacs Lisp for editing po file of gettext
  24. %description -l ja
  25. gettext の po ファイルを編集するための Emacs Lisp です.
  26. %prep
  27. %setup -q -n gettext-%{version}
  28. %build
  29. %install
  30. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  31. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  32. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
  33. mkdir -p %{buildroot}%{emacsen_pkgdir}/install
  34. mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
  35. #
  36. # install el files
  37. #
  38. pushd gettext-tools/misc
  39. cp -p *.el %{SOURCE1} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  40. popd
  41. #
  42. # install script (bytecompile el and install elc , remove)
  43. #
  44. %_installemacsenscript %{origname} %{SOURCE3}
  45. %_removeemacsenscript %{origname} %{SOURCE4}
  46. %clean
  47. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  48. %post
  49. if [ "$1" = 2 ]; then
  50. %_emacsenPackageRemove %{origname}
  51. fi
  52. %_addemacsenlist %{origname}
  53. %_emacsenPackageInstall %{origname}
  54. %preun
  55. if [ "$1" = 0 ]; then
  56. %_emacsenPackageRemove %{origname}
  57. %_removeemacsenlist %{origname}
  58. fi
  59. %files
  60. %defattr(-,root,root,-)
  61. %doc AUTHORS COPYING THANKS NEWS
  62. %doc gettext-tools/misc/ChangeLog
  63. %{_datadir}/emacs/site-lisp/%{origname}
  64. %{emacsen_pkgdir}/install/%{origname}
  65. %{emacsen_pkgdir}/remove/%{origname}
  66. %changelog
  67. * Fri Feb 10 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.19.8.1
  68. - update to 0.19.8.1
  69. * Fri Apr 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.19.4-1
  70. - new upstream release
  71. * Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 0.18.1.1-1
  72. - new upstream release
  73. - drop using forward-line patch (Patch0): upstream fixed
  74. - add Requires: emacsen
  75. * Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
  76. - split from gettext package: [VineSeed:20076]
  77. - add Packager
  78. - replace Prereq to Requires(post)
  79. - add using forward-line patch (Patch0): <BTS:VineLinux:934>
  80. * Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
  81. - correct some output messages on po-mode-install.sh
  82. - use %%emacsen_pkgdir
  83. * Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
  84. - we better not to use BuildConflicts very often :-P
  85. instead we pass --disable-java to configure here
  86. - add --enable-shared --disable-static --without-included-gettext to configure
  87. - remove .la files
  88. - add -devel and --libs subpackages
  89. * Wed May 6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
  90. - apply vine-default
  91. - update po-mode-init.el (Source1)
  92. - update po-mode-install.sh (Source3)
  93. - update po-mode-remove.sh (Source4)
  94. - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
  95. - update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
  96. * Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
  97. - new upstream release
  98. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
  99. - applied new versioning policy, spec in utf-8
  100. * Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
  101. - changelog update missing
  102. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
  103. - new upstream release
  104. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
  105. - changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  106. * Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
  107. - add BuildConflicts: libgcj34-devel not to depend on libgcj34
  108. * Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
  109. - add BuildConflicts: libgcj-devel not to depend on libgcj
  110. - add BuildRequires: emacsen (if emacsen_pkg is enabled)
  111. - remove unneeded files at the %%install
  112. * Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
  113. - rebuilt without libgcj package
  114. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
  115. - modified emacsen-common path
  116. * Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
  117. - new upstream release
  118. - updated Source3
  119. - added --disable-csharp
  120. * Wed Apr 7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
  121. - remove dependency to libgcj
  122. * Wed Apr 7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
  123. - new upstream release
  124. * Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
  125. - build without libgcj package
  126. - create po-mode package for Emacsen
  127. * Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
  128. - based on Redhat Rawhide 0.12.1-1
  129. - dropped all patches (Rawhide does so)
  130. - Source100(ja.po) is much older than source, dropped
  131. - s/Copyright/License/
  132. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
  133. - new upstream release
  134. * Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  135. - sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
  136. * Wed Jun 7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  137. - sync with RH6.2
  138. * Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
  139. - minor configure tweaks for ia64
  140. * Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
  141. - add --comments to msghack
  142. * Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
  143. - fix bug #9240 - gettextize has the right aclocal patch
  144. * Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
  145. - add the --diff and --dummy options
  146. * Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
  147. - add the --missing option to msghack
  148. * Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
  149. - updated msghack not to merge in fuzzies in the master catalogs
  150. * Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
  151. - update ja.po
  152. * Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
  153. - use message.c.diff-2
  154. * Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
  155. - updated msghack to understand --append
  156. * Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
  157. - updated msghack to correctly deal with sorting files
  158. * Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
  159. - added multibyte patch for msgmerge
  160. * Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
  161. - ja locale support from JaPO Project
  162. * Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
  163. - msghack updates
  164. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  165. - auto rebuild in the new build environment (release 8)
  166. * Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
  167. - added patch for misc hacks to facilitate rpm translations
  168. * Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
  169. - patch to allow to build on ARM
  170. * Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
  171. - add Emacs po-mode.el files.
  172. * Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
  173. - include the aclocal support files
  174. * Fri Sep 3 1998 Bill Nottingham <notting@redhat.com>
  175. - remove devel package (functionality is in glibc)
  176. * Tue Sep 1 1998 Jeff Johnson <jbj@redhat.com>
  177. - update to 0.10.35.
  178. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  179. - add gettextize.
  180. - create devel package for libintl.a and libgettext.h.
  181. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  182. - translations modified for de, fr, tr
  183. * Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
  184. - added info handling
  185. - added misc-patch (skip emacs-lisp modofications)
  186. * Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
  187. - removed locale.aliases as we get it from glibc now
  188. - uses a buildroot
  189. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  190. - Built against glibc