plan-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %define ver 1.8.7
  2. %define rel 0vl5
  3. Summary: an X/Motif calendar and day planner
  4. Summary(ja): X/Motif を用いた高機能スケジューラ
  5. Name: plan
  6. Version: %{ver}
  7. Release: %{rel}
  8. Source: ftp://ftp.fu-berlin.de/pub/unix/graphics/plan/plan-%{ver}.tar.gz
  9. # vine sources
  10. Source1: Plan.vine.ad
  11. Source2: holiday_japan_EUC
  12. Source3: plan-1.8.3.lang.japanese
  13. # from vine-users:023414
  14. Source4: plan_calEUC.ps
  15. Source5: netplan.boot
  16. Source6: plan.sh
  17. Source7: netplangrpadd.sh
  18. Source8: plan.README.vine
  19. # vine patches
  20. Patch: plan-1.8.7-jp.vine.patch
  21. #jp patch is merged with http://cgi.shikoku.ne.jp/~fun/srpms.html
  22. Patch1: plan-1.8.7-jp.patch
  23. Patch2: plan-1.8.7-netplan.patch
  24. Patch3: plan-1.8.4-makefile.patch
  25. URL: http://www.IN-Berlin.DE/User/bitrot/plan.html
  26. License: distributable
  27. Group: Applications/Productivity
  28. Buildroot: %{_tmppath}/%{name}-root
  29. BuildPrereq: openMotif-devel, byacc, flex
  30. Requires: openMotif
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. Plan is a schedule planner based on X/Motif. It also works with
  35. lesstif instead of Motif. It displays a month calendar similar to
  36. xcal, but every day box is large enough to show appointments in small
  37. print. By pressing on a day box, the appointments for that day can
  38. be listed and edited.
  39. %description -l ja
  40. PlanはX/Motifを用いた高機能スケジューラです.月表示,週表示,一日表示等が
  41. でき,ネットワークを介したグループでの利用もできます.Apple Newton PDA や
  42. PalmPilot PDA とのファイル交換もできます.利用には openMotif が必要です。
  43. netplan を利用するときには、netplan.dir として /home/netplan を利用する
  44. ように設定してあります。
  45. %prep
  46. rm -rf %{buildroot}
  47. %setup -n plan-%{ver}
  48. %patch -p1
  49. %patch1 -p1
  50. %patch2 -p1
  51. # %patch3 -p1
  52. cp %{SOURCE3} language/plan.lang.japanese
  53. cp %{SOURCE4} misc/plan_cal.ps
  54. cp %{SOURCE8} README.vine
  55. %build
  56. chPath(){
  57. for i in $*; do
  58. sed -e "s|/usr/local/bin|/usr/bin|g" \
  59. -e "s|/usr/local/lib/netplan.dir|/home/netplan|g" \
  60. -e "s|/usr/local/lib|%{_libdir}/plan|g" \
  61. -e "s|\!/usr/local/bin/perl|\!/usr/bin/perl|g" \
  62. -e "s|\!/bin/perl|\!/usr/bin/perl|g" \
  63. -e "s|\!/usr/bin/sed|\!/bin/sed|g" \
  64. -e "s|\! /usr/local/bin/perl|\!/usr/bin/perl|g" \
  65. -e "s|\! /bin/perl|\!/usr/bin/perl|g" \
  66. -e "s|\! /usr/bin/sed|\!/bin/sed|g" \
  67. $i > $i.new
  68. mv $i.new $i
  69. done
  70. }
  71. (cd misc
  72. chPath vsc cvs Mkdoc msschedule2plan Killpland
  73. )
  74. cp %{SOURCE2} holiday/holiday_japan
  75. (cd src
  76. make linux
  77. )
  78. (
  79. cd web
  80. for i in *.cgi common.pl; do
  81. chPath $i
  82. done
  83. )
  84. %install
  85. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  86. mkdir -p %{buildroot}/usr/X11R6/lib/X11/app-defaults
  87. install -m 644 %{SOURCE1} %{buildroot}/usr/X11R6/lib/X11/app-defaults/Plan
  88. (cd src
  89. mkdir -p %{buildroot}/usr/{bin,lib}
  90. mkdir -p %{buildroot}%{_libdir}/plan
  91. mkdir -p %{buildroot}/home/netplan
  92. make DESTDIR=%{buildroot} install
  93. )
  94. mv %{buildroot}%{_bindir}/plan %{buildroot}%{_bindir}/plan.bin
  95. install -m 755 %{SOURCE6} %{buildroot}%{_bindir}/plan
  96. install -m 755 %{SOURCE7} %{buildroot}%{_sbindir}/netplangrpadd
  97. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  98. install -m 755 %{SOURCE5} %{buildroot}%{_sysconfdir}/rc.d/init.d/netplan
  99. (cd web
  100. mkdir -p %{buildroot}/home/httpd/html/plan/
  101. install -m 755 *.cgi %{buildroot}/home/httpd/html/plan/
  102. install -m 644 *.pl %{buildroot}/home/httpd/html/plan/
  103. install -m 644 *.{html,jpg} holiday_webplan %{buildroot}/home/httpd/html/plan/
  104. )
  105. (cd misc
  106. install -m 755 msschedule2plan Killpland %{buildroot}%{_bindir}
  107. mkdir -p %{buildroot}%{_mandir}/{man1,man4}
  108. install *.1 %{buildroot}%{_mandir}/man1
  109. install *.4 %{buildroot}%{_mandir}/man4
  110. #prepare for doc
  111. rm *.1 *.4 *cat msschedule2plan Killpland *.ps
  112. )
  113. cat > %{buildroot}/home/netplan/.netplan-acl<<EOF
  114. #Examples(see man netplan in detail)
  115. #*: permit read
  116. #*: permit write host daphne
  117. #thomas: deny user *
  118. #thomas: permit read write delete user 207 208
  119. #announce: permit write netmask 255.255.255.0 host 10.0.1.0
  120. #
  121. *: permit read
  122. EOF
  123. %clean
  124. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  125. %files
  126. %defattr(-,root,root)
  127. %doc README* HISTORY holiday/
  128. %doc misc/
  129. %{_sysconfdir}/rc.d/init.d/netplan
  130. /home/httpd/html/plan/
  131. /usr/X11R6/lib/X11/app-defaults/Plan
  132. %{_bindir}/plan
  133. %{_bindir}/plan.bin
  134. %{_bindir}/msschedule2plan
  135. %{_bindir}/Killpland
  136. %attr(755,-,-)%dir %{_libdir}/plan/
  137. %{_libdir}/plan/pland
  138. %{_libdir}/plan/notifier
  139. %{_libdir}/plan/plan.help
  140. %{_libdir}/plan/plan.lang.*
  141. %{_libdir}/plan/plan*.ps
  142. %{_sbindir}/netplan
  143. %{_sbindir}/netplangrpadd
  144. %attr(1700,nobody,nobody)%dir /home/netplan/
  145. %attr(-,nobody,nobody)%config(noreplace) /home/netplan/.netplan-acl
  146. %{_mandir}/man1/plan.1*
  147. %{_mandir}/man1/netplan.1*
  148. %{_mandir}/man4/plan.4*
  149. %changelog
  150. * Tue Oct 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.8.7-0vl5
  151. - rebuilt for Vine Linux 4.0
  152. - s/Copyright/License/
  153. - added %clean section
  154. * Sat Mar 12 2005 Jun NISHII <jun@vinelinux.org> 1.8.7-0vl4
  155. - build on Vine 3.1
  156. - added byacc, flex in BuildPreReq
  157. * Wed Feb 23 2005 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl3
  158. - fix plan.sh
  159. - update holiday_japan
  160. * Tue Feb 22 2005 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl2
  161. - update holiday_japan
  162. * Mon Oct 27 2003 Jun Nishii <jun@vinelinux.org> 1.8.7-0vl1
  163. - ver.up
  164. * Mon Jun 2 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl6
  165. - build with openMotif
  166. * Mon Feb 17 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl5
  167. - update holiday_japan
  168. * Wed Jan 22 2003 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl4
  169. - plan-1.8.4-jp2.vine.patch (fix locale handling for printing)
  170. - smaller default fonts in month view
  171. * Fri Jan 18 2002 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl3
  172. - rebuild with gcc-2.95.3
  173. - update holiday_japan
  174. * Wed May 9 2001 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl2
  175. - fix LOCALE_EUC as ja_JP.eucJP
  176. - use more macros in spec
  177. * Fri Apr 20 2001 Jun Nishii <jun@vinelinux.org> 1.8.4-0vl1
  178. - ver.up
  179. - move netplan.dir to /home/netplan
  180. - many improvements
  181. * Tue Feb 6 2001 Jun Nishii <jun@vinelinux.org>
  182. - 1.8.3-0vl4
  183. - fix path in common.pl
  184. * Fri Oct 6 2000 Jun Nishii <jun@vinelinux.org>
  185. - 1.8.3-0vl3
  186. - updated holiday_japan
  187. * Wed Jun 14 2000 Jun Nishii <jun@vinelinux.org>
  188. - 1.8.3-0vl2
  189. - merge plan_calEUC.ps from vine-useres:023414
  190. * Fri Feb 11 2000 Jun Nishii <jun@vinelinux.org>
  191. - 1.8.3
  192. - merge japanese patch from http://cgi.shikoku.ne.jp/~fun/srpms.html