pilot-link-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318
  1. %define ver 0.12.5
  2. %define srcver %{ver}
  3. %define rel 4%{?_dist_release}
  4. %define support_perl 0
  5. Name: pilot-link
  6. Summary: File transfer utilities between Linux and PalmPilots.
  7. Summary(ja): Linux と Palm handheld device を接続する為のユーティリティ
  8. Version: %{ver}
  9. Release: %{rel}
  10. Epoch: 1
  11. # libpisock/md5.c Public Domain
  12. # libpisock/blob.c LGPLv2+
  13. # libpisock/contact.c GPLv2
  14. # kittykiller.c GPLv2+
  15. License: GPLv2 and GPLv2+ and LGPLv2+ and Public Domain
  16. Group: Applications/Communications
  17. URL: http://www.pilot-link.org/
  18. Source0: http://downloads.pilot-link.org/pilot-link-%{version}.tar.bz2
  19. Source1: connect-palm-ppp.tar.bz2
  20. Source2: 60-libpisock.rules.vine
  21. Source3: 60-pilot.perms
  22. Patch0: pilot-link-0.12.1-var.patch
  23. Patch1: pilot-link-0.12.2-open.patch
  24. Patch2: pilot-link-0.12.3-clio.patch
  25. Patch3: pilot-link-0.12.5-mp.patch
  26. Patch4: pilot-link-0.12.5-redefinePerlsymbols.patch
  27. Patch5: pilot-link-0.12.5-compiler_warnings.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: bison >= 1.35
  30. BuildRequires: libusb-devel >= 0.1
  31. BuildRequires: libpng-devel
  32. BuildRequires: readline-devel
  33. BuildRequires: bluez-libs-devel
  34. BuildRequires: popt-devel
  35. %if %{support_perl}
  36. BuildRequires: perl
  37. %endif
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. This suite of tools allows you to upload and download programs and
  42. data files between a Linux/UNIX machine and the PalmPilot. It has a
  43. few extra utils that will allow for things like syncing the
  44. PalmPilot's calendar app with Ical. Note that you might still need to
  45. consult the sources for pilot-link if you would like the Python, Tcl,
  46. or Perl bindings.
  47. Install pilot-link if you want to synchronize your Palm with your Vine
  48. Linux system.
  49. %description -l ja
  50. このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
  51. プログラムやファイルを転送することができます。このツールには、Palm
  52. handheld device の予定表と Ical との間で同期を可能にするようないくつ
  53. かのユーティリティが付属しています。もし Python や Tcl、あるいは
  54. Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
  55. あることに注意してください。
  56. Palm handheld device を Vine Linux システムで同期させたい場合は
  57. pilot-link をインストールします。
  58. %package libs
  59. Summary: PalmPilot libraries
  60. Summary(ja): Palm handheld ライブラリ
  61. Group: System Environment/Libraries
  62. %description libs
  63. Libraries for applications communicating with PalmPilot
  64. %package devel
  65. Summary: PalmPilot development header files.
  66. Summary(ja): Palm handheld プログラム開発用のヘッダ ファイル
  67. Group: Development/Libraries
  68. Requires: %{name}-libs = %{epoch}:%{version}-%{release}
  69. %description devel
  70. This package contains the development headers that are used to build
  71. the pilot-link package.
  72. If you want to develop PalmPilot synchronizing applications, you'll
  73. need to install pilot-link-devel.
  74. %description devel -l ja
  75. このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
  76. ヘッダファイルが含まれます。
  77. Palm handheld deviceと同期するアプリケーションを開発したい場合は、
  78. pilot-link-devel パッケージをインストールする必要があります。
  79. %prep
  80. %setup -q -a 1
  81. %patch0 -p1 -b .var
  82. %patch1 -p1 -b .open
  83. %patch2 -p1 -b .clio
  84. %patch3 -p1 -b .mp
  85. %patch4 -p1 -b .symbol
  86. %patch5 -p1 -b .compiler
  87. iconv -f windows-1252 -t UTF8 doc/README.usb > doc/README.usb.aux
  88. mv doc/README.usb.aux doc/README.usb
  89. iconv -f windows-1252 -t UTF8 ChangeLog > ChangeLog.aux
  90. mv ChangeLog.aux ChangeLog
  91. iconv -f windows-1252 -t UTF8 NEWS > NEWS.aux
  92. mv NEWS.aux NEWS
  93. %build
  94. %configure \
  95. --disable-static \
  96. --enable-conduits \
  97. --enable-libusb \
  98. --with-libpng \
  99. --with-bluez \
  100. --without-python \
  101. --without-tcl \
  102. --without-java \
  103. %if %{support_perl}
  104. --with-perl
  105. %else
  106. --without-perl
  107. %endif
  108. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  109. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  110. make %{?_smp_mflags}
  111. %install
  112. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  113. make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
  114. make install -C doc/man DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir}
  115. %if %{support_perl}
  116. if test -f bindings/Perl/Makefile.PL ; then
  117. cd bindings/Perl
  118. perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
  119. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
  120. make
  121. cd ../..
  122. fi
  123. %endif
  124. %if %{support_perl}
  125. make install -C bindings/Perl
  126. rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
  127. $RPM_BUILD_ROOT%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
  128. %endif
  129. # install modified udev rules.
  130. #mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
  131. #install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
  132. # remove files we don't want to include
  133. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  134. # remove broken prog
  135. rm -f $RPM_BUILD_ROOT%{_bindir}/pilot-prc
  136. # install visor configs to share/udev
  137. install -p -m644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/pilot-link/udev
  138. # now that rules are moved out HAL, install to /lib/udev/
  139. install -d $RPM_BUILD_ROOT/lib/udev/rules.d/
  140. install -p -m644 %{SOURCE2} $RPM_BUILD_ROOT/lib/udev/rules.d/60-libpisock.rules
  141. %post libs -p /sbin/ldconfig
  142. %postun libs -p /sbin/ldconfig
  143. %clean
  144. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  145. %files
  146. %defattr(-,root,root)
  147. %doc COPYING ChangeLog README NEWS AUTHORS doc/README.*
  148. %{_bindir}/*
  149. %{_mandir}/man1/*
  150. %files libs
  151. %defattr(-,root,root)
  152. %doc COPYING.LIB
  153. /lib/udev/rules.d/60-libpisock.rules
  154. #{_sysconfdir}/udev/rules.d/60-libpisock.rules
  155. %{_libdir}/*.so.*
  156. %if %{support_perl}
  157. %{_libdir}/perl5/vendor_perl/*/*/*/PDA
  158. %{_libdir}/perl5/vendor_perl/*/*/PDA
  159. %endif
  160. %{_datadir}/pilot-link
  161. %{_mandir}/man7/*
  162. %files devel
  163. %defattr(-, root, root)
  164. %{_libdir}/*.so
  165. #{_libdir}/*.la
  166. %{_libdir}/pkgconfig/pilot-link.pc
  167. %{_includedir}/*
  168. %{_datadir}/aclocal/*.m4
  169. %changelog
  170. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-4
  171. - rebuild with readline-6.3
  172. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.12.5-3
  173. - added Patch1, 2, 3, 4 and 5 from Fedora
  174. - added Source3 from Fedora
  175. - built with libpng 1.6.12
  176. - updated devel description
  177. - moved main package to Applications/Communications Group
  178. * Sat Sep 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.12.5-2
  179. - rebuilt with current environment
  180. * Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.5-1
  181. - new upstream release
  182. - split libraries to subpackage
  183. - built with rpm-4.8.1 for pkg-config
  184. - added URL tag
  185. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
  186. - new upstream release
  187. - removed static libraries from devel package
  188. - added --with-bluez to %%configure (added also BR: bluez-libs-devel)
  189. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
  190. - applied new versioning policy, spec in utf-8
  191. * Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
  192. - add modified udev rules (Source2). <BTS:VineLinux:222>
  193. * Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
  194. - source update.
  195. - change Group to Applications/Other
  196. - use %%configure macro instead of ./configure
  197. - delete unused configure options for itcl and tk.
  198. - use '%%__make install' to use DESTDIR variable.
  199. - comment out '%%makeinstall -C doc/man'(not required to install man).
  200. - add 60-libpisock.rules for udev in %%files.
  201. - add pilot-link.pc in %%files for -devel.
  202. - add Requires libusb and BuildRequires libusb-devel >= 0.1.
  203. * Fri Jan 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
  204. - rebuild for VineSeed
  205. - add "%%{epoch}:" to Requires in pilot-link-devel
  206. * Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
  207. - convert spec from SJIS to EUC.
  208. * Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
  209. - source update
  210. - add japanese translation(summary & description).
  211. - use License tag instead of Copyright.
  212. - change BuildRequires XFree86-devel to XOrg-devel.
  213. - add BuildRequires readline-devel.
  214. - add new Patch9.(avoid make error "undefined reference to `pow'")
  215. * Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
  216. - disuse %%configure macro to avoid unsuitable prefixed filename
  217. * Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
  218. - source update
  219. * Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
  220. - unfortunately added Epoch 1
  221. (the previous version was 0.9.5.pre5-0vl2. Sigh...)
  222. * Sat Oct 13 2001 <uh@u.dhis.portside.net>
  223. - 0.9.5-0vl1
  224. - upgrade to 0.9.5
  225. - add COPYING.LIB to %doc
  226. * Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
  227. - New upstream release.
  228. - Fixed defattr stuff for devel package.
  229. - Use rpmmacros.
  230. * Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
  231. - upgrade to pilot-link 0.9.3, rewrite spec.
  232. * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
  233. - strip binaries
  234. * Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
  235. - added missing files from devel subpackage
  236. * Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
  237. - move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
  238. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  239. - auto rebuild in the new build environment (release 5)
  240. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  241. - Injected new description and group.
  242. * Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
  243. - arm fix
  244. * Thu Sep 24 1998 Michael Maher <mike@redhat.com>
  245. - cleaned up spec file, updated package
  246. * Tue May 19 1998 Michael Maher <mike@redhat.com>
  247. - updated rpm
  248. * Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
  249. - added changelog
  250. - updated to 0.8.9
  251. - removed explicit requires for /usr/bin/perl