php-pear-Net-SMTP-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214
  1. %{!?__pear: %{expand: %%global __pear %{_bindir}/pear5}}
  2. %global pear_name Net_SMTP
  3. Name: php-pear-Net-SMTP
  4. Version: 1.6.1
  5. Release: 3%{?_dist_release}
  6. Summary: Provides an implementation of the SMTP protocol
  7. Group: Development/Libraries
  8. License: PHP
  9. URL: http://pear.php.net/package/Net_SMTP
  10. Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
  11. Source2: xml2changelog
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildArch: noarch
  14. BuildRequires: php-pear(PEAR) >= 1.9.1
  15. Requires(post): %{__pear}
  16. Requires(postun): %{__pear}
  17. Provides: php-pear(%{pear_name}) = %{version}
  18. Requires: php-pear(PEAR) >= 1.4.9
  19. Requires: php-pear(Net_Socket) >= 1.0.7
  20. Requires: php-pear(Auth_SASL)
  21. %description
  22. Provides an implementation of the SMTP protocol using PEAR's Net_Socket class.
  23. php-pear-Net-SMTP can optionally use package "php-pear-Auth-SASL".
  24. %prep
  25. %setup -q -c
  26. %{_bindir}/php -n %{SOURCE2} package.xml | tee CHANGELOG | head -n 2
  27. cd %{pear_name}-%{version}
  28. # package.xml is V2
  29. mv ../package.xml %{name}.xml
  30. %build
  31. cd %{pear_name}-%{version}
  32. # Empty build section, most likely nothing required.
  33. %install
  34. rm -rf %{buildroot}
  35. cd %{pear_name}-%{version}
  36. %{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
  37. # Clean up unnecessary files
  38. rm -rf %{buildroot}%{pear_phpdir}/.??*
  39. # Install XML package description
  40. %{__mkdir_p} %{buildroot}%{pear_xmldir}
  41. %{__install} -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
  42. %check
  43. # Sanity check
  44. lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print)
  45. [ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1;
  46. # For documentation purpose only
  47. # After install, as root :
  48. # cd /usr/share/pear/test/Net_SMTP/tests
  49. # cp config.php.dist config.php
  50. # vi config.php # you should use a working mail account
  51. # pear run-tests -p Net_SMTP
  52. # Should return
  53. # 3 PASSED TESTS
  54. # 0 SKIPPED TESTS
  55. %clean
  56. rm -rf %{buildroot}
  57. %post
  58. %{__pear} install --nodeps --soft --force --register-only \
  59. %{pear_xmldir}/%{name}.xml >/dev/null || :
  60. %postun
  61. if [ $1 -eq 0 ] ; then
  62. %{__pear} uninstall --nodeps --ignore-errors --register-only \
  63. %{pear_name} >/dev/null || :
  64. fi
  65. %files
  66. %defattr(-,root,root,-)
  67. %doc CHANGELOG
  68. %doc %{pear_docdir}/%{pear_name}
  69. %{pear_phpdir}/Net/*
  70. %{pear_testdir}/%{pear_name}
  71. %{pear_xmldir}/%{name}.xml
  72. %changelog
  73. * Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-3
  74. - initial build for Vine Linux
  75. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-2
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  77. * Tue Aug 16 2011 Remi Collet <Fedora@FamilleCollet.com> 1.6.1-1
  78. - Version 1.6.1 (stable) - API 1.2.0 (stable)
  79. * Fri Jun 10 2011 Remi Collet <Fedora@FamilleCollet.com> 1.6.0-1
  80. - Version 1.6.0 (stable) - API 1.2.0 (stable)
  81. * Sat Apr 17 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.2-1
  82. - Version 1.5.2 (stable) - API 1.1.3 (stable)
  83. * Fri Mar 11 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.1-1
  84. - Version 1.5.1 (stable) - API 1.1.3 (stable)
  85. - keep doc in pear_docdir
  86. * Sun Feb 13 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.0-1
  87. - Version 1.5.0 (stable) - API 1.1.3 (stable)
  88. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.4-2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  90. * Mon Oct 11 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.4-1
  91. - Version 1.4.4 (stable) - API 1.1.3 (stable)
  92. * Mon Oct 11 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.3-1
  93. - Version 1.4.3 (stable) - API 1.1.3 (stable)
  94. - set timezone during build
  95. * Tue Mar 09 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.2-1
  96. - update to 1.4.2
  97. * Mon Jan 25 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.1-1
  98. - update to 1.4.1
  99. * Sun Jan 24 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.0-1
  100. - update to 1.4.0
  101. - add examples to %%doc
  102. * Sun Nov 29 2009 Remi Collet <Fedora@FamilleCollet.com> 1.3.4-1
  103. - update to 1.3.4
  104. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  106. * Tue Jul 14 2009 Remi Collet <Fedora@FamilleCollet.com> 1.3.3-1
  107. - update to 1.3.3
  108. - rename Net_SMTP.xml to php-pear-Net-SMTP.xml
  109. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  111. * Sun Dec 21 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.2-1
  112. - update to 1.3.2
  113. * Tue Jun 10 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.1-1
  114. - update to 1.3.1
  115. - add Comment on howto to run test suite
  116. * Sun Apr 27 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.0-1
  117. - update to 1.3.0
  118. * Fri Feb 15 2008 Remi Collet <Fedora@FamilleCollet.com> 1.2.11-1
  119. - update to 1.2.11
  120. - fix License
  121. * Sat Mar 31 2007 Remi Collet <Fedora@FamilleCollet.com> 1.2.10-1
  122. - remove PEAR from sumnary
  123. - update to 1.2.10
  124. - requires Net_Socket >= 1.0.7
  125. - spec cleanup
  126. - add generated CHANGELOG
  127. - don't own /usr/share/pear/Net (already own by Net_Socket)
  128. * Fri Sep 08 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-5
  129. - last template.spec
  130. * Sun Sep 03 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-4
  131. - new and simpler %%prep and %%install
  132. * Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-3
  133. - install Licence in prep
  134. - use new macros from /etc/rpm/macros.pear
  135. - own /usr/share/pear/Net
  136. - require php >= 4.0.5
  137. * Sat May 20 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-2
  138. - Require pear >= 1.4.9
  139. - bundle the v3.01 PHP LICENSE file
  140. - use --packagingroot (instead of -R)
  141. - check from install to check (as in php-pear)
  142. - Remove Auth_SASL from Requires (optional)
  143. * Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-1
  144. - spec for extras
  145. - workaround for buggy pear 1.4.6 installer
  146. - use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
  147. * Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.2.8-3.fc{3,4,5}.remi
  148. - change /var/lib/pear to %%{_libdir}/php/pear for XML (as in extras for FC5)
  149. - spec cleanning
  150. * Sat Mar 04 2006 Remi Collet <RPMS@FamilleCollet.com> 1.2.8-2.fc{3,4}.remi
  151. - add Requires: php-pear(Auth_SASL)
  152. * Sat Feb 25 2006 Remi Collet <RPMS@FamilleCollet.com> 1.2.8-1.fc{3,4}.remi
  153. - update to 1.2.8
  154. * Sat Jan 7 2006 Remi Collet <remi.collet@univ-reims.fr> 1.2.7-1.fc{3,4}.remi
  155. - initial RPM