php-pear-Log-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. %{!?__pear: %{expand: %%global __pear /usr/bin/pear5}}
  2. %global pear_name Log
  3. Summary: Abstracted logging facility for PHP
  4. Name: php-pear-Log
  5. Version: 1.12.7
  6. Release: 1%{?_dist_release}
  7. License: MIT
  8. Group: Development/Libraries
  9. Source http://pear.php.net/get/Log-%{version}.tgz
  10. Source2: xml2changelog
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. URL: http://pear.php.net/package/Log
  13. BuildArch: noarch
  14. ## Vine's php5-pear is a subpackage from php5 (internal version 1.9.4)
  15. BuildRequires: php-pear(PEAR) >= 1.4.9
  16. Requires: php-pear(PEAR) >= 1.4.9
  17. Requires: php-pear
  18. Requires: php-pear(DB) >= 1.3
  19. Requires: php-pear(MDB2) >= 2.0.0
  20. Requires: php-pear(Mail)
  21. Requires(post): %{__pear}
  22. Requires(postun): %{__pear}
  23. Provides: php-pear(Log) = %{version}
  24. %description
  25. The Log framework provides an abstracted logging system.
  26. It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal
  27. targets. It also provides a subject - observer mechanism.
  28. php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3)
  29. and "php-pear-MDB2" (version >= 2.0.0RC1).
  30. %prep
  31. %setup -c -q
  32. %{_bindir}/php -n %{SOURCE2} package.xml | tee CHANGELOG | head -n 10
  33. cd %{pear_name}-%{version}
  34. # package.xml is V2
  35. mv ../package.xml %{name}.xml
  36. %build
  37. # Empty build section
  38. %install
  39. rm -rf %{buildroot}
  40. pushd Log-%{version}
  41. %{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
  42. # Clean up unnecessary files
  43. rm -rf %{buildroot}%{pear_phpdir}/.??*
  44. # Install XML package description
  45. install -D -p -m 644 %{name}.xml %{buildroot}%{pear_xmldir}/%{name}.xml
  46. popd
  47. %clean
  48. rm -rf %{buildroot}
  49. %check
  50. lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print)
  51. [ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1;
  52. cd %{pear_name}-%{version}
  53. %{__pear} \
  54. run-tests \
  55. -i "-d include_path=%{buildroot}%{pear_phpdir}:%{pear_phpdir}" \
  56. tests | tee ../tests.log
  57. grep "FAILED TESTS" ../tests.log && exit 1
  58. %post
  59. %{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{name}.xml >/dev/null || :
  60. %postun
  61. if [ "$1" -eq "0" ]; then
  62. %{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || :
  63. fi
  64. %files
  65. %defattr(-,root,root,-)
  66. %doc CHANGELOG
  67. %doc %{pear_docdir}/%{pear_name}
  68. %{pear_phpdir}/Log
  69. %{pear_phpdir}/Log.php
  70. %{pear_testdir}/Log
  71. %{pear_datadir}/Log
  72. %{pear_xmldir}/%{name}.xml
  73. %changelog
  74. * Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.12.7-1
  75. - initial build for Vine Linux
  76. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.7-2
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  78. * Thu Sep 22 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.7-1
  79. - Version 1.12.7 (stable) - API 1.0.0 (stable)
  80. - minor spec cleanups
  81. * Fri May 27 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.6-1
  82. - Version 1.12.6 (stable) - API 1.0.0 (stable)
  83. * Sun Apr 17 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-4
  84. - remove temporary link in doc
  85. * Wed Mar 16 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-3
  86. - doc in %%{pear_docdir}
  87. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.5-2
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  89. * Fri Dec 23 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-1
  90. - Version 1.12.5 (stable) - API 1.0.0 (stable)
  91. * Mon Dec 6 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.4-1.1
  92. - levels.phpt fails, see http://pear.php.net/bugs/18099
  93. * Mon Dec 6 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.4-1
  94. - Version 1.12.4 (stable) - API 1.0.0 (stable)
  95. * Tue Sep 28 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.3-1
  96. - Version 1.12.3 (stable) - API 1.0.0 (stable)
  97. - run tests during %%check
  98. * Sun Aug 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.2-1
  99. - Version 1.12.2 (stable) - API 1.0.0 (stable)
  100. * Sat May 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.1-1
  101. - bump release (missing sources)
  102. * Sat May 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.1-1
  103. - update to Version 1.12.1 (stable) - API 1.0.0 (stable)
  104. - type in french description
  105. * Mon Jan 25 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.0-1
  106. - update to 1.12.0
  107. * Sat Dec 26 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.6-1
  108. - update to 1.11.6
  109. * Sat Aug 08 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.5-1
  110. - update to 1.11.5
  111. - rename Log.xml to php-pear-Log.xml
  112. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11.4-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  114. * Mon Mar 30 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.4-1
  115. - update to 1.11.4
  116. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11.3-2
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  118. * Sat Nov 22 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.3-1
  119. - update to 1.11.3
  120. * Fri Sep 05 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.2-1
  121. - update to 1.11.2
  122. * Wed Aug 06 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.1-1
  123. - update to 1.11.1
  124. * Sat Jun 28 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.0-1
  125. - update to 1.11.0 : switch from PHP to MIT license
  126. * Thu May 08 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.1-1
  127. - update to 1.10.1
  128. * Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.0-1
  129. - update to 1.10.0
  130. - add Requires php-pear(Mail) (new handler)
  131. - remove levels.patch (merged upstream)
  132. * Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.16-1
  133. - update to 1.9.16
  134. - add examples in documentation
  135. - add levels.patch http://pear.php.net/bugs/bug.php?id=12933
  136. * Wed Jan 02 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.14-1
  137. - update to 1.9.14
  138. * Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1
  139. - update to 1.9.13
  140. - add documentation in %%check (post install only)
  141. * Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1
  142. - update to 1.9.12
  143. * Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2
  144. - Fix License
  145. * Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1
  146. - update to 1.9.11
  147. * Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1
  148. - update to 1.9.10
  149. - All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023
  150. * Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1
  151. - update to 1.9.9
  152. * Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6
  153. - add CHANGELOG to %%doc
  154. * Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1
  155. - rebuild for FC5
  156. * Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5
  157. - BR php-pear >= 1:1.4.9-1.2
  158. * Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4
  159. - last template.spec
  160. * Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3
  161. - new and simpler %%prep and %%install
  162. * Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2
  163. - failsafe scriplet
  164. * Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1
  165. - update to 1.9.8
  166. * Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1
  167. - update to 1.9.7
  168. - use new macros from /etc/rpm/macros.pear
  169. * Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1
  170. - install Licence in prep
  171. - update to 1.9.6
  172. * Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3
  173. - Require pear >= 1.4.9
  174. - Requires(hint): (only comment actually) + description
  175. - bundle the v3.01 PHP LICENSE file (as in php-pear)
  176. - use --packagingroot (instead of -R)
  177. - check from install to check (as in php-pear)
  178. * Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2
  179. - cleanning (description-line-too-long)
  180. * Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1
  181. - use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
  182. - update to 1.9.5
  183. - workaround for buggy pear 1.4.6 installer
  184. * Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1
  185. - spec for extras
  186. - add french summary & description
  187. * Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi
  188. - update to 1.9.4
  189. * Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi
  190. - initial RPM