pgperl-vl.spec 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. Summary: a libpq-based PostgreSQL interface for Perl
  2. Name: pgperl
  3. Version: 2.0.2
  4. Release: 2%{?_dist_release}
  5. URL: http://gborg.postgresql.org/project/pgperl/projdisplay.php
  6. Source0: ftp://gborg.postgresql.org/pub/pgperl/stable/%{name}-%{version}.tar.gz
  7. License: Perl's
  8. Group: Development/Libraries
  9. BuildRoot: %{_tmppath}/%{name}-root
  10. Requires: postgresql-libs
  11. BuildRequires: postgresql-devel perl
  12. Obsoletes: postgresql-perl
  13. %description
  14. pgperl is an interface between Perl and PostgreSQL. This uses the Perl5
  15. API for C extensions to call the PostgreSQL libpq interface. Unlike
  16. DBD:pg, pgperl tries to implement the libpq interface as closely as
  17. possible.
  18. You have a choice between two different interfaces: the old C-style
  19. interface and a new one, using a more Perl-ish style. The old style has
  20. the benefit that existing libpq applications can easily be ported to
  21. perl. The new style uses class packages and might be more familiar to
  22. C++ programmers.
  23. %prep
  24. %setup -q -n Pg-%{version}
  25. %build
  26. export POSTGRES_INCLUDE=%{_includedir}/pgsql
  27. export POSTGRES_LIB=%{_libdir}
  28. perl Makefile.PL INSTALLDIRS=vendor
  29. make
  30. %install
  31. rm -rf %{buildroot}
  32. make DESTDIR=$RPM_BUILD_ROOT install
  33. #make PREFIX=%{buildroot}%{_prefix} \
  34. # INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
  35. # INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 install
  36. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  37. sed "s@^$RPM_BUILD_ROOT@@g" |
  38. grep -v perllocal.pod |
  39. grep -v "\.packlist" |
  40. grep -v ^%{_mandir} > %{name}.files
  41. if [ "$(cat %{name}.files)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. %clean
  46. rm -rf %{buildroot}
  47. %files -f %{name}.files
  48. %defattr(-,root,root)
  49. %doc README Changes examples
  50. %{_mandir}/man3/Pg.3pm*
  51. %dir %{perl_vendorarch}/auto
  52. %dir %{perl_vendorarch}/auto/Pg
  53. %changelog
  54. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0.2-2
  55. - rebuilt with postgresql-8.4.0
  56. * Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.2-1vl5
  57. - applied new versioning policy
  58. - rebuilt with postgresql-8.3.3
  59. * Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl5
  60. - rebuilt with postgresql-8.2.6
  61. * Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl4
  62. - rebuilt with postgresql-8.2.5
  63. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-0vl3
  64. - changed Group to Development/Libraries
  65. * Sat Mar 18 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.2-0vl2
  66. - rebuilt with postgresql-8.0.x
  67. * Sat Apr 26 2003 IWAI Masaharu <iwai@alib.jp> 2.0.2-0vl1
  68. - first build for Vine Linux