perl-namespace-autoclean-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. # Run optional test
  2. %bcond_with perl_namespace_autoclean_enables_optional_test
  3. %global perl_bootstrap 1
  4. Name: perl-namespace-autoclean
  5. Version: 0.28
  6. Release: 15%{?_dist_release}
  7. License: GPL+ or Artistic
  8. Summary: Keep imports out of your namespace
  9. Source0: https://cpan.metacpan.org/authors/id/E/ET/ETHER/namespace-autoclean-%{version}.tar.gz
  10. URL: https://metacpan.org/release/namespace-autoclean
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. BuildArch: noarch
  14. # Module Build
  15. BuildRequires: coreutils
  16. BuildRequires: findutils
  17. BuildRequires: make
  18. BuildRequires: perl >= 2:5.26.2
  19. BuildRequires: perl(ExtUtils::MakeMaker)
  20. # Module
  21. BuildRequires: perl(B::Hooks::EndOfScope)
  22. BuildRequires: perl(List::Util)
  23. BuildRequires: perl(namespace::clean)
  24. BuildRequires: perl(strict)
  25. BuildRequires: perl(Sub::Identify)
  26. BuildRequires: perl(warnings)
  27. # Test Suite
  28. BuildRequires: perl(base)
  29. BuildRequires: perl(Carp)
  30. BuildRequires: perl(constant)
  31. BuildRequires: perl(File::Basename)
  32. BuildRequires: perl(File::Spec)
  33. BuildRequires: perl(FindBin)
  34. BuildRequires: perl(overload)
  35. BuildRequires: perl(Scalar::Util)
  36. BuildRequires: perl(Test::More)
  37. BuildRequires: perl(Test::Requires)
  38. %if %{with perl_namespace_autoclean_enables_optional_test}
  39. # Optional Tests
  40. BuildRequires: perl(CPAN::Meta)
  41. %if 0
  42. BuildRequires: perl(Moo)
  43. %endif
  44. %if ! %{defined perl_bootstrap}
  45. # Break build-cycle: perl-namespace-autoclean → perl-Moose
  46. # → perl-Package-DeprecationManager → perl-namespace-autoclean
  47. # Break build-cycle: perl-namespace-autoclean → perl-Mouse → perl-Moose
  48. # → perl-Package-DeprecationManager → perl-namespace-autoclean
  49. BuildRequires: perl(Moose)
  50. BuildRequires: perl(Moose::Role)
  51. BuildRequires: perl(MooseX::Role::WithOverloading) >= 0.09
  52. BuildRequires: perl(Mouse)
  53. %endif
  54. BuildRequires: perl(Sub::Install)
  55. BuildRequires: perl(Sub::Name)
  56. %endif
  57. # Runtime
  58. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  59. Requires: perl(Sub::Identify)
  60. %description
  61. When you import a function into a Perl package, it will naturally also be
  62. available as a method. The 'namespace::autoclean' pragma will remove all
  63. imported symbols at the end of the current package's compile cycle. Functions
  64. called in the package itself will still be bound by their name, but they won't
  65. show up as methods on your class or instances. This module is very similar to
  66. namespace::clean, except it will clean all imported functions, no matter if you
  67. imported them before or after you 'use'd the pragma. It will also not touch
  68. anything that looks like a method.
  69. %prep
  70. %setup -q -n namespace-autoclean-%{version}
  71. %build
  72. perl Makefile.PL INSTALLDIRS=vendor
  73. make %{?_smp_mflags}
  74. %install
  75. make pure_install DESTDIR=%{buildroot}
  76. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  77. %{_fixperms} %{buildroot}
  78. %check
  79. make test
  80. %files
  81. %license LICENCE
  82. %doc Changes CONTRIBUTING README
  83. %{perl_vendorlib}/namespace/
  84. %{_mandir}/man3/namespace::autoclean.3*
  85. %changelog
  86. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.28-15
  87. - initial build for Vine Linux.
  88. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-14
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  90. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-13
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  92. * Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-12
  93. - Perl 5.28 re-rebuild of bootstrapped packages
  94. * Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-11
  95. - Perl 5.28 rebuild
  96. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-10
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  98. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-9
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  100. * Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-8
  101. - Perl 5.26 re-rebuild of bootstrapped packages
  102. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-7
  103. - Perl 5.26 rebuild
  104. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-6
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  106. * Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-5
  107. - Perl 5.24 re-rebuild of bootstrapped packages
  108. * Mon May 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-4
  109. - Perl 5.24 rebuild
  110. * Tue Mar 29 2016 Petr Pisar <ppisar@redhat.com> - 0.28-3
  111. - Break build-cycle: perl-namespace-autoclean → perl-Moose
  112. → perl-Package-DeprecationManager → perl-namespace-autoclean
  113. - Break build-cycle: perl-namespace-autoclean → perl-Mouse → perl-Moose
  114. → perl-Package-DeprecationManager → perl-namespace-autoclean
  115. - Remove unused direct test dependency on Class::MOP
  116. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-2
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  118. * Tue Oct 13 2015 Paul Howarth <paul@city-fan.org> - 0.28-1
  119. - Update to 0.28
  120. - Skip failing tests with old Moo or when Sub::Util is broken
  121. (CPAN RT#107643)
  122. * Wed Sep 9 2015 Paul Howarth <paul@city-fan.org> - 0.27-1
  123. - Update to 0.27
  124. - Package with only ExtUtils::MakeMaker to ease installation on perl 5.6
  125. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26-4
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  127. * Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-3
  128. - Perl 5.22 re-rebuild of bootstrapped packages
  129. * Mon Jun 08 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-2
  130. - Perl 5.22 rebuild
  131. * Sun Jun 7 2015 Paul Howarth <paul@city-fan.org> - 0.26-1
  132. - Update to 0.26
  133. - Mark all Mouse tests as TODO below perl 5.010, to enable installation
  134. despite apparent instability issues (see CPAN RT#101825)
  135. * Sat Jun 6 2015 Paul Howarth <paul@city-fan.org> - 0.25-1
  136. - Update to 0.25
  137. - Load Moo::Role earlier in a test, to make a potential misconfiguration more
  138. visible
  139. * Mon Jan 5 2015 Paul Howarth <paul@city-fan.org> - 0.24-1
  140. - Update to 0.24
  141. - Be more lenient in optional Mouse tests to handle edge cases in older and
  142. pure perl versions
  143. - Drop redundant %%{?perl_default_filter}
  144. * Tue Nov 4 2014 Paul Howarth <paul@city-fan.org> - 0.22-1
  145. - Update to 0.22
  146. - Drop testing of MooseX::MarkAsMethods, now that Moose 2.1400 has better
  147. overload handling
  148. * Tue Sep 23 2014 Paul Howarth <paul@city-fan.org> - 0.20-1
  149. - Update to 0.20
  150. - Moose earlier than 2.0300 had a broken ->does method, which called methods
  151. on a class's meta when it might not be initialized (CPAN RT#98424)
  152. * Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-4
  153. - Perl 5.20 re-rebuild of bootstrapped packages
  154. * Mon Sep 01 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-3
  155. - Perl 5.20 rebuild
  156. * Fri Aug 15 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-2
  157. - Disable BRs MooseX::MarkAsMethods and MooseX::Role::WithOverloading to
  158. avoid circular deps when bootstrapping
  159. * Thu Aug 14 2014 Paul Howarth <paul@city-fan.org> - 0.19-1
  160. - Update to 0.19
  161. - Bump dependency on B::Hooks::EndOfScope, to get the separation of pure-perl
  162. and XS components (CPAN RT#89245)
  163. - Repository migrated to the github moose organization
  164. - Update configure_requires checking in Makefile.PL, add CONTRIBUTING file
  165. - Changed the code to no longer _require_ Class::MOP; if your class is not a
  166. Moose class then we don't load Class::MOP, which was particularly
  167. problematic for Moo classes, as using namespace::autoclean with a Moo class
  168. "upgraded" it to be a Moose class
  169. - Using this module just broke overloading in a class (CPAN RT#50938)
  170. - Add -except to import options; this allows you to explicitly not clean a
  171. sub.
  172. - Better method detection for Mouse (GH#4)
  173. - More comprehensive testing with Moo/Mouse/Moose
  174. - Fixed cleaning of constants
  175. - This release by ETHER -> update source URL
  176. - Switch to Module::Build::Tiny flow
  177. - Update %%description to remove reference to Class::MOP
  178. - Make %%files list more explicit
  179. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-7
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  181. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-6
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  183. * Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 0.13-5
  184. - Perl 5.18 rebuild
  185. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
  186. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  187. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-3
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  189. * Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 0.13-2
  190. - Perl 5.16 rebuild
  191. * Sat Jan 14 2012 Iain Arnell <iarnell@gmail.com> 0.13-1
  192. - update to latest upstream version
  193. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-4
  194. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  195. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.12-3
  196. - Perl mass rebuild
  197. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.12-2
  198. - Perl mass rebuild
  199. * Sun Mar 13 2011 Iain Arnell <iarnell@gmail.com> 0.12-1
  200. - update to latest upstream version
  201. - clean up spec for modern rpmbuild
  202. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-3
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  204. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-2
  205. - 661697 rebuild for fixing problems with vendorach/lib
  206. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.09-4
  207. - Mass rebuild with perl-5.12.0
  208. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.09-3
  209. - rebuild against perl 5.10.1
  210. * Thu Sep 17 2009 Stepan Kasal <skasal@redhat.com> 0.09-2
  211. - fix the previous changelog entry
  212. * Wed Sep 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.09-1
  213. - add %%perl_default_filter'ing
  214. - auto-update to 0.09 (by cpan-spec-update 0.01)
  215. - added a new req on perl(B::Hooks::EndOfScope) (version 0.07)
  216. - added a new req on perl(Class::MOP) (version 0.80)
  217. - added a new req on perl(List::Util) (version 0)
  218. - added a new req on perl(namespace::clean) (version 0.11)
  219. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-2
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  221. * Wed Jul 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-1
  222. - submission
  223. * Wed Jul 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-0
  224. - initial RPM packaging
  225. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)