perl-YAML-vl.spec 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. %define origname YAML
  2. Summary: YAML Ain't Markup Language (tm) for Perl
  3. Name: perl-YAML
  4. Version: 0.95
  5. Release: 1%{?_dist_release}
  6. License: perl's
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/%{origname}-%{version}.tar.gz
  9. Source1: filter-requires-perl-YAML.sh
  10. Url: http://search.cpan.org/dist/YAML/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildArch: noarch
  13. BuildRequires: perl
  14. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  15. Requires: perl
  16. Distribution: Vine Linux
  17. Vendor: Project Vine
  18. Packager: iwaim
  19. %if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
  20. %define __find_requires %{SOURCE1}
  21. %else if %{?_dist_release} == "vl7"
  22. %define __perllib_requires %{SOURCE1}
  23. %else
  24. %define __perl_requires %{SOURCE1}
  25. %endif
  26. %description
  27. This module has been released to CPAN as YAML::Old, and soon YAML.pm
  28. will be changed to just be a frontend interface module for all the
  29. various Perl YAML implementation modules, including YAML::Old.
  30. If you want robust and fast YAML processing using the normal Dump/Load
  31. API, please consider switching to YAML::XS. It is by far the best Perl
  32. module for YAML at this time. It requires that you have a C compiler,
  33. since it is written in C.
  34. %prep
  35. %setup -q -n %{origname}-%{version}
  36. %build
  37. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  38. make
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. mkdir -p $RPM_BUILD_ROOT%{_prefix}
  42. make DESTDIR=$RPM_BUILD_ROOT install
  43. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  44. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  45. sed "s@^$RPM_BUILD_ROOT@@g" |
  46. grep -v ^%{_mandir} |
  47. grep -v perllocal.pod |
  48. grep -v "\.packlist" > %{name}.files
  49. if [ "$(cat %{name}.files)X" = "X" ] ; then
  50. echo "ERROR: EMPTY FILE LIST"
  51. exit -1
  52. fi
  53. %check
  54. make test
  55. %clean
  56. rm -rf $RPM_BUILD_ROOT
  57. %files -f %{name}.files
  58. %defattr(-,root,root)
  59. %doc README Changes LICENSE
  60. %dir %{perl_vendorlib}/YAML
  61. %{_mandir}/man3/*
  62. %changelog
  63. * Tue Jul 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.95-1
  64. - build with Perl 5.16
  65. - update to 0.95
  66. - add BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  67. - update filter (Source1)
  68. - using __perllibl_requires macro for VineSeed (vl7)
  69. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 0.72-1
  70. - new upstream release
  71. - using __perl_requires macro for VineSeed (vl6)
  72. * Mon Feb 22 2010 IWAI, Masaharu <iwai@alib.jp> 0.71-1
  73. - first release for Vine Linux