perl-XML-SAX-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. Summary: XML-SAX Perl module
  2. Name: perl-XML-SAX
  3. Version: 1.00
  4. Release: 1%{?_dist_release}
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/XML-SAX/
  8. Source0: http://www.cpan.org/authors/id/G/GR/GRANTM/XML-SAX-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(XML::NamespaceSupport)
  15. # The following creates circular dependency, but they are not needed for build.
  16. #BuildRequires: perl(XML::LibXML) perl(XML::LibXML::Common)
  17. # XML::SAX::Base became independent package, BR just for test
  18. BuildRequires: perl(XML::SAX::Base)
  19. Requires: perl(:MODULE_COMPAT_%(perl -MConfig -e 'print $Config{version}'))
  20. #Requires: perl(XML::LibXML) perl(XML::LibXML::Common)
  21. %description
  22. XML::SAX consists of several framework classes for using and building
  23. Perl SAX2 XML parsers, filters, and drivers. It is designed around the
  24. need to be able to "plug in" different SAX parsers to an application
  25. without requiring programmer intervention. Those of you familiar with
  26. the DBI will be right at home. Some of the designs come from the Java
  27. JAXP specification (SAX part), only without the javaness.
  28. %prep
  29. %setup -q -n XML-SAX-%{version}
  30. %if %{_dist_release} > "vl6"
  31. %{?perl_default_filter:
  32. %filter_from_provides /^perl(XML::SAX::PurePerl)$/d
  33. %filter_from_requires /^perl(XML::SAX::PurePerl::\(DTDDecls\|DocType\|EncodingDetect\|XMLDecl\|NoUnicodeExt\|UnicodeExt\|Reader::NoUnicodeExt\))/d
  34. %perl_default_filter}
  35. %global __provides_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(XML::SAX::PurePerl\\)
  36. %global __requires_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(XML::SAX::PurePerl::(DTDDecls|DocType|EncodingDetect|XMLDecl|NoUnicodeExt|UnicodeExt|Reader::NoUnicodeExt)\\)
  37. %{?perl_default_subpackage_tests}
  38. %else
  39. cat << \EOF > %{name}-prov
  40. #!/bin/sh
  41. %{__perl_provides} $* |\
  42. sed -e '/perl(XML::SAX::PurePerl)/d'
  43. EOF
  44. %global __perl_provides %{_builddir}/XML-SAX-%{version}/%{name}-prov
  45. chmod +x %{__perl_provides}
  46. cat << \EOF > %{name}-req
  47. #!/bin/sh
  48. %{__perl_requires} $* |\
  49. sed -e '/perl(XML::SAX::PurePerl::\(DTDDecls\|DocType\|EncodingDetect\|XMLDecl\|NoUnicodeExt\|UnicodeExt\|Reader::NoUnicodeExt\))/d'
  50. EOF
  51. %global __perl_requires %{_builddir}/XML-SAX-%{version}/%{name}-req
  52. chmod +x %{__perl_requires}
  53. %endif
  54. %build
  55. echo N | %{__perl} Makefile.PL INSTALLDIRS=vendor
  56. make %{?_smp_mflags}
  57. %install
  58. rm -rf %{buildroot}
  59. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  60. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  61. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  62. chmod -R u+w %{buildroot}/*
  63. touch %{buildroot}%{perl_vendorlib}/XML/SAX/ParserDetails.ini
  64. %check
  65. make test
  66. %clean
  67. rm -rf %{buildroot}
  68. %post
  69. if [ ! -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini" ] ; then
  70. perl -MXML::SAX -e \
  71. 'XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()' 2>/dev/null || :
  72. else
  73. cp -p "%{perl_vendorlib}/XML/SAX/ParserDetails.ini" "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup"
  74. fi
  75. %triggerun -- perl-XML-LibXML < 1.58-8
  76. if [ -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" ] ; then
  77. mv "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" "%{perl_vendorlib}/XML/SAX/ParserDetails.ini"
  78. fi
  79. %preun
  80. # create backup of ParserDetails.ini, therefore user's configuration is used
  81. if [ $1 -eq 0 ] ; then
  82. perl -MXML::SAX -e \
  83. 'XML::SAX->remove_parser(q(XML::SAX::PurePerl))->save_parsers()' || :
  84. fi
  85. [ -f "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" ] && \
  86. rm -rf "%{perl_vendorlib}/XML/SAX/ParserDetails.ini.backup" || :
  87. %files
  88. %license LICENSE
  89. %doc Changes README
  90. %dir %{perl_vendorlib}/XML
  91. %{perl_vendorlib}/XML/SAX.pm
  92. %dir %{perl_vendorlib}/XML/SAX
  93. %{perl_vendorlib}/XML/SAX/*.pm
  94. %{perl_vendorlib}/XML/SAX/*.pod
  95. %{perl_vendorlib}/XML/SAX/PurePerl
  96. %{_mandir}/man3/XML::*.3pm*
  97. %ghost %{perl_vendorlib}/XML/SAX/ParserDetails.ini
  98. %changelog
  99. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.00-1
  100. - new upstream release.
  101. - rebuilt with perl-5.26.
  102. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.99-3
  103. - rebuilt with perl-5.16.0.
  104. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-2
  105. - rebuild
  106. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-1
  107. - updated to 0.99
  108. - revamped spec in accordance with Fedora's 0.99-2
  109. - previous Vine changelogs as follows:
  110. - Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16-3
  111. - drebuild with perl-5.12.3
  112. - using __perl_requires macro for VineSeed (vl6)
  113. - Sun Jun 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-2
  114. - added Requires(post,preun): perl-XML-LibXML
  115. - Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16-1
  116. - new upstream release
  117. - built with perl-5.10.0-2
  118. - added SOURCE1, 2 for avoiding unwanted dependancies
  119. - Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 0.12-0vl2
  120. - build on perl-5.8.6-0vl1
  121. - Sun Oct 17 2004 Satoshi MACHINO <machino@vinelinux.org> 0.12-0vl1
  122. - new upstream version
  123. - updated patch0 to perl-XML-SAX-0.12-makefile.patch
  124. - Mon Apr 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.10-0vl1
  125. - first build for Vine Linux
  126. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-2
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  128. * Fri Oct 07 2011 Marcela Mašláňová <mmaslano@redhat.com> 0.99-1
  129. - update to 0.99
  130. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.96-15
  131. - Perl mass rebuild
  132. * Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-14
  133. - fix macros to work with new macros
  134. - clean spec
  135. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-13
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  137. * Mon Jan 24 2011 Adrian Reber <adrian@lisas.de> - 0.96-12
  138. - rebuild for ppc
  139. * Thu Dec 23 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.96-11
  140. - 661697 rebuild for fixing problems with vendorach/lib
  141. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.96-10
  142. - Mass rebuild with perl-5.12.0
  143. * Fri Feb 5 2010 Stepan Kasal <skasal@redhat.com> - 0.96-9
  144. - anchor the filtering regexps
  145. * Fri Feb 5 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-8
  146. - XML-LibXML use triggers for XML::SAX update. Deleting of settings in
  147. ParserDetails.ini is solved by post and preun part, which create backup.
  148. * Thu Nov 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-7
  149. - instead of path into post used perl_vendorlib macro
  150. - rebuilt will be needed for perl-5.10.1
  151. * Thu Nov 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-6
  152. - post scriptlet needs to check whether the file is installed. When it isn't,
  153. then it's needed call for adding PurePerl parser
  154. http://perl-xml.sourceforge.net/faq/#parserdetails.ini
  155. * Mon Oct 19 2009 Stepan Kasal <skasal@redhat.com> - 0.96-5
  156. - use the filtering macros
  157. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-4
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  159. * Tue Apr 28 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-3
  160. - 478905 fix scriptlets
  161. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.96-2
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  163. * Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 0.96-1
  164. - update to 0.96, big leap in versioning
  165. * Sun Mar 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-5
  166. - Re-enable XML::LibXML BuildRequires
  167. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-4
  168. - Rebuild for perl 5.10 (again)
  169. * Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3.1
  170. - temporarily disable BR against perl-XML-LibXML
  171. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3
  172. - rebuild for new perl
  173. * Sat Jul 07 2007 Robin Norwood <rnorwood@redhat.com> - 0.16-2
  174. - Resolves: rhbz#247213
  175. - Fix provides and requires scripts.
  176. * Mon Jul 02 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.16-1
  177. - Update to 0.16.
  178. - Brings specfile closer to Fedora Perl template.
  179. - Corrects Source0 URL (upstream maintainer has changed).
  180. - Move Requires filter into spec, and add Provides filter.
  181. * Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.15-1
  182. - New version: 0.15
  183. * Fri Jun 09 2006 Jason Vas Dias <jvdias@redhat.com> - 0.14-2
  184. - fix bug 194706: fails to build under (new!) mock
  185. * Mon Jun 05 2006 Jason Vas Dias <jvdias@redhat.com> - 0.14-1
  186. - upgrade to 0.14
  187. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.13-1.1
  188. - rebuild for new perl-5.8.8
  189. * Mon Dec 19 2005 Jason Vas Dias <jvdias@redhat.com> - 0.13-1
  190. - upgrade to 0.13
  191. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  192. - rebuilt for new gcc
  193. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  194. - rebuilt for new gcj
  195. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0.12-7
  196. - #121167
  197. - Handle ParserDetails.ini parser registration.
  198. - Require perl(:MODULE_COMPAT_*).
  199. - Own installed directories.
  200. * Wed Oct 22 2003 Chip Turner <cturner@redhat.com> - 0.12-1
  201. - Specfile autogenerated.