perl-XML-LibXML-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. Summary: Perl interface to the libxml2 library
  2. Summary(ja): libxml2 ライブラリへの Perl インターフェイス
  3. Name: perl-XML-LibXML
  4. # NOTE: also update perl-XML-LibXSLT to the same version, see
  5. # https://bugzilla.redhat.com/show_bug.cgi?id=469480
  6. Version: 2.0200
  7. Release: 2%{?_dist_release}
  8. License: GPL+ or Artistic
  9. Group: Development/Libraries
  10. URL: http://search.cpan.org/dist/XML-LibXML/
  11. Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libxcrypt-devel
  14. BuildRequires: libxml2-devel
  15. BuildRequires: perl(XML::NamespaceSupport)
  16. BuildRequires: perl(XML::SAX)
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(Test::More)
  19. Requires: %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
  20. Requires: %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
  21. Requires: %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
  22. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  23. Provides: perl-XML-LibXML-Common = %{version}
  24. Obsoletes: perl-XML-LibXML-Common <= 0.13
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. This module implements a Perl interface to the GNOME libxml2 library
  29. which provides interfaces for parsing and manipulating XML files. This
  30. module allows Perl programmers to make use of the highly capable
  31. validating XML parser and the high performance DOM implementation.
  32. %prep
  33. %setup -q -n XML-LibXML-%{version}
  34. %define libxml_libs %(pkg-config --libs libxml-2.0)
  35. %define libxml_cflags %(pkg-config --cflags libxml-2.0)
  36. perl -pi -e 's|Alien::Libxml2->cflags|"%{libxml_cflags}"|' Makefile.PL
  37. perl -pi -e 's|Alien::Libxml2->libs|"%{libxml_libs}"|' Makefile.PL
  38. sed -i -e '/Alien/d' Makefile.PL
  39. %build
  40. %__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  41. %__make %{?_smp_mflags}
  42. %install
  43. %__rm -rf $RPM_BUILD_ROOT
  44. %__make install \
  45. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
  46. INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
  47. find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
  48. -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
  49. find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
  50. %__chmod -R u+w $RPM_BUILD_ROOT/*
  51. for i in Changes; do
  52. /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
  53. done
  54. %check
  55. %__make test
  56. %clean
  57. %__rm -rf $RPM_BUILD_ROOT
  58. %triggerin -- perl-XML-SAX
  59. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  60. perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
  61. 2>/dev/null || :
  62. done
  63. %preun
  64. if [ $1 -eq 0 ] ; then
  65. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  66. perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
  67. 2>/dev/null || :
  68. done
  69. fi
  70. %files
  71. %defattr(-,root,root,-)
  72. %doc Changes LICENSE README
  73. %{perl_vendorarch}/auto/XML
  74. %{perl_vendorarch}/XML
  75. %{_mandir}/man3/*.3*
  76. %changelog
  77. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0200-2
  78. - rebuilt with perl-5.26.
  79. * Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0200-1
  80. - new upstream release.
  81. - added BR:libxcrypt-devel.
  82. * Sun Nov 30 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0117-1
  83. - new upstream release.
  84. - built with libxml2 2.9.2
  85. - added Japanese summary
  86. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0116-1
  87. - new upstream release.
  88. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
  89. - rebuild with perl-5.12.3
  90. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
  91. - new upstream release
  92. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
  93. - Mass rebuild with perl-5.12.0
  94. * Fri Jan 8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
  95. - remove BR XML::LibXML::Common
  96. * Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
  97. - corrected version of obsoletes
  98. * Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
  99. - 541605 this package now contains XML::LibXML::Common
  100. * Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
  101. - update to fix 539102
  102. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  104. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  106. * Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
  107. - update to 1.69
  108. * Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
  109. - Supress warning about nonexistent file in perl-XML-SAX install trigger
  110. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
  111. - new upsteream release
  112. - built with perl-5.10.0-2
  113. - changed Group to Development/Libraries
  114. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
  115. - changed Group to Development/Languages
  116. - rebuilt with libxml2-2.6.26
  117. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
  118. - rebuilt for Vine Linux
  119. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
  120. - bump again for double-long bug on ppc(64)
  121. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
  122. - rebuilt for new gcc4.1 snapshot and glibc changes
  123. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
  124. - rebuild for new perl-5.8.8
  125. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  126. - rebuilt for new gcc
  127. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  128. - rebuilt for new gcj
  129. * Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
  130. - rebuild
  131. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
  132. - #121168
  133. - Update to 1.58.
  134. - Require perl(:MODULE_COMPAT_*).
  135. - Handle ParserDetails.ini parser registration.
  136. - BuildRequires libxml2-devel.
  137. - Own installed directories.
  138. * Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
  139. - Specfile autogenerated.