perl-WWW-Curl-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. Name: perl-WWW-Curl
  2. Version: 4.17
  3. Release: 2%{?_dist_release}
  4. Summary: Perl extension interface for libcurl
  5. License: MIT
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/WWW-Curl/
  8. Source0: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz
  9. Patch0: WWW-Curl-4.17-Skip-preprocessor-symbol-only-CURL_STRICTER.patch
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildRequires: perl
  13. BuildRequires: perl(inc::Module::Install)
  14. BuildRequires: perl(Carp)
  15. BuildRequires: perl(Exporter)
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: perl(File::Temp)
  18. %{?_with_network_tests: BuildRequires: perl(lib) }
  19. BuildRequires: perl(strict)
  20. BuildRequires: perl(Test::More)
  21. # Test::Pod is optional
  22. BuildRequires: perl(warnings)
  23. BuildRequires: perl(XSLoader)
  24. BuildRequires: curl-devel
  25. Requires: perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo $version))
  26. %{?perl_default_filter}
  27. %description
  28. WWW::Curl is a Perl extension interface for libcurl.
  29. %prep
  30. %setup -q -n WWW-Curl-%{version}
  31. %patch0 -p1
  32. rm -rf inc && sed -i -e '/^inc\//d' MANIFEST
  33. %build
  34. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  35. make %{?_smp_mflags}
  36. %install
  37. make pure_install DESTDIR=$RPM_BUILD_ROOT
  38. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
  39. find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
  40. %{_fixperms} $RPM_BUILD_ROOT/*
  41. %check
  42. # These tests require network, use "--with network_tests" to execute them
  43. %{?!_with_network_tests: rm t/01basic.t }
  44. %{?!_with_network_tests: rm t/02callbacks.t }
  45. %{?!_with_network_tests: rm t/04abort-test.t }
  46. %{?!_with_network_tests: rm t/05progress.t }
  47. %{?!_with_network_tests: rm t/08ssl.t }
  48. %{?!_with_network_tests: rm t/09times.t }
  49. %{?!_with_network_tests: rm t/14duphandle.t }
  50. %{?!_with_network_tests: rm t/15duphandle-callback.t }
  51. %{?!_with_network_tests: rm t/18twinhandles.t }
  52. %{?!_with_network_tests: rm t/19multi.t }
  53. %{?!_with_network_tests: rm t/21write-to-scalar.t }
  54. make test
  55. %files
  56. %doc Changes LICENSE README
  57. %{perl_vendorarch}/auto/*
  58. %{perl_vendorarch}/WWW*
  59. %{_mandir}/man3/*
  60. %changelog
  61. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.17-2
  62. - rebuilt with perl-5.26.2.
  63. - added Patch0 for recent curl.
  64. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.17-1
  65. - initial build for Vine Linux
  66. * Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 4.17-4
  67. - Perl 5.20 rebuild
  68. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-3
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  70. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.17-2
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  72. * Wed Feb 26 2014 Petr Šabata <contyk@redhat.com> - 4.17-1
  73. - 4.17 bump, license change
  74. * Fri Feb 21 2014 Petr Šabata <contyk@redhat.com> - 4.16-1
  75. - 4.16 bump
  76. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-12
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  78. * Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 4.15-11
  79. - Perl 5.18 rebuild
  80. * Sun Jul 14 2013 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-10
  81. - Update dependencies
  82. - Use DESTDIR rather than PERL_INSTALL_ROOT
  83. - Remove buildroot cleaning
  84. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-9
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  86. * Thu Aug 16 2012 Jitka Plesnikova <jplesnik@redhat.com> - 4.15-8
  87. - Specify all dependencies
  88. - Modernize spec file
  89. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-7
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  91. * Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 4.15-6
  92. - Perl 5.16 rebuild
  93. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-5
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  95. * Sun Jul 24 2011 Iain Arnell <iarnell@gmail.com> 4.15-4
  96. - use perl_default_filter
  97. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.15-3
  98. - Perl mass rebuild
  99. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.15-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  101. * Tue Nov 30 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.15-1
  102. - Update to 4.15
  103. * Thu Oct 28 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.14-1
  104. - Update to 4.14
  105. - Add a filter provide to avoid private-shared-object-provides error
  106. * Sun Sep 5 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.13-1
  107. - Update to 4.13
  108. * Wed Aug 25 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.12-1
  109. - Update to 4.12
  110. * Thu Jun 3 2010 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-3
  111. - Remove test 19 because it requires network
  112. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 4.11-2
  113. - Mass rebuild with perl-5.12.0
  114. * Fri Dec 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.11-1
  115. - Update to 4.11
  116. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 4.09-3
  117. - rebuild against perl 5.10.1
  118. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.09-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  120. * Sat Jul 11 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.09-1
  121. - Rebuild for 4.09
  122. * Mon Jun 1 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.07-1
  123. - Rebuild for 4.07
  124. * Sat Apr 18 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.06-1
  125. - Step to 4.06
  126. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.05-5
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  128. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-4
  129. - Licence update
  130. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-3
  131. - README.Win32 file removed
  132. * Wed Jan 14 2009 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-2
  133. - Timestamp preserved
  134. - changelog format fix
  135. - README.Win32 file removed
  136. * Thu Dec 11 2008 Nicoleau Fabien <nicoleau.fabien@gmail.com> - 4.05-1
  137. - Initial build with cpan2spec