perl-Video-ivtv-vl.spec 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. %define perlversion %(rpm -q perl --qf "%%{epoch}:%%{version}")
  2. %define pkgname Video-ivtv
  3. %define installdirs site
  4. Summary: A perl module for ivtv support.
  5. Name: perl-%{pkgname}
  6. Version: 0.13
  7. Release: 1%{?_dist_release}
  8. Group: Development/Libraries
  9. License: distributable
  10. URL: http://ivtv.sf.net/
  11. Source0: %{pkgname}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. Requires: perl = %{perlversion}
  15. %description
  16. Video::ivtv is designed to be a quick hack at making the record_ivtv.pl
  17. script not have to depend on the test_ioctl program included with the ivtv
  18. utils. By moving to have the things that have proven difficult to do purely
  19. in perl to C where they currently are being done, I can concentrate on
  20. improving the code rather than hitting my head against the wall trying to
  21. do code cleanups. ;)
  22. %prep
  23. %setup -q -n %{pkgname}-%{version}
  24. %build
  25. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT%{_prefix} INSTALLDIRS=vendor
  26. make
  27. %install
  28. rm -rf $RPM_BUILD_ROOT
  29. make install
  30. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  31. find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
  32. sed "s@^$RPM_BUILD_ROOT@@g" | \
  33. grep -v perllocal.pod | \
  34. grep -v "\.packlist" > %{pkgname}-%{version}-filelist
  35. if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
  36. echo "ERROR: EMPTY FILE LIST"
  37. exit -1
  38. fi
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %files -f %{pkgname}-%{version}-filelist
  42. %defattr(-,root,root)
  43. %doc README MANIFEST
  44. %changelog
  45. * Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.13-1
  46. - apply new versioning policy
  47. - rebuild with perl v5.10.0
  48. * Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
  49. - add Requires: perl = %%{perlversion}
  50. * Tue May 16 2006 Takahiro Adachi <tadachi@tadachi-net.com> 0.13-0vl1
  51. - change source (0.13) for ivtv-0.2 or later version
  52. * Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12-0vl1
  53. - initial build for Vine Linux