perl-Thread-Serialize-vl.spec 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. %define real_name Thread-Serialize
  2. Summary: serialize data-structures between threads
  3. Name: perl-Thread-Serialize
  4. Version: 1.01
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL+
  7. Group: Development/Libraries
  8. Source: http://search.cpan.org/CPAN/authors/id/E/EL/ELIZABETH/Thread-Serialize-%{version}.tar.gz
  9. URL: http://search.cpan.org/dist/Thread-Serialize/
  10. BuildArch: noarch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. BuildRequires: perl(Storable)
  14. BuildRequires: perl(Test::More) >= 0.88
  15. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  16. Requires: perl(Storable)
  17. %description
  18. The Thread::Serialize module is a library for centralizing the
  19. routines used to serialize data-structures between threads.
  20. Because of this central location, other modules such as
  21. Thread::Conveyor, Thread::Pool or Thread::Tie can benefit from
  22. the same optimizations that may take place here in the future.
  23. This module only functions on Perl versions 5.8.0 and later.
  24. And then only when threads are enabled with -Dusethreads. It
  25. is of no use with any version of Perl before 5.8.0 or without
  26. threads enabled.
  27. %prep
  28. %setup -q -n %{real_name}-%{version}
  29. %build
  30. %{expand: %%define optflags %{optflags} -fPIC}
  31. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  32. make %{?_smp_mflags}
  33. %install
  34. rm -rf %{buildroot}
  35. make pure_install DESTDIR=%{buildroot}
  36. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  37. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  38. %{_fixperms} %{buildroot}
  39. %clean
  40. %{__rm} -rf %{buildroot}
  41. %check
  42. make test
  43. %files
  44. %defattr(-, root, root, 0755)
  45. %doc MANIFEST README CHANGELOG
  46. %doc %{_mandir}/man3/Thread::Serialize.3pm*
  47. %dir %{perl_vendorlib}/Thread/
  48. %{perl_vendorlib}/Thread/Serialize.pm
  49. %changelog
  50. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.01-1
  51. - updated to 1.01
  52. - build with perl 5.16.3
  53. * Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
  54. - initial build for Vine Linux