perl-Thread-Conveyor-vl.spec 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. %define real_name Thread-Conveyor
  2. Summary: Transport of any data-structure between threads
  3. Name: perl-Thread-Conveyor
  4. Version: 0.19
  5. Release: 2%{?_dist_release}
  6. License: Artistic or GPL+
  7. Group: Development/Libraries
  8. URL: http://search.cpan.org/dist/Thread-Conveyor/
  9. Source: http://www.cpan.org/modules/by-module/Thread/Thread-Conveyor-%{version}.tar.gz
  10. BuildArch: noarch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: perl
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(load)
  15. BuildRequires: perl(Thread::Tie) >= 0.09
  16. BuildRequires: perl(Thread::Serialize)
  17. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. The Thread::Conveyor object is a thread-safe data structure that
  22. mimics the behaviour of a conveyor belt. One or more worker threads
  23. can put boxes with frozen values and references on one end of the belt
  24. to be taken off by one or more worker threads on the other end of the
  25. belt to be thawed and returned.
  26. A box may consist of any combination of scalars and references to
  27. scalars, arrays (lists) and hashes. Freezing and thawing is currently
  28. done with the Thread::Serialize module, but that may change in the
  29. future. Objects and code references are currently not allowed.
  30. By default, the maximum number of boxes on the belt is limited to 50.
  31. Putting of boxes on the belt is halted if the maximum number of boxes
  32. is exceeded. This throttling feature was added because it was found
  33. that excessive memory usage could be caused by having the belt growing
  34. too large. Throttling can be disabled if so desired.
  35. This module only functions on Perl versions 5.8.0 and later.
  36. And then only when threads are enabled with -Dusethreads. It
  37. is of no use with any version of Perl before 5.8.0 or without
  38. threads enabled.
  39. %prep
  40. %setup -q -n %{real_name}-%{version}
  41. %build
  42. %{expand: %%define optflags %{optflags} -fPIC}
  43. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  44. make %{?_smp_mflags}
  45. %install
  46. rm -rf %{buildroot}
  47. make pure_install DESTDIR=%{buildroot}
  48. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  49. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  50. %{_fixperms} %{buildroot}
  51. %check
  52. make test
  53. %clean
  54. rm -rf %{buildroot}
  55. %files
  56. %defattr(-, root, root, -)
  57. %doc MANIFEST README CHANGELOG TODO
  58. %{perl_vendorlib}/*
  59. %{_mandir}/man3/*
  60. %changelog
  61. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.19-2
  62. - rebuilt with perl 5.16.3
  63. * Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.19-1
  64. - initial build for Vine Linux