perl-Text-Template-vl.spec 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. %define pkgname Text-Template
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 1.46
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. URL: http://search.cpan.org/~mjd/Text-Template/
  9. Source0: http://search.cpan.org/CPAN/authors/id/M/MJ/MJD/%{pkgname}-%{version}.tar.gz
  10. Summary: Text::Template - Expand template text with embedded Perl
  11. Summary(ja): Text::Template - Perl が埋め込まれたテンプレートテキストの拡張
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. # Dependency
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: yasumichi
  20. %description
  21. This is a library for generating form letters, building HTML pages, or
  22. filling in templates generally. A `template' is a piece of text that has
  23. little Perl programs embedded in it here and there. When you `fill in' a
  24. template, you evaluate the little programs and replace them with their
  25. values.
  26. You can store a template in a file outside your program. People can modify
  27. the template without modifying the program. You can separate the formatting
  28. details from the main code, and put the formatting parts of the program into
  29. the template. That prevents code bloat and encourages functional separation.
  30. #%%description -l ja
  31. %prep
  32. %setup -q -n %{pkgname}-%{version}
  33. %build
  34. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  35. %{__make} %{?_smp_mflags}
  36. %install
  37. %{__rm} -rf ${RPM_BUILD_ROOT}
  38. %{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
  39. # remove unnecessary files.
  40. find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
  41. find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
  42. find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
  43. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  44. # generate file list
  45. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  46. sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
  47. if [ "$(cat %{name}.files)X" = "X" ] ; then
  48. echo "ERROR: EMPTY FILE LIST"
  49. exit -1
  50. fi
  51. %clean
  52. %{__rm} -rf ${RPM_BUILD_ROOT}
  53. %files -f %{name}.files
  54. %defattr(-,root,root)
  55. %doc COPYING README
  56. %changelog
  57. * Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.46-1
  58. - updated to 1.46
  59. - built with perl 5.16.3
  60. - added URL tag
  61. * Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.45-1
  62. - initial build for Vine Linux