perl-Test-Warnings-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. Name: perl-Test-Warnings
  2. Version: 0.026
  3. Release: 1%{?_dist_release}
  4. Summary: Test for warnings and the lack of them
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Test-Warnings
  8. Source0: http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Warnings-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. # Build
  12. BuildRequires: perl >= 2:5.26.2
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. # Module
  15. BuildRequires: perl(Exporter)
  16. BuildRequires: perl(Test::Builder)
  17. BuildRequires: perl(parent)
  18. BuildRequires: perl(strict)
  19. BuildRequires: perl(warnings)
  20. # Test Suite
  21. BuildRequires: perl(CPAN::Meta)
  22. BuildRequires: perl(CPAN::Meta::Requirements)
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. BuildRequires: perl(File::Spec::Functions)
  25. BuildRequires: perl(if)
  26. BuildRequires: perl(List::Util)
  27. BuildRequires: perl(Test::More)
  28. BuildRequires: perl(Test::Tester)
  29. BuildRequires: perl(version)
  30. # Runtime
  31. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. If you've ever tried to use Test::NoWarnings to confirm there are no warnings
  36. generated by your tests, combined with the convenience of done_testing to not
  37. have to declare a test count, you'll have discovered that these two features do
  38. not play well together, as the test count will be calculated before the
  39. warnings test is run, resulting in a TAP error (see examples/test_nowarnings.pl
  40. in this distribution for a demonstration).
  41. This module is intended to be used as a drop-in replacement for
  42. Test::NoWarnings: it also adds an extra test, but runs this test before
  43. done_testing calculates the test count, rather than after. It does this by
  44. hooking into done_testing as well as via an END block. You can declare a plan,
  45. or not, and things will still Just Work.
  46. It is actually equivalent to:
  47. use Test::NoWarnings 1.04 ':early';
  48. as warnings are still printed normally as they occur. You are safe, and
  49. enthusiastically encouraged, to perform a global search-replace of the above
  50. with use Test::Warnings; whether or not your tests have a plan.
  51. %prep
  52. %setup -q -n Test-Warnings-%{version}
  53. %build
  54. perl Makefile.PL INSTALLDIRS=vendor
  55. make %{?_smp_mflags}
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make pure_install DESTDIR=$RPM_BUILD_ROOT
  59. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  60. %{_fixperms} $RPM_BUILD_ROOT
  61. %check
  62. make test
  63. %clean
  64. rm -rf $RPM_BUILD_ROOT
  65. %files
  66. %license LICENSE
  67. %doc Changes CONTRIBUTING README README.md examples/
  68. %{perl_vendorlib}/Test/
  69. %{_mandir}/man3/Test::Warnings.3pm*
  70. %changelog
  71. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.026-1
  72. - new upstream release.
  73. - rebuilt with perl-5.26.
  74. * Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.016-3
  75. - inital build for Vine Linux
  76. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.016-2
  77. - Perl 5.20 rebuild
  78. * Sun Jun 22 2014 Paul Howarth <paul@city-fan.org> - 0.016-1
  79. - Update to 0.16
  80. - Fix prereq problem with last release - now no longer testing the example
  81. scripts for user installs
  82. * Fri Jun 20 2014 Paul Howarth <paul@city-fan.org> - 0.015-1
  83. - Update to 0.15
  84. - Adjusted packaging and tests to become perl-5.6 friendly, including only
  85. using core or dual-lifed prerequisites
  86. - Switch to ExtUtils::MakeMaker flow
  87. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.014-2
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  89. * Mon Mar 3 2014 Paul Howarth <paul@city-fan.org> - 0.014-1
  90. - Update to 0.014
  91. - Fix test that fails when FOO or BAR environment variables are set
  92. (CPAN RT#93447)
  93. * Mon Dec 16 2013 Paul Howarth <paul@city-fan.org> - 0.013-1
  94. - Update to 0.013
  95. - Update configure_requires checking in Makefile.PL
  96. * Mon Oct 14 2013 Paul Howarth <paul@city-fan.org> - 0.012-1
  97. - Update to 0.012
  98. - Re-release to fix t/00-report-prereqs.t use of CPAN::Meta::Requirements
  99. * Sun Oct 13 2013 Paul Howarth <paul@city-fan.org> - 0.011-1
  100. - Update to 0.011
  101. - Unnecessary tests removed
  102. - CONTRIBUTING file added
  103. - Drop buildreqs only needed for removed tests
  104. - BR: optional test requirement perl(CPAN::Meta::Requirements)
  105. * Wed Sep 25 2013 Paul Howarth <paul@city-fan.org> - 0.010-1
  106. - Update to 0.010
  107. - Re-release with fixed compile test
  108. - Update dependencies
  109. - Package examples
  110. * Wed Sep 11 2013 Paul Howarth <paul@city-fan.org> - 0.009-1
  111. - Update to 0.009
  112. - Fixed error in synopsis (we do not export anything by default)
  113. - A caveat added to the documentation regarding embedding warning checks
  114. inside another sub
  115. - ':no_end_test' now also covers side effects of done_testing, as well as
  116. END blocks, making it possible to use the warning(s) subs without having an
  117. end warning test while using done_testing (necessary when combining with
  118. the 'if' pragma)
  119. - END tests will not be added by a subequent use of Test::Warnings if a
  120. previous one passed ':no_end_test'
  121. - Update dependencies
  122. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.008-3
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  124. * Wed Jul 24 2013 Petr Pisar <ppisar@redhat.com> - 0.008-2
  125. - Perl 5.18 rebuild
  126. * Mon Jul 15 2013 Paul Howarth <paul@city-fan.org> - 0.008-1
  127. - Update to 0.008
  128. - Compile test updated, to hopefully fix mswin32 parsing issues
  129. * Wed Jul 10 2013 Paul Howarth <paul@city-fan.org> - 0.007-1
  130. - Update to 0.007
  131. - Fix subtest tests to work on Test::More before 0.95_01 (CPAN RT#86802)
  132. - BR: perl(Capture::Tiny)
  133. - Bump perl(Module::Build::Tiny) version requirement to 0.024
  134. - Bump perl(Test::CheckDeps) version requirement to 0.006
  135. - Drop perl(Test::More) version requirement to 0.94
  136. * Tue Jul 9 2013 Paul Howarth <paul@city-fan.org> - 0.006-2
  137. - Sanitize for Fedora submission
  138. * Tue Jul 9 2013 Paul Howarth <paul@city-fan.org> - 0.006-1
  139. - Initial RPM version