perl-Test-Unit-vl.spec 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. Summary: a unit testing interface for Perl
  2. Name: perl-Test-Unit
  3. Version: 0.25
  4. Release: 3%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://perlunit.sourceforge.net/
  8. Source0: http://prdownloads.sourceforge.net/perlunit/Test-Unit-%{version}.tar.gz
  9. # https://rt.cpan.org/Public/Bug/Display.html?id=69025
  10. Patch0: tests5.14.patch
  11. # https://rt.cpan.org/Public/Bug/Display.html?id=77779
  12. Patch1: perl5.16.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildArch: noarch
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Carp)
  17. BuildRequires: perl(Class::Inner)
  18. BuildRequires: perl(Data::Dumper)
  19. BuildRequires: perl(Devel::Symdump)
  20. BuildRequires: perl(Error)
  21. BuildRequires: perl(Exporter)
  22. BuildRequires: perl(Test)
  23. BuildRequires: perl(Tk)
  24. BuildRequires: perl(Tk::Canvas)
  25. BuildRequires: perl(Tk::Derived)
  26. BuildRequires: perl(Tk::DialogBox)
  27. BuildRequires: perl(Tk::ROText)
  28. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  29. %description
  30. Test::Unit is the procedural style interface to a sophisticated
  31. unit testing framework for Perl that is derived from the JUnit
  32. testing framework for Java by Kent Beck and Erich Gamma.
  33. %prep
  34. %setup -q -n Test-Unit-%{version}
  35. %patch0 -p1
  36. %patch1 -p1
  37. sed -i 's/\r//' examples/Experimental/Sample.pm
  38. chmod a+x TkTestRunner.pl TestRunner.pl
  39. %build
  40. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  41. make
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. make pure_install DESTDIR=$RPM_BUILD_ROOT
  45. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  46. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  47. chmod -R u+w $RPM_BUILD_ROOT/*
  48. %check
  49. make test
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %files
  53. %defattr(-,root,root)
  54. %doc AUTHORS ChangeLog Changes COPYING.Artistic COPYING.GPL-2 doc examples README
  55. %{perl_vendorlib}/*
  56. %{_mandir}/man3/*
  57. %changelog
  58. * Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.25-3
  59. - rebuilt with perl 5.16.3
  60. - added Patch0 and 1 from Fedora
  61. * Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 0.25-13
  62. - apply patch to for Test::Unit::TestBase RT#77779
  63. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.25-11
  64. - apply upstream patch for tests RT#69025
  65. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-2
  66. - rebuild with perl-5.12.3
  67. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-1vl5
  68. - applied new versioning policy
  69. - added BuildRequires: perl-Class-Inner, perl-Devel-Symdump, perl-Error
  70. * Thu Feb 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.25-0vl1
  71. - updated to 0,25
  72. - changed Group to Development/Libraires
  73. - added Requires: perl-Tk
  74. * Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.24-0vl1
  75. - version up to 0.24
  76. - replace Copyright tag with License tag
  77. - clarify the License
  78. - update Requires:
  79. add perl-Error, perl-Devel-Symdump and perl-Class-Inner
  80. * Fri Apr 5 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.14-0vl1
  81. - first release for Vine Linux