perl-Test-File-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. # This module usually ships with version numbers having two digits after the decimal point
  2. %global cpanversion 1.443
  3. %global rpmversion 1.44.3
  4. Summary: Test file attributes through Test::Builder
  5. Name: perl-Test-File
  6. Version: %{rpmversion}
  7. Release: 8%{?_dist_release}
  8. License: GPL+ or Artistic
  9. URL: https://metacpan.org/release/Test-File
  10. Source0: https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Test-File-%{cpanversion}.tar.gz
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. BuildArch: noarch
  14. # Module Build
  15. BuildRequires: coreutils
  16. BuildRequires: make
  17. BuildRequires: perl >= 2:5.26.2
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(ExtUtils::Manifest)
  20. # Module Runtime
  21. BuildRequires: perl(base)
  22. BuildRequires: perl(Exporter)
  23. BuildRequires: perl(File::Spec)
  24. BuildRequires: perl(strict)
  25. BuildRequires: perl(Test::Builder)
  26. BuildRequires: perl(vars)
  27. BuildRequires: perl(warnings)
  28. # Test Suite
  29. BuildRequires: perl(Cwd)
  30. BuildRequires: perl(File::Spec::Functions)
  31. BuildRequires: perl(Test::Builder)
  32. BuildRequires: perl(Test::Builder::Tester)
  33. BuildRequires: perl(Test::More)
  34. BuildRequires: perl(Test::utf8)
  35. BuildRequires: perl(utf8)
  36. # Optional Tests
  37. BuildRequires: perl(Test::Pod)
  38. BuildRequires: perl(Test::Pod::Coverage)
  39. # Runtime
  40. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  41. %description
  42. This module provides a collection of test utilities for file attributes.
  43. Some file attributes depend on the owner of the process testing the file
  44. in the same way the file test operators do.
  45. %prep
  46. %setup -q -n Test-File-%{cpanversion}
  47. %build
  48. perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
  49. make %{?_smp_mflags}
  50. %install
  51. make install DESTDIR=%{buildroot}
  52. %{_fixperms} -c %{buildroot}
  53. %check
  54. make test
  55. %files
  56. %license LICENSE
  57. %doc Changes README.pod
  58. %{perl_vendorlib}/Test/
  59. %{_mandir}/man3/Test::File.3*
  60. %changelog
  61. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.44.3-8
  62. - initial build for Vine Linux.
  63. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-7
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  65. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-6
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  67. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.44.3-5
  68. - Perl 5.28 rebuild
  69. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-4
  70. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  71. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.3-3
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  73. * Tue Jun 06 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.44.3-2
  74. - Perl 5.26 rebuild
  75. * Mon Apr 17 2017 Paul Howarth <paul@city-fan.org> - 1.44.3-1
  76. - Update to 1.443
  77. - Found another relative path require issue:
  78. http://blogs.perl.org/users/ryan_voots/2017/04/trials-and-troubles-with-changing-inc.html
  79. - This is another attempt at avoiding failures from the v5.26 removal of . from @INC
  80. - Drop redundant Group: tag
  81. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.44.2-2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  83. * Fri Oct 14 2016 Paul Howarth <paul@city-fan.org> - 1.44.2-1
  84. - Update to 1.442
  85. - Fix for missing . in @INC; this relates to CVE-2016-1238
  86. (https://github.com/briandfoy/test-file/issues/14)
  87. - Split rpm and upstream versioning
  88. - Use features from recent EUMM to simplify %%install section
  89. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.44-3
  90. - Perl 5.24 rebuild
  91. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.44-2
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  93. * Mon Jul 6 2015 Paul Howarth <paul@city-fan.org> - 1.44-1
  94. - Update to 1.44
  95. - Fix problem with META* specifying requirements (CPAN RT#105210)
  96. - Don't install README.pod
  97. - check file_mode_has tests for Windows
  98. - Fix file_has_* tests to work on Windows (GH#13)
  99. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.41-3
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  101. * Fri Jun 12 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.41-2
  102. - Perl 5.22 rebuild
  103. * Wed Sep 24 2014 Paul Howarth <paul@city-fan.org> - 1.41-1
  104. - Update to 1.41
  105. - Uncomment accidentally commented symlink_target_is_absolute_ok
  106. - Add mtime test functions (GH#8)
  107. - Allow tests to run in parallel (CPAN RT#89908, CPAN RT#91862)
  108. - Fix up tests for UTF-8 checks
  109. - This release by BDFOY → update source URL
  110. - Classify buildreqs by usage
  111. - Use %%license
  112. * Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.36-3
  113. - Perl 5.20 rebuild
  114. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.36-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  116. * Thu Jan 2 2014 Paul Howarth <paul@city-fan.org> - 1.36-1
  117. - Update to 1.36
  118. - Fix bad line counts on latest dev version of Perl (CPAN RT#89849)
  119. * Thu Oct 10 2013 Paul Howarth <paul@city-fan.org> - 1.35-1
  120. - Update to 1.35
  121. - Don't distribute MYMETA.* (CPAN RT#89175)
  122. - Add dir_exists_ok and dir_contains_ok
  123. - Add file_contains_* functions
  124. - Specify all dependencies
  125. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.34-4
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  127. * Sun Jul 21 2013 Petr Pisar <ppisar@redhat.com> - 1.34-3
  128. - Perl 5.18 rebuild
  129. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.34-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  131. * Tue Jul 24 2012 Paul Howarth <paul@city-fan.org> - 1.34-1
  132. - Update to 1.34
  133. - Added dir_exists_ok and dir_contains_ok
  134. - Added file_contains_like and file_contains_unlike
  135. - Fixed a few grammatical errors in POD
  136. - Added some SKIP blocks to avoid test failures when running as root
  137. - Fixed qr//mx patterns to work with older Perls (CPAN RT#74365)
  138. - Fixed incorrect spelling of "privileges" in SKIP blocks (CPAN RT#74483)
  139. - Skip testing of symlinks on Windows (CPAN RT#57682)
  140. - Fixed automatically generated test name for owner_isnt (CPAN RT#37676)
  141. - Fixed problem in MANIFEST file (CPAN RT#37676)
  142. - Fixed problem in links.t (CPAN RT#76853)
  143. - This release by BAREFOOT -> update source URL
  144. - BR: perl(base), perl(Exporter) and perl(File::Spec)
  145. - Bump perl(Test::Manifest) version requirement to 1.21
  146. - Bump perl(Test::More) version requirement to 0.88
  147. - Drop perl(ExtUtils::MakeMaker) version requirement
  148. - BR: at least version 1.00 of perl(Test::Pod)
  149. - Drop buildreq perl(Test::Prereq) since t/prereq.t isn't in the test_manifest
  150. - Package LICENSE file
  151. - Expand %%summary and %%description
  152. - Drop %%defattr, redundant since rpm 4.4
  153. - Don't need to remove empty directories from the buildroot
  154. - Don't use macros for commands
  155. - Make %%files list more explicit
  156. - Use %%{_fixperms} macro rather than our own chmod incantation
  157. - Use DESTDIR rather than PERL_INSTALL_ROOT
  158. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-7
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  160. * Wed Jun 13 2012 Petr Pisar <ppisar@redhat.com> - 1.29-6
  161. - Perl 5.16 rebuild
  162. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-5
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  164. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.29-4
  165. - Perl mass rebuild
  166. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-3
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  168. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-2
  169. - Rebuild to fix problems with vendorarch/lib (#661697)
  170. * Tue Jun 29 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.29-1
  171. - update to 1.29
  172. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.25-5
  173. - Mass rebuild with perl-5.12.0
  174. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 1.25-4
  175. - rebuild against perl 5.10.1
  176. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.25-3
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  178. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.25-2
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  180. * Tue Jan 20 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.25-1
  181. - Upstream update.
  182. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-3
  183. - helps if you upload new source
  184. * Fri Feb 8 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-2
  185. - rebuild for new perl
  186. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.22-1
  187. - bump to 1.22
  188. - fix license tag
  189. * Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  190. - Update to 1.16.
  191. * Fri May 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  192. - Update to 1.15.
  193. * Wed May 03 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-1
  194. - First build.