perl-Test-EOL-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. # We don't really need ExtUtils::MakeMaker > 6.30
  2. %global old_eumm %(perl -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.30 ? 1 : 0;' 2>/dev/null || echo 0)
  3. Name: perl-Test-EOL
  4. Version: 1.5
  5. Release: 1%{?_dist_release}
  6. Summary: Check the correct line endings in your project
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Test-EOL/
  10. Source0: http://search.cpan.org/CPAN/authors/id/R/RI/RIBASUSHI/Test-EOL-%{version}.tar.gz
  11. Patch0: Test-EOL-1.0-old-EU::MM.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildArch: noarch
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. BuildRequires: perl(File::Find)
  16. BuildRequires: perl(File::Spec)
  17. BuildRequires: perl(FindBin)
  18. # Simplify breaking dependency loops at bootstrap time
  19. %if 0%{!?perl_bootstrap:1}
  20. BuildRequires: perl(Pod::Coverage::TrustPod)
  21. %endif
  22. BuildRequires: perl(Test::Builder)
  23. BuildRequires: perl(Test::More)
  24. BuildRequires: perl(Test::NoTabs)
  25. BuildRequires: perl(Test::Pod)
  26. BuildRequires: perl(Test::Pod::Coverage)
  27. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  28. %description
  29. This module scans your project/distribution for any perl files (scripts,
  30. modules, etc.) with Windows line endings. It can also check for trailing
  31. whitespace.
  32. %prep
  33. %setup -q -n Test-EOL-%{version}
  34. # We don't really need ExtUtils::MakeMaker > 6.30
  35. %if %{old_eumm}
  36. %patch0 -p1
  37. %endif
  38. %build
  39. perl Makefile.PL INSTALLDIRS=vendor
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf %{buildroot}
  43. make pure_install DESTDIR=%{buildroot}
  44. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  45. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  46. %{_fixperms} %{buildroot}
  47. %check
  48. make test RELEASE_TESTING=1
  49. %clean
  50. rm -rf %{buildroot}
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc Changes LICENSE README
  54. %{perl_vendorlib}/Test/
  55. %{_mandir}/man3/Test::EOL.3pm*
  56. %changelog
  57. * Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.5-1
  58. - updated to 1.5
  59. - built with perl 5.16.3
  60. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1-1
  61. - initial build for Vine Linux
  62. * Mon Jan 16 2012 Paul Howarth <paul@city-fan.org> 1.1-1
  63. - Update to 1.1
  64. - Fix test fails on < 5.8 perls
  65. - Fix t/13-latin1.t failures on Win32 and under TB1.5
  66. - Add buildreqs for required core modules, which might be dual-lived
  67. * Thu Jan 5 2012 Paul Howarth <paul@city-fan.org> 1.0-1
  68. - Update to 1.0
  69. - Fix misleading test failure diagnostics when only issue is trailing
  70. whitespace
  71. - No longer blindly assume utf8 on input files (CPAN RT#59877)
  72. - Properly document testing options
  73. - This release by RIBASUSHI -> update source URL
  74. - Drop upstreamed patch for CPAN RT#59877
  75. - Update patch for building with old ExtUtils::MakeMaker versions
  76. * Thu Jun 30 2011 Paul Howarth <paul@city-fan.org> - 0.9-5
  77. - Restore EPEL-4 compatibility
  78. - perl(Pod::Coverage::TrustPod) is available everywhere now
  79. - %%{?perl_default_filter} isn't needed for this tiny package
  80. - Nobody else likes macros for commands
  81. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.9-4
  82. - Perl mass rebuild
  83. - Add macro perl_bootstrap
  84. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-3
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  86. * Mon Oct 18 2010 Paul Howarth <paul@city-fan.org> 0.9-2
  87. - Don't assume tested files are UTF-8 encoded (CPAN RT#59877)
  88. * Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.9-1
  89. - Update to 0.9 (fix warnings on very old perls - CPAN RT#58442)
  90. - Use DESTDIR instead of PERL_INSTALL_ROOT
  91. - Add %%{?perl_default_filter}
  92. * Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.8-1
  93. - Initial RPM version