perl-Test-Differences-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. # RPM version needs 4 digits after the decimal to preserve upgrade path
  2. %global module_version 0.62
  3. %global RPM_version %(echo %{module_version} | %{__perl} -pi -e 's/(.*)/sprintf("%.4f", $1)/e')
  4. Name: perl-Test-Differences
  5. Version: %{RPM_version}
  6. Release: 1%{?_dist_release}
  7. Summary: Test strings and data structures and show differences if not OK
  8. Group: Development/Libraries
  9. License: GPL+ or Artistic
  10. URL: http://search.cpan.org/dist/Test-Differences/
  11. Source0: http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Differences-%{module_version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: perl(Text::Diff) >= 0.35
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Test::More)
  17. BuildRequires: perl(Test::Pod)
  18. BuildRequires: perl(Test::Pod::Coverage)
  19. BuildRequires: perl(Capture::Tiny)
  20. # not detected
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. %description
  23. When the code you're testing returns multiple lines, records or data
  24. structures and they're just plain wrong, an equivalent to the Unix
  25. diff utility may be just what's needed.
  26. %prep
  27. %setup -q -n Test-Differences-%{module_version}
  28. %build
  29. %{__perl} Makefile.PL INSTALLDIRS=vendor
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf %{buildroot}
  33. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  34. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  35. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  36. chmod -R u+w %{buildroot}/*
  37. %check
  38. make test
  39. %clean
  40. rm -rf %{buildroot}
  41. %files
  42. %defattr(-,root,root,-)
  43. %doc Changes README
  44. %{perl_vendorlib}/Test/
  45. %{_mandir}/man3/Test::Differences.3pm*
  46. %changelog
  47. * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.6200-1
  48. - updated to 0.62
  49. - built with perl 5.16.3
  50. - added BR: perl(Capture::Tiny)
  51. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5000-1
  52. - initial build for Vine Linux
  53. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-6
  54. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  55. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.5000-5
  56. - Perl mass rebuild
  57. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-4
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  59. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.5000-3
  60. - 661697 rebuild for fixing problems with vendorach/lib
  61. * Thu Jul 08 2010 Iain Arnell <iarnell@gmail.com> 0.500-2
  62. - explicitly require perl(Text::Diff)
  63. * Tue Jun 29 2010 Paul Howarth <paul@city-fan.org> - 0.5000-1
  64. - Update to 0.500
  65. - Add support for all diff styles supplied by Text::Diff (CPAN RT#23579)
  66. - Add Build.PL
  67. - Convert to universally use Test::More instead of Test
  68. - Convert to modern Perl distribution.
  69. - Applied doc suggestion from CPAN RT#24297
  70. - Fix the { a => 1 } versus { a => '1' } bug (CPAN RT#3029)
  71. - Upstream dropped eg/ docs
  72. - Bump perl(Text::Diff) requirement to 0.35
  73. - BR: perl(Test::Pod) and perl(Test::Pod::Coverage) for extra test cover
  74. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.4801-5
  75. - Mass rebuild with perl-5.12.0
  76. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.4801-4
  77. - rebuild against perl 5.10.1
  78. * Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-3
  79. - fix source url
  80. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4801-2
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  82. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-1
  83. - update to 0.4801
  84. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.47-5
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  86. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-4
  87. - Rebuild for perl 5.10 (again)
  88. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-3
  89. - rebuild for new perl
  90. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.2
  91. - add BR: perl(Test::More)
  92. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.1
  93. - correct license tag
  94. - add BR: perl(ExtUtils::MakeMaker)
  95. * Sun May 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-2
  96. - Bumping release (repodata checksum inconsistency for previous release).
  97. * Mon May 01 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-1
  98. - First build.