perl-Test-Classy-vl.spec 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. %define pkgname Test-Classy
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.10
  5. Release: 1%{?_dist_release}
  6. Summary: write your unit tests in other modules than *.t
  7. Summary(ja): *.t 以外のモジュールで単体テストを書く
  8. License: Artistic or GPL
  9. Group: Development/Libraries
  10. URL: http://search.cpan.org/~ishigaki/Test-Classy/
  11. Source0: http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: perl(Class::Data::Inheritable)
  15. BuildRequires: perl(Class::Inspector)
  16. BuildRequires: perl(Data::Dump)
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(Module::Find)
  19. BuildRequires: perl(Term::Encoding)
  20. BuildRequires: perl(Test::UseAllModules)
  21. BuildRequires: perl(Sub::Install)
  22. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: yasumichi
  26. %description
  27. This is yet another Test::Class-like unit testing framework. As stated in
  28. Test::Class pod, you don't need to care if your tests are small and working
  29. correctly. If not, this may be one of your options.
  30. Unlike Test::Class, Test::Classy (actually Test::Classy::Base) is based on
  31. Test::More and exports everything Test::More exports. Test::Classy doesn't
  32. control test flow as fully as Test::Class, but it may be easier to skip and
  33. limit tests.
  34. #%%description -l ja
  35. %prep
  36. %setup -q -n Test-Classy-%{version}
  37. %build
  38. perl Makefile.PL INSTALLDIRS=vendor
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf $RPM_BUILD_ROOT
  42. make pure_install DESTDIR=$RPM_BUILD_ROOT
  43. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  44. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} ';' 2>/dev/null
  45. %{_fixperms} $RPM_BUILD_ROOT
  46. %clean
  47. rm -rf $RPM_BUILD_ROOT
  48. %check
  49. make test
  50. %files
  51. %defattr(-,root,root)
  52. %doc Changes README
  53. %{perl_vendorlib}/Test/*
  54. %{_mandir}/man3/*
  55. %changelog
  56. * Tue Nov 25 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.10-1
  57. - updated to 0.10
  58. - built with perl 5.16.3
  59. - installed module to vendor_perl
  60. - added BuildArch: noarch
  61. - added BuildRequires: perl modules
  62. - added URL tag
  63. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
  64. - initial build for Vine Linux