perl-Term-Table-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. # Recognize terminal size
  2. %bcond_with perl_Term_Table_enables_terminal
  3. # Respect Unicode rules when breaking lines
  4. %bcond_with perl_Term_Table_enables_unicode
  5. Name: perl-Term-Table
  6. Version: 0.013
  7. Release: 3%{?_dist_release}
  8. Summary: Format a header and rows into a table
  9. License: GPL+ or Artistic
  10. URL: https://metacpan.org/release/Term-Table
  11. Source0: https://cpan.metacpan.org/authors/id/E/EX/EXODIST/Term-Table-%{version}.tar.gz
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. BuildArch: noarch
  15. BuildRequires: make
  16. BuildRequires: perl >= 2:5.26.2
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(strict)
  19. BuildRequires: perl(warnings)
  20. # Run-time:
  21. BuildRequires: perl(Carp)
  22. BuildRequires: perl(Config)
  23. BuildRequires: perl(Importer)
  24. BuildRequires: perl(List::Util)
  25. BuildRequires: perl(Scalar::Util)
  26. # Optional run-time:
  27. %if %{with perl_Term_Table_enables_terminal}
  28. # Term::ReadKey 2.32 not used if Term::Size::Any is available
  29. # Prefer Term::Size::Any over Term::ReadKey
  30. BuildRequires: perl(Term::Size::Any)
  31. %endif
  32. %if %{with perl_Term_Table_enables_unicode}
  33. BuildRequires: perl(Unicode::GCString)
  34. %endif
  35. # Tests:
  36. BuildRequires: perl(base)
  37. #BuildRequires: perl(Test2::API)
  38. #BuildRequires: perl(Test2::Tools::Tiny)
  39. BuildRequires: perl(Test::More)
  40. BuildRequires: perl(utf8)
  41. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  42. Requires: perl(Importer) >= 0.024
  43. %if %{with perl_Term_Table_enables_terminal}
  44. Suggests: perl(Term::ReadKey)
  45. # Prefer Term::Size::Any over Term::ReadKey
  46. Recommends: perl(Term::Size::Any)
  47. %endif
  48. %if %{with perl_Term_Table_enables_unicode}
  49. Recommends: perl(Unicode::GCString)
  50. %endif
  51. # Remove under-specified dependencies
  52. %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Importer\\)$
  53. %description
  54. This Perl module is able to format rows of data into tables.
  55. %prep
  56. %setup -q -n Term-Table-%{version}
  57. %build
  58. perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
  59. make %{?_smp_mflags}
  60. %install
  61. make pure_install DESTDIR=$RPM_BUILD_ROOT
  62. %{_fixperms} $RPM_BUILD_ROOT/*
  63. %check
  64. %if %{with perl_Term_Table_enables_terminal}
  65. unset TABLE_TERM_SIZE
  66. make test
  67. %endif
  68. %files
  69. %license LICENSE
  70. %doc Changes README
  71. %{perl_vendorlib}/*
  72. %{_mandir}/man3/*
  73. %changelog
  74. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.013-3
  75. - initial build for Vine Linux.
  76. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.013-2
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  78. * Wed Dec 05 2018 Petr Pisar <ppisar@redhat.com> - 0.013-1
  79. - 0.013 bump
  80. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-4
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  82. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.012-3
  83. - Perl 5.28 rebuild
  84. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  86. * Fri Oct 20 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.012-1
  87. - 0.012 bump
  88. * Wed Oct 11 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-1
  89. - 0.011 bump
  90. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.008-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  92. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.008-2
  93. - Perl 5.26 rebuild
  94. * Mon Mar 20 2017 Petr Pisar <ppisar@redhat.com> - 0.008-1
  95. - 0.008 bump
  96. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.006-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  98. * Wed Jan 11 2017 Petr Pisar <ppisar@redhat.com> - 0.006-1
  99. - 0.006 bump
  100. * Mon Jan 02 2017 Petr Pisar <ppisar@redhat.com> - 0.005-1
  101. - 0.005 bump
  102. * Wed Dec 21 2016 Petr Pisar <ppisar@redhat.com> - 0.004-1
  103. - 0.004 bump
  104. * Tue Dec 20 2016 Petr Pisar <ppisar@redhat.com> 0.002-1
  105. - Specfile autogenerated by cpanspec 1.78.