perl-Sub-Name-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. # Only need manual requires for "use base XXX;" prior to rpm 4.9
  2. %global rpm49 %(rpm --version | perl -pi -e 's/^.* (\\d+)\\.(\\d+).*/sprintf("%d.%03d",$1,$2) ge 4.009 ? 1 : 0/e')
  3. Name: perl-Sub-Name
  4. Version: 0.21
  5. Release: 1%{?_dist_release}
  6. Summary: Name - or rename - a sub
  7. License: GPL+ or Artistic
  8. Group: Development/Libraries
  9. URL: http://search.cpan.org/dist/Sub-Name/
  10. Source0: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Sub-Name-%{version}.tar.gz
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: perl(base)
  15. BuildRequires: perl(Devel::CheckBin)
  16. BuildRequires: perl(DynaLoader)
  17. BuildRequires: perl(Exporter)
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(strict)
  20. BuildRequires: perl(Test::More)
  21. BuildRequires: perl(warnings)
  22. BuildRequires: libxcrypt-devel
  23. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  24. %if ! %{rpm49}
  25. Requires: perl(DynaLoader)
  26. Requires: perl(Exporter)
  27. %endif
  28. # Don't "provide" private perl objects
  29. %{?perl_default_filter}
  30. %description
  31. This module allows one to "name" or rename subroutines, including anonymous
  32. ones.
  33. Note that this is mainly for aid in debugging; you still cannot call the sub
  34. by the new name (without some deep magic).
  35. %prep
  36. %setup -q -n Sub-Name-%{version}
  37. %build
  38. perl Makefile.PL INSTALLDIRS=vendor optimize="%{optflags}"
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf %{buildroot}
  42. make pure_install DESTDIR=%{buildroot}
  43. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  44. find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} \;
  45. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  46. %{_fixperms} %{buildroot}
  47. %check
  48. make test
  49. %clean
  50. rm -rf %{buildroot}
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc Changes README
  54. %{perl_vendorarch}/auto/Sub/
  55. %{perl_vendorarch}/Sub/
  56. %{_mandir}/man3/Sub::Name.3pm*
  57. %changelog
  58. * Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.21-1
  59. - new upstream release.
  60. - rebuilt with perl-5.26.
  61. - added BR:libxcrypt-devel.
  62. * Sat Nov 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
  63. - updated to 0.12
  64. - added BR: perl(Devel::CheckBin)
  65. - built with perl 5.16.3
  66. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.05-1
  67. - initial build for Vine Linux
  68. * Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.05-6
  69. - Add patch for CPAN RT#50524 (copy contents of %%DB::sub entry if it exists)
  70. - Reinstate compatibility with old distributions like EL-5
  71. - Add BuildRoot definition
  72. - Clean buildroot in %%install
  73. - Restore %%clean section
  74. - Restore %%defattr
  75. - Don't use + to terminate find -exec commands
  76. - Spec clean-up
  77. - Make %%files list more explicit
  78. - Use DESTDIR rather than PERL_INSTALL_ROOT
  79. - Don't use macros for commands
  80. - Use tabs
  81. - Add buildreqs for Perl core modules that might be dual-lived
  82. - Explicit requires for "use base XXX;" only required prior to rpm 4.9
  83. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-5
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  85. * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.05-4
  86. - Perl mass rebuild
  87. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-3
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  89. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.05-2
  90. - Rebuild to fix problems with vendorarch/lib (#661697)
  91. * Sat Dec 18 2010 Iain Arnell <iarnell@gmail.com> - 0.05-1
  92. - Update to latest upstream version
  93. - Clean up spec for modern rpmbuild
  94. - BR perl(Test::More)
  95. - Requires perl(DynaLoader) and perl(Exporter)
  96. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.04-6
  97. - Mass rebuild with perl-5.12.0
  98. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.04-5
  99. - Rebuild against perl 5.10.1
  100. * Thu Aug 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-4
  101. - Filtering errant private provides
  102. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-3
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  104. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  106. * Sun Aug 03 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.04-1
  107. - Update to 0.04
  108. * Sat Mar 15 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
  109. - Update to 0.03
  110. * Tue Mar 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-5
  111. - Rebuild for new perl
  112. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.02-4.1
  113. - Autorebuild for GCC 4.3
  114. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.02-3.1
  115. - Correct license tag
  116. - Add BR: perl(ExtUtils::MakeMaker)
  117. * Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-3
  118. - Bump
  119. * Wed Sep 06 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-2
  120. - Bump
  121. * Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.02-1
  122. - Specfile autogenerated by cpanspec 1.69.1