perl-Sub-Install-vl.spec 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. %define pkgname Sub-Install
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.928
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: install subroutines into packages easily
  14. Summary(ja): 簡単にパッケージにサブルーチンをインストールする
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. This module makes it easy to install subroutines into packages without the
  21. unslightly mess of no strict or typeglobs lying about where just anyone can
  22. see them.
  23. #%%description -l ja
  24. %prep
  25. %setup -q -n %{pkgname}-%{version}
  26. %build
  27. perl Makefile.PL
  28. %{__make}
  29. %install
  30. %{__rm} -rf ${RPM_BUILD_ROOT}
  31. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  32. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  33. sed "s@^$RPM_BUILD_ROOT@@g" |
  34. grep -v ^%{_mandir} |
  35. grep -v perllocal.pod |
  36. grep -v "\.packlist" > %{name}.files
  37. if [ "$(cat %{name}.files)X" = "X" ] ; then
  38. echo "ERROR: EMPTY FILE LIST"
  39. exit -1
  40. fi
  41. # remove unnecessary files.
  42. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  43. %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Sub/Install/.packlist
  44. %clean
  45. %{__rm} -rf ${RPM_BUILD_ROOT}
  46. %files -f %{name}.files
  47. %defattr(-,root,root)
  48. %license LICENSE
  49. %doc Changes README
  50. %{_mandir}/*/*
  51. %changelog
  52. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.928-1
  53. - new upstream release.
  54. - rebuilt with perl-5.26.
  55. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.927-1
  56. - update to 927-1
  57. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.925-1
  58. - initial build for Vine Linux