perl-SUPER-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. Name: perl-SUPER
  2. Version: 1.20141117
  3. Release: 2%{?_dist_release}
  4. Summary: Sane superclass method dispatcher
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/SUPER/
  8. Source0: http://search.cpan.org/CPAN/authors/id/C/CH/CHROMATIC/SUPER-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. BuildRequires: perl(Carp)
  14. BuildRequires: perl(Exporter)
  15. BuildRequires: perl(Module::Build)
  16. BuildRequires: perl(Scalar::Util)
  17. BuildRequires: perl(Sub::Identify)
  18. BuildRequires: perl(Test::Simple)
  19. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  20. Requires: perl(Scalar::Util)
  21. Requires: perl(Sub::Identify)
  22. # Filter out bogus provides (rpm 4.9 onwards)
  23. %global __provides_exclude ^perl\\((DB|UNIVERSAL)\\)
  24. %description
  25. When subclassing a class, you occasionally want to dispatch control to the
  26. superclass - at least conditionally and temporarily. This module provides
  27. an easier, cleaner way for class methods to access their ancestor's
  28. implementation.
  29. %prep
  30. %setup -q -n SUPER-%{version}
  31. # Filter out bogus provides (prior to rpm 4.9)
  32. %global provfilt /bin/sh -c "%{__perl_provides} | grep -Evx 'perl[(](DB|UNIVERSAL)[)]'"
  33. %define __perl_provides %{provfilt}
  34. %build
  35. perl Build.PL installdirs=vendor
  36. ./Build
  37. %install
  38. rm -rf %{buildroot}
  39. ./Build install destdir=%{buildroot} create_packlist=0
  40. %{_fixperms} %{buildroot}
  41. %check
  42. ./Build test
  43. %clean
  44. rm -rf %{buildroot}
  45. %files
  46. %doc Changes README
  47. %{perl_vendorlib}/SUPER.pm
  48. %{_mandir}/man3/SUPER.3pm*
  49. %changelog
  50. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.20141117-2
  51. - rebuilt with perl-5.26.
  52. * Mon Dec 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.20141117-1
  53. - new upstream release
  54. - built with perl 5.16.3
  55. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
  56. - initial build for Vine Linux
  57. * Tue Mar 6 2012 Paul Howarth <paul@city-fan.org> - 1.17-7
  58. - Add provides filters that work with all supported distributions
  59. - BR: perl(Carp) and perl(Exporter)
  60. - Make %%files list more explicit
  61. - Drop explicit requires of perl(Exporter) since it's auto-detected by rpm
  62. 4.9 onwards, and is bundled with perl on all older distributions
  63. - Don't need to remove empty directories from buildroot
  64. - Don't use macros for commands
  65. - %%defattr redundant since rpm 4.4
  66. - Use tabs
  67. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-6
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  69. * Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.17-5
  70. - Perl mass rebuild
  71. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-4
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  73. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-3
  74. - Rebuild to fix problems with vendorarch/lib (#661697)
  75. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.17-2
  76. - Mass rebuild with perl-5.12.0
  77. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> - 1.17-1
  78. - Update filtering
  79. - Auto-update to 1.17 (by cpan-spec-update 0.01)
  80. - Added a new br on perl(Scalar::Util) (version 1.20)
  81. - Altered br on perl(Sub::Identify) (0 => 0.03)
  82. - Altered br on perl(Test::Simple) (0 => 0.61)
  83. - Added a new req on perl(Scalar::Util) (version 1.20)
  84. - Added a new req on perl(Sub::Identify) (version 0.03)
  85. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-5
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  87. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.16-4
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  89. * Tue Mar 04 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.16-3
  90. - Rebuild for new perl
  91. * Wed Jan 02 2008 Ralf Corsépius <rc040203@freenet.de> - 1.16-2
  92. - Adjust License-tag
  93. - BR: perl(Test::Simple) (BZ 419631)
  94. * Wed Apr 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.16-1
  95. - Update to 1.16
  96. * Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.15-1
  97. - Update to 1.15
  98. - Add explict requires on perl(Exporter); missed due to a use base construct
  99. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-4
  100. - Bump
  101. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-3
  102. - Update %%description and %%summary
  103. * Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-2
  104. - Filter errant perl(DB) provide
  105. * Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> - 1.14-1
  106. - Specfile autogenerated by cpanspec 1.69.1