perl-Ref-Util-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. # Run optional test
  2. %bcond_without perl_Ref_Util_enables_optional_test
  3. Name: perl-Ref-Util
  4. Version: 0.204
  5. Release: 5%{?_dist_release}
  6. Summary: Utility functions for checking references
  7. License: MIT
  8. URL: https://metacpan.org/release/Ref-Util
  9. Source0: https://cpan.metacpan.org/authors/id/A/AR/ARC/Ref-Util-%{version}.tar.gz
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. # Build
  14. BuildRequires: coreutils
  15. BuildRequires: findutils
  16. BuildRequires: make
  17. BuildRequires: perl >= 2:5.26.2
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(lib)
  20. BuildRequires: perl(Text::ParseWords)
  21. # Dependencies of bundled ExtUtils::HasCompiler
  22. BuildRequires: gcc
  23. BuildRequires: perl(base)
  24. BuildRequires: perl(Config)
  25. BuildRequires: perl(DynaLoader)
  26. BuildRequires: perl(File::Basename)
  27. BuildRequires: perl(File::Spec::Functions)
  28. BuildRequires: perl(File::Temp)
  29. # Module
  30. BuildRequires: perl(Carp)
  31. BuildRequires: perl(constant)
  32. BuildRequires: perl(Exporter)
  33. BuildRequires: perl(Scalar::Util)
  34. BuildRequires: perl(strict)
  35. BuildRequires: perl(warnings)
  36. # Test Suite
  37. BuildRequires: perl(File::Find)
  38. BuildRequires: perl(File::Spec)
  39. BuildRequires: perl(IPC::Open2)
  40. BuildRequires: perl(Ref::Util::XS)
  41. BuildRequires: perl(Test::More)
  42. %if %{with perl_Ref_Util_enables_optional_test}
  43. # Optional Tests
  44. BuildRequires: perl(B::Concise)
  45. BuildRequires: perl(CPAN::Meta)
  46. BuildRequires: perl(Readonly)
  47. %endif
  48. # Runtime
  49. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  50. Requires: perl(Ref::Util::XS)
  51. %description
  52. Ref::Util introduces several functions to help identify references in a faster
  53. and smarter way.
  54. %prep
  55. %setup -q -n Ref-Util-%{version}
  56. %build
  57. perl Makefile.PL INSTALLDIRS=vendor
  58. make %{?_smp_mflags}
  59. %install
  60. make pure_install DESTDIR=%{buildroot}
  61. find %{buildroot} -type f -name .packlist -delete
  62. %{_fixperms} -c %{buildroot}
  63. %check
  64. make test
  65. %files
  66. %if 0%{?_licensedir:1}
  67. %license LICENSE
  68. %else
  69. %doc LICENSE
  70. %endif
  71. %doc Changes README
  72. %{perl_vendorlib}/Ref/
  73. %{_mandir}/man3/Ref::Util.3*
  74. %{_mandir}/man3/Ref::Util::PP.3*
  75. %changelog
  76. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0204-5
  77. - initial build for Vine Linux.
  78. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.204-4
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  80. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.204-3
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  82. * Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.204-2
  83. - Perl 5.28 rebuild
  84. * Thu Apr 19 2018 Paul Howarth <paul@city-fan.org> - 0.204-1
  85. - Update to 0.204
  86. - Fix Makefile.PL so that the 'install' sub is patched before WriteMakefile()
  87. is called (GH#41)
  88. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.203-4
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  90. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.203-3
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  92. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.203-2
  93. - Perl 5.26 rebuild
  94. * Mon May 15 2017 Paul Howarth <paul@city-fan.org> - 0.203-1
  95. - Update to 0.203
  96. - Fix space/tab issue in Makefile
  97. - Don't use DynamicPrereqs for unrelated Makefile.PL snippet
  98. - Use of the Pure-Perl implementation can now be forced at runtime by setting
  99. either $Ref::Util::IMPLEMENTATION or $ENV{PERL_REF_UTIL_IMPLEMENTATION} to
  100. "XS"
  101. - Fix is_*_formatref() error messages (GH#38)
  102. - Speed enhancements for is_*_formatref() on 5.8+
  103. - Restore 5.6 and 5.8 compatibility
  104. - PP behaviour now matches XS for \v1.2.3 and \sub {}
  105. - Updated documentation to reflect the PP/XS split
  106. * Fri May 12 2017 Paul Howarth <paul@city-fan.org> - 0.200-1
  107. - Update to 0.200
  108. - Reimplement in pure Perl, with a dynamic dependency on a new Ref::Util::XS
  109. module that contains the fast XS implementation
  110. - This release by ARC → update source URL
  111. - Package is now noarch
  112. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.113-2
  113. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  114. * Tue Jan 17 2017 Paul Howarth <paul@city-fan.org> - 0.113-1
  115. - Update to 0.113
  116. - Fix bugtracker link
  117. * Sun Jan 15 2017 Paul Howarth <paul@city-fan.org> - 0.112-1
  118. - Update to 0.112
  119. - Fix compilation on Sun (Oracle) and some MSVC compilers (GH#35)
  120. * Fri Dec 30 2016 Paul Howarth <paul@city-fan.org> - 0.111-1
  121. - Update to 0.111
  122. - Fix test failure on 5.8.5 and under
  123. - Moved to Dist::Zilla
  124. * Thu Dec 29 2016 Paul Howarth <paul@city-fan.org> - 0.110-1
  125. - Update to 0.110
  126. - Fix support of 5.8 (GH#29, GH#34)
  127. - Additional optimizations
  128. - More extensive test suite
  129. * Mon Aug 29 2016 Paul Howarth <paul@city-fan.org> - 0.101-1
  130. - Update to 0.101
  131. - A test accidentally added a dependency on Readonly.pm - fixed! (GH#30)
  132. - Update README
  133. * Sat Aug 27 2016 Paul Howarth <paul@city-fan.org> - 0.100-1
  134. - Update to 0.100
  135. - Support situations in op-code implementation where the parameters do not
  136. come as a list
  137. - Fix memory leak in dangling op
  138. - Support magic (tied variables)
  139. - Rework op implementation
  140. - Speed up by changing the top of the stack instead of POPing and PUSHing
  141. - Update ppport.h file from Devel::PPPort and remove the copy of SVRXOK since
  142. it's now available
  143. - Add license in Pod
  144. - Specify minimum version of perl (5.6.2)
  145. * Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-2
  146. - Sanitize for Fedora submission
  147. * Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-1
  148. - Initial RPM version