perl-Ref-Util-XS-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. # Run optional tests
  2. %if ! (0%{?rhel})
  3. %bcond_without perl_Ref_Util_XS_enables_optional_test
  4. %else
  5. %bcond_with perl_Ref_Util_XS_enables_optional_test
  6. %endif
  7. Name: perl-Ref-Util-XS
  8. Version: 0.117
  9. Release: 6%{?_dist_release}
  10. Summary: Utility functions for checking references
  11. License: MIT
  12. URL: https://metacpan.org/release/Ref-Util-XS
  13. Source0: https://cpan.metacpan.org/authors/id/X/XS/XSAWYERX/Ref-Util-XS-%{version}.tar.gz
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. # Build
  17. BuildRequires: coreutils
  18. BuildRequires: findutils
  19. BuildRequires: gcc
  20. BuildRequires: make
  21. BuildRequires: perl >= 2:5.26.2
  22. BuildRequires: perl(ExtUtils::MakeMaker)
  23. # Module
  24. BuildRequires: perl(Exporter)
  25. BuildRequires: perl(strict)
  26. BuildRequires: perl(warnings)
  27. BuildRequires: perl(XSLoader)
  28. # Test Suite
  29. BuildRequires: perl(constant)
  30. BuildRequires: perl(File::Spec)
  31. BuildRequires: perl(Test::More)
  32. %if %{with perl_Ref_Util_XS_enables_optional_test}
  33. # Optional Tests
  34. BuildRequires: perl(B::Concise)
  35. BuildRequires: perl(CPAN::Meta)
  36. BuildRequires: perl(Readonly)
  37. %endif
  38. # Runtime
  39. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  40. # Avoid provides for private objects
  41. %{?perl_default_filter}
  42. %description
  43. Ref::Util::XS introduces several functions to help identify references in a
  44. faster and smarter way.
  45. %prep
  46. %setup -q -n Ref-Util-XS-%{version}
  47. %build
  48. perl Makefile.PL INSTALLDIRS=vendor
  49. make %{?_smp_mflags}
  50. %install
  51. make pure_install DESTDIR=%{buildroot}
  52. find %{buildroot} -type f -name .packlist -delete
  53. find %{buildroot} -type f -name '*.bs' -empty -delete
  54. %{_fixperms} -c %{buildroot}
  55. %check
  56. make test
  57. %files
  58. %license LICENSE
  59. %doc Changes README
  60. %{perl_vendorarch}/auto/Ref/
  61. %{perl_vendorarch}/Ref/
  62. %{_mandir}/man3/Ref::Util::XS.3*
  63. %changelog
  64. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.117-6
  65. - initial build for Vine Linux.
  66. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-5
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  68. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-4
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  70. * Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.117-3
  71. - Perl 5.28 rebuild
  72. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-2
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  74. * Wed Jan 31 2018 Paul Howarth <paul@city-fan.org> - 0.117-1
  75. - Update to 0.117
  76. - Allow the custom OPs to be deparsed with B::Deparse
  77. - Optimize the shared object size by moving common call checker logic into a
  78. function
  79. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.116-5
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  81. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.116-4
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  83. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.116-3
  84. - Perl 5.26 rebuild
  85. * Tue May 30 2017 Paul Howarth <paul@city-fan.org> - 0.116-2
  86. - Incorporate package review feedback (#1450440)
  87. - Drop EL6-isms as we need Test::More 0.94, which EL-6 will never have
  88. * Mon May 15 2017 Paul Howarth <paul@city-fan.org> - 0.116-1
  89. - Update to 0.116
  90. - Changes rephrasing
  91. - Restore 5.6 compatibility
  92. - Replace docs with a link to Ref::Util
  93. * Fri May 12 2017 Paul Howarth <paul@city-fan.org> - 0.115-1
  94. - Package renamed Ref-Util-XS to make room for Ref-Util's new pure-Perl
  95. implementation
  96. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.113-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  98. * Tue Jan 17 2017 Paul Howarth <paul@city-fan.org> - 0.113-1
  99. - Update to 0.113
  100. - Fix bugtracker link
  101. * Sun Jan 15 2017 Paul Howarth <paul@city-fan.org> - 0.112-1
  102. - Update to 0.112
  103. - Fix compilation on Sun (Oracle) and some MSVC compilers (GH#35)
  104. * Fri Dec 30 2016 Paul Howarth <paul@city-fan.org> - 0.111-1
  105. - Update to 0.111
  106. - Fix test failure on 5.8.5 and under
  107. - Moved to Dist::Zilla
  108. * Thu Dec 29 2016 Paul Howarth <paul@city-fan.org> - 0.110-1
  109. - Update to 0.110
  110. - Fix support of 5.8 (GH#29, GH#34)
  111. - Additional optimizations
  112. - More extensive test suite
  113. * Mon Aug 29 2016 Paul Howarth <paul@city-fan.org> - 0.101-1
  114. - Update to 0.101
  115. - A test accidentally added a dependency on Readonly.pm - fixed! (GH#30)
  116. - Update README
  117. * Sat Aug 27 2016 Paul Howarth <paul@city-fan.org> - 0.100-1
  118. - Update to 0.100
  119. - Support situations in op-code implementation where the parameters do not
  120. come as a list
  121. - Fix memory leak in dangling op
  122. - Support magic (tied variables)
  123. - Rework op implementation
  124. - Speed up by changing the top of the stack instead of POPing and PUSHing
  125. - Update ppport.h file from Devel::PPPort and remove the copy of SVRXOK since
  126. it's now available
  127. - Add license in Pod
  128. - Specify minimum version of perl (5.6.2)
  129. * Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-2
  130. - Sanitize for Fedora submission
  131. * Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-1
  132. - Initial RPM version