perl-Parse-RecDescent-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. Name: perl-Parse-RecDescent
  2. Version: 1.967009
  3. Release: 1%{?_dist_release}
  4. Summary: Parse-RecDescent Perl module
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Parse-RecDescent/
  8. Source0: http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Parse-RecDescent-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(Carp)
  12. BuildRequires: perl(Data::Dumper)
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(Module::Build)
  15. BuildRequires: perl(Text::Balanced)
  16. BuildRequires: perl(Test::More)
  17. BuildRequires: perl(Test::Pod)
  18. BuildRequires: perl(Test::Warn)
  19. BuildRequires: perl(version)
  20. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  21. Distribution: Vine
  22. Vendor: Project Vine
  23. Packager: munepi, shaolin
  24. %{?perl_default_filter}
  25. %description
  26. Parse::RecDescent incrementally generates top-down recursive-descent
  27. text parsers from simple yacc-like grammar specifications. It
  28. provides:
  29. * Regular expressions or literal strings as terminals (tokens),
  30. * Multiple (non-contiguous) productions for any rule,
  31. * Repeated and optional subrules within productions,
  32. * Full access to Perl within actions specified as part of the
  33. grammar,
  34. * Simple automated error reporting during parser generation and
  35. parsing,
  36. * The ability to commit to, uncommit to, or reject particular
  37. productions during a parse,
  38. * The ability to pass data up and down the parse tree ("down" via
  39. subrule argument lists, "up" via subrule return values)
  40. * Incremental extension of the parsing grammar (even during a
  41. parse),
  42. * Precompilation of parser objects,
  43. User-definable reduce-reduce conflict resolution via "scoring" of
  44. matching productions.
  45. %prep
  46. %setup -q -n Parse-RecDescent-%{version}
  47. chmod a-x demo/* tutorial/*
  48. %{__perl} -pi -e 's|^#!\s?/usr/local/bin/perl\b|#!%{__perl}|' demo/*
  49. %{__perl} -pi -e 's|^#!\s?/opt/local/bin/perl5\.10\.0\b|#!%{__perl}|' demo/*
  50. for f in Changes demo/demo_dot.pl; do
  51. iconv -f iso-8859-1 -t utf-8 < "$f" > "${f}_" && %__mv -f "${f}_" "$f"
  52. done
  53. %build
  54. %{__perl} Makefile.PL INSTALLDIRS=vendor
  55. %__make %{?_smp_mflags}
  56. %install
  57. %__rm -rf %{buildroot}
  58. %__make pure_install DESTDIR=%{buildroot}
  59. find %{buildroot} -type f -name .packlist -exec %__rm -f {} ';'
  60. find %{buildroot} -type d -depth -exec %__rmdir {} 2>/dev/null ';'
  61. %__chmod -R u+w %{buildroot}/*
  62. %check
  63. %__make test
  64. %clean
  65. %__rm -rf %{buildroot}
  66. %files
  67. %defattr(-,root,root,-)
  68. %{perl_vendorlib}/Parse/
  69. %{_mandir}/man3/*.3*
  70. %doc Changes README demo/ tutorial/
  71. %changelog
  72. * Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.967009-1
  73. - updated to 1.967009
  74. - built with perl 5.16.3
  75. * Mon Mar 12 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.964-2
  76. - rebuild
  77. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.964-1
  78. - initial build
  79. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.964-2
  80. - Mass rebuild with perl-5.12.0
  81. * Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.964-1
  82. - update, fix previous issue and https://rt.cpan.org/Public/Bug/Display.html?id=53948
  83. * Tue Feb 16 2010 Marcela Mašláňová <mmaslano@redhat.com> 1.963-2
  84. - apply upstream patch https://rt.cpan.org/Public/Bug/Display.html?id=54457
  85. which should fix problems with rebuilds of other modules
  86. * Tue Feb 9 2010 Paul Howarth <paul@city-fan.org> 1.963-1
  87. - update to 1.963 (fix subtle bug in leftop and rightop due to removal of $&)
  88. - recode Changes as utf-8
  89. - more script interpreter fixes
  90. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.962.2-1
  91. - updated for latest GA SQL::Translator
  92. - add default filtering
  93. - auto-update to 1.962.2 (by cpan-spec-update 0.01)
  94. - added a new br on perl(Text::Balanced) (version 0)
  95. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-3
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  97. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.96-2
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  99. * Mon Feb 2 2009 Stepan Kasal <skasal@redhat.com> - 1.96-1
  100. - new upstream version
  101. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-5
  102. - Rebuild for perl 5.10 (again)
  103. * Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-4
  104. - rebuild for new perl
  105. * Wed Nov 14 2007 Robin Norwood <rnorwood@redhat.com> - 1.95.1-3
  106. - Apply fixes from package review:
  107. - Remove BR: perl
  108. - Use iconv to convert file to utf-8
  109. - Include BR: perl(Test::Pod)
  110. - Fix old changelog entry
  111. - Resolves: bz#226274
  112. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-2
  113. - add BR: perl(version), perl(Test::More)
  114. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.95.1-1
  115. - bump to 1.95.1
  116. - correct license tag (now under perl license)
  117. - add BR: perl(ExtUtils::MakeMaker)
  118. * Fri Jul 20 2007 Robin Norwood <rnorwood@redhat.com> - 1.94-6.fc8
  119. - Bring fixes from EPEL build into F8
  120. - Fix minor specfile issues
  121. - Package the docs as well
  122. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.94-5.2.1
  123. - rebuild
  124. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.94-5.2
  125. - rebuild for new perl-5.8.8
  126. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  127. - rebuilt for new gcc
  128. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  129. - rebuilt for new gcj
  130. * Thu Apr 21 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.94-5
  131. - #155620
  132. - Bring up to date with current Fedora.Extras perl spec template.
  133. * Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.94-4
  134. - rebuild
  135. * Tue Feb 17 2004 Chip Turner <cturner@redhat.com> 1.94-2
  136. - fix rm to not be interactive (bz115997)
  137. * Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 1.94-1
  138. - update to 1.94
  139. * Tue Aug 6 2002 Chip Turner <cturner@redhat.com>
  140. - automated release bump and build
  141. * Sat Jul 20 2002 Chip Turner <cturner@localhost.localdomain>
  142. - remove Text::Balanced modules since they are now in core perl
  143. * Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
  144. - description update
  145. * Fri Jun 07 2002 cturner@redhat.com
  146. - Specfile autogenerated