perl-Params-Validate-vl.spec 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. %define pkgname Params-Validate
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 1.13
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: Params::Validate - Validate method/function parameters
  14. Summary(ja): Params::Validate - メソッド/関数のパラメーターを検証する
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. The Params::Validate module allows you to validate method or function call
  21. parameters to an arbitrary level of specificity. At the simplest level, it
  22. is capable of validating the required parameters were given and that no
  23. unspecified additional parameters were passed in.
  24. It is also capable of determining that a parameter is of a specific type,
  25. that it is an object of a certain class hierarchy, that it possesses certain
  26. methods, or applying validation callbacks to arguments.
  27. #%%description -l ja
  28. #Params::Validate モジュールを使えば、
  29. %prep
  30. %setup -q -n %{pkgname}-%{version}
  31. %build
  32. %{__perl} Build.PL installdirs="vendor"
  33. ./Build
  34. %install
  35. %{__rm} -rf ${RPM_BUILD_ROOT}
  36. PERL_INSTALL_ROOT=${RPM_BUILD_ROOT} ./Build install
  37. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  38. sed "s@^$RPM_BUILD_ROOT@@g" |
  39. grep -v ^%{_mandir} |
  40. grep -v perllocal.pod |
  41. grep -v "\.packlist" > %{name}.files
  42. if [ "$(cat %{name}.files)X" = "X" ] ; then
  43. echo "ERROR: EMPTY FILE LIST"
  44. exit -1
  45. fi
  46. # remove unnecessary files.
  47. find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
  48. find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
  49. %clean
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %files -f %{name}.files
  52. %defattr(-,root,root)
  53. %doc Changes LICENSE README
  54. %changelog
  55. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13-1
  56. - new upstream release.
  57. * Thu Jan 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.00-1
  58. - initial build for Vine Linux