perl-POE-Test-Loops.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. Name: perl-POE-Test-Loops
  2. Summary: Reusable tests for POE::Loop authors
  3. Version: 1.360
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Source0: http://search.cpan.org/CPAN/authors/id/R/RC/RCAPUTO/POE-Test-Loops-%{version}.tar.gz
  8. URL: http://search.cpan.org/dist/POE-Test-Loops
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. BuildArch: noarch
  12. BuildRequires: perl(constant)
  13. BuildRequires: perl(ExtUtils::MakeMaker)
  14. BuildRequires: perl(File::Path)
  15. BuildRequires: perl(File::Spec)
  16. BuildRequires: perl(File::Temp)
  17. BuildRequires: perl(IO::Handle)
  18. BuildRequires: perl(IO::Socket)
  19. BuildRequires: perl(IO::Socket::INET)
  20. BuildRequires: perl(POE)
  21. BuildRequires: perl(Socket)
  22. BuildRequires: perl(Test::More)
  23. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  24. %if %{_dist_release} > "vl6"
  25. %global __provides_exclude %{?__provides_exclude:__requires_exclude|}^perl\\(POE::MySession\\)
  26. %global __provides_exclude %__provides_exclude|perl\\(POE::Kernel\\)
  27. %global __provides_exclude %__provides_exclude|perl\\(PoeTestWorker\\)
  28. %global __provides_exclude %__provides_exclude|perl\\([DIFMOSU].*\\)
  29. %global __provides_exclude %__provides_exclude|perl\\(Switch\\)
  30. %endif
  31. %description
  32. POE::Test::Loops contains one function, generate(), which will generate
  33. all the loop tests for one or more POE::Loop subclasses. The SYNOPSIS
  34. example is a version of poe-gen-tests, which is a stand-alone utility
  35. to generate the actual tests. The poe-gen-tests manual page also documents
  36. the POE::Test::Loops system in more detail.
  37. %prep
  38. %setup -q -n POE-Test-Loops-%{version}
  39. find . -type f -exec chmod -c -x {} ';'
  40. %if %{_dist_release} <= "vl6"
  41. cat << \EOF > %{name}-prov
  42. #!/bin/sh
  43. %{__perl_provides} $* |\
  44. sed -e '/perl(POE::MySession)/d' |\
  45. sed -e '/perl(POE::Kernel)/d' |\
  46. sed -e '/perl(PoeTestWorker)/d' |\
  47. sed -e '/perl([DIFMOSU].*)/d' |\
  48. sed -e '/perl(Switch)/d'
  49. EOF
  50. %global __perl_provides %{_builddir}/POE-Test-Loops-%{version}/%{name}-prov
  51. chmod +x %{__perl_provides}
  52. %endif
  53. %build
  54. %{__perl} Makefile.PL INSTALLDIRS=vendor
  55. make %{?_smp_mflags}
  56. %install
  57. make pure_install DESTDIR=%{buildroot}
  58. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  59. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  60. %{_fixperms} %{buildroot}/*
  61. %check
  62. make test
  63. %files
  64. %doc CHANGES README
  65. %{perl_vendorlib}/*
  66. %{_mandir}/man3/*.3*
  67. %{_bindir}/poe-gen-tests
  68. %{_mandir}/man1/poe-gen-tests.1.gz
  69. %changelog
  70. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.360-1
  71. - new upstream release.
  72. - rebuilt with perl-5.26.
  73. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.350-2
  74. - build with Perl 5.16
  75. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.350-1
  76. - initial build for Vine Linux
  77. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.350-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  79. * Wed Dec 21 2011 Petr Šabata <contyk@redhat.com> - 1.350-1
  80. - 1.350 bump
  81. * Fri Aug 5 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.312-2
  82. - filter also Switch from provides, just to be sure
  83. * Wed Jul 27 2011 Petr Sabata <contyk@redhat.com> - 1.312-1
  84. - 1.312 bump (needed by current POE)
  85. - Drop Buildroot and defattr support
  86. - Fix dependencies a bit
  87. - Add RPM 4.9 style filters
  88. - Filter POE::Kernel and PoeTestWorker from Provides
  89. * Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.035-4
  90. - Perl mass rebuild
  91. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.035-3
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  93. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.035-2
  94. - 661697 rebuild for fixing problems with vendorach/lib
  95. * Mon Jun 7 2010 Petr Pisar <ppisar@redhat.com> - 1.035-1
  96. - 1.035 bump
  97. - Orthography fix in description
  98. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.033-2
  99. - Mass rebuild with perl-5.12.0
  100. * Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.033-1
  101. - update by Fedora::App::MaintainerTools 0.006
  102. - PERL_INSTALL_ROOT => DESTDIR
  103. - updating to latest GA CPAN version (1.033)
  104. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.022-1
  105. - update filtering
  106. - auto-update to 1.022 (by cpan-spec-update 0.01)
  107. * Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.021-1
  108. - auto-update to 1.021 (by cpan-spec-update 0.01)
  109. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.005-2
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  111. * Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-1
  112. - update for submission
  113. * Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-0
  114. - initial RPM packaging
  115. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)