perl-Net_SSLeay-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176
  1. %define real_name Net-SSLeay
  2. Summary: Perl module for using OpenSSL via Network
  3. Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
  4. Name: perl-Net_SSLeay
  5. Version: 1.42
  6. Release: 2%{?_dist_release}
  7. License: BSDish
  8. Group: Development/Libraries
  9. Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
  10. Source1: COPYRIGHT.SSLeay-0.9.0
  11. BuildRequires: perl, openssl-devel >= 0.9.6b
  12. BuildRequires: zlib-devel
  13. Requires: perl, openssl >= 0.9.6b
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. %description
  16. Perl module for using OpenSSL via Network, Net::SSLeay.
  17. %description -l ja
  18. OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
  19. %prep
  20. %setup -q -n %{real_name}-%{version}
  21. cp -p %{SOURCE1} .
  22. # openssl_path is /usr here, therefore don't -I/usr/include and
  23. # especially don't (badly) hardcode standard library search path
  24. # /usr/lib
  25. if [[ "%{_prefix}" = "/usr" ]]; then
  26. perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
  27. fi
  28. %build
  29. # note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
  30. perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
  31. n
  32. EOI
  33. make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
  34. perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
  35. %install
  36. rm -rf %{buildroot}
  37. #mkdir -p %{buildroot}%{perl_archlib}
  38. #make install PREFIX=%{buildroot}%{_prefix} \
  39. # SITEPREFIX=%{buildroot}%{_prefix} \
  40. # VENDORPREFIX=%{buildroot}%{_prefix} \
  41. # INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
  42. # INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
  43. # INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
  44. # INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
  45. # INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
  46. # INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
  47. # INSTALLBIN=%{buildroot}%{_bindir} \
  48. # INSTALLSITEBIN=%{buildroot}%{_bindir} \
  49. # INSTALLVENDORBIN=%{buildroot}%{_bindir} \
  50. # INSTALLSCRIPT=%{buildroot}%{_bindir} \
  51. # INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
  52. # INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
  53. # INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
  54. # INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
  55. # INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
  56. # INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
  57. make install DESTDIR=%{buildroot}
  58. sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
  59. mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
  60. #if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
  61. # mv %{buildroot}%{perl_archlib}/perllocal.pod .
  62. #else
  63. # touch perllocal.pod
  64. #fi
  65. perllocalfile=`find %{buildroot} -name perllocal.pod`
  66. echo "mv $perllocalfile ."
  67. mv $perllocalfile .
  68. {
  69. find %{buildroot} \
  70. -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
  71. } > %{name}.files
  72. %clean
  73. rm -rf %{buildroot}
  74. #check
  75. #make test
  76. %files -f %{name}.files
  77. %defattr(-,root,root)
  78. %doc Changes Credits QuickRef README COPYRIGHT.SSLeay-0.9.0 perllocal.pod
  79. #%dir %{perl_vendorarch}/auto/Net
  80. #%dir %{perl_vendorarch}/auto/Net/SSLeay
  81. #%dir %{perl_vendorarch}/Net
  82. #%dir %{perl_vendorarch}/Net/SSLeay
  83. %changelog
  84. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.42-2
  85. - build with Perl 5.16
  86. * Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
  87. - new upstream release
  88. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
  89. - rebuild with perl-5.12.3
  90. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
  91. - new upstream release
  92. - change BuildRequires: openssl-devel instead of openssl
  93. - add BuildRequires: zlib-devel
  94. * Wed Jul 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
  95. - new upstream release
  96. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
  97. - spec in utf-8
  98. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
  99. - rebuilt with perl-5.10.0
  100. - applied new versioning policy
  101. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
  102. - rebuilt with openssl-0.9.8e
  103. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
  104. - updated to 1.30
  105. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
  106. - installed files to vendor_perl
  107. - changed Group to Development/Libraries
  108. * Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
  109. - build on perl-5.8.6-0vl1
  110. * Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
  111. - build with perl-5.8.2
  112. - add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
  113. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
  114. - new upstream version
  115. - built on perl-5.8.1
  116. * Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
  117. - fixed install man dir, again
  118. * Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
  119. - fixed install dir of perllocal.pod
  120. * Thu May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
  121. - fixed install man dir
  122. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
  123. - comment out "make test"
  124. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
  125. - updated to 1.22
  126. * Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
  127. - updated to 1.13
  128. - BuildPreReq/Requires: perl, openssl-0.9.6b
  129. - rewrite a better spec with License/Group
  130. * Mon Jul 16 2001 <sagami@vinelinux.org>
  131. - 1.07-0vl3: rebuilt with openssl-0.9.6b
  132. - erase unneeeded files from %%doc
  133. - use _prefix, not prefix
  134. * Thu Jul 05 2001 <sagami@vinelinux.org>
  135. - 1.07-0vl2: built with perl-5.6.1
  136. * Thu Jun 7 2001 Yasuhide OMORI <omori@m-t.com>
  137. - 1.07
  138. * Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
  139. - first version of rpm.