perl-Net-SSLeay-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194
  1. %define real_name Net-SSLeay
  2. Summary: Perl module for using OpenSSL via Network
  3. Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
  4. Name: perl-Net-SSLeay
  5. Version: 1.88
  6. Release: 1%{?_dist_release}
  7. License: BSDish
  8. Group: Development/Libraries
  9. Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
  10. Source1: COPYRIGHT.SSLeay-0.9.0
  11. BuildRequires: perl, openssl-devel >= 1.1.1
  12. BuildRequires: zlib-devel
  13. Requires: perl, openssl >= 1.1.1
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Obsoletes: perl-Net_SSLeay < 1.64
  18. Provides: perl-Net_SSLeay = %{version}-%{release}
  19. %description
  20. Perl module for using OpenSSL via Network, Net::SSLeay.
  21. %description -l ja
  22. OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
  23. %prep
  24. %setup -q -n %{real_name}-%{version}
  25. cp -p %{SOURCE1} .
  26. # openssl_path is /usr here, therefore don't -I/usr/include and
  27. # especially don't (badly) hardcode standard library search path
  28. # /usr/lib
  29. if [[ "%{_prefix}" = "/usr" ]]; then
  30. perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
  31. fi
  32. %build
  33. # note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
  34. perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
  35. n
  36. EOI
  37. make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
  38. perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
  39. %install
  40. rm -rf %{buildroot}
  41. #mkdir -p %{buildroot}%{perl_archlib}
  42. #make install PREFIX=%{buildroot}%{_prefix} \
  43. # SITEPREFIX=%{buildroot}%{_prefix} \
  44. # VENDORPREFIX=%{buildroot}%{_prefix} \
  45. # INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
  46. # INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
  47. # INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
  48. # INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
  49. # INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
  50. # INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
  51. # INSTALLBIN=%{buildroot}%{_bindir} \
  52. # INSTALLSITEBIN=%{buildroot}%{_bindir} \
  53. # INSTALLVENDORBIN=%{buildroot}%{_bindir} \
  54. # INSTALLSCRIPT=%{buildroot}%{_bindir} \
  55. # INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
  56. # INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
  57. # INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
  58. # INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
  59. # INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
  60. # INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
  61. make install DESTDIR=%{buildroot}
  62. sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
  63. mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
  64. #if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
  65. # mv %{buildroot}%{perl_archlib}/perllocal.pod .
  66. #else
  67. # touch perllocal.pod
  68. #fi
  69. perllocalfile=`find %{buildroot} -name perllocal.pod`
  70. echo "mv $perllocalfile ."
  71. mv $perllocalfile .
  72. {
  73. find %{buildroot} \
  74. -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
  75. } > %{name}.files
  76. %clean
  77. rm -rf %{buildroot}
  78. #check
  79. #make test
  80. %files -f %{name}.files
  81. %defattr(-,root,root)
  82. %license COPYRIGHT.SSLeay-0.9.0
  83. %doc Changes Credits QuickRef README perllocal.pod
  84. #%dir %{perl_vendorarch}/auto/Net
  85. #%dir %{perl_vendorarch}/auto/Net/SSLeay
  86. #%dir %{perl_vendorarch}/Net
  87. #%dir %{perl_vendorarch}/Net/SSLeay
  88. %changelog
  89. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.88-1
  90. - new upstream release.
  91. - rebuilt with perl-5.26.
  92. * Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.85-1
  93. - new upstream release.
  94. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.74-1
  95. - new upstream release.
  96. * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64-1
  97. - new upstream release.
  98. - renamed from "perl-Net_SSLeay".
  99. - added "Obsoletes: perl-Net_SSLeay" and "Provides: perl-Net_SSLeay".
  100. * Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
  101. - new upstream release
  102. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
  103. - rebuild with perl-5.12.3
  104. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
  105. - new upstream release
  106. - change BuildRequires: openssl-devel instead of openssl
  107. - add BuildRequires: zlib-devel
  108. * Wed Jul 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
  109. - new upstream release
  110. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
  111. - spec in utf-8
  112. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
  113. - rebuilt with perl-5.10.0
  114. - applied new versioning policy
  115. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
  116. - rebuilt with openssl-0.9.8e
  117. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
  118. - updated to 1.30
  119. * Sat Sep 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
  120. - installed files to vendor_perl
  121. - changed Group to Development/Libraries
  122. * Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
  123. - build on perl-5.8.6-0vl1
  124. * Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
  125. - build with perl-5.8.2
  126. - add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
  127. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
  128. - new upstream version
  129. - built on perl-5.8.1
  130. * Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
  131. - fixed install man dir, again
  132. * Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
  133. - fixed install dir of perllocal.pod
  134. * Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
  135. - fixed install man dir
  136. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
  137. - comment out "make test"
  138. * Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
  139. - updated to 1.22
  140. * Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
  141. - updated to 1.13
  142. - BuildPreReq/Requires: perl, openssl-0.9.6b
  143. - rewrite a better spec with License/Group
  144. * Mon Jul 16 2001 <sagami@vinelinux.org>
  145. - 1.07-0vl3: rebuilt with openssl-0.9.6b
  146. - erase unneeeded files from %%doc
  147. - use _prefix, not prefix
  148. * Thu Jul 05 2001 <sagami@vinelinux.org>
  149. - 1.07-0vl2: built with perl-5.6.1
  150. * Thu Jun 7 2001 Yasuhide OMORI <omori@m-t.com>
  151. - 1.07
  152. * Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
  153. - first version of rpm.