perl-Module-Signature-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. Name: perl-Module-Signature
  2. Version: 0.73
  3. Release: 6%{?_dist_release}
  4. Summary: CPAN signature management utilities and modules
  5. Summary(ja): CPAN の署名管理ツール及び perl モジュール
  6. Group: Development/Libraries
  7. License: CC0
  8. URL: http://search.cpan.org/dist/Module-Signature/
  9. Source0: http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Module-Signature-%{version}.tar.gz
  10. Source1: AKOENIG.pub
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. # Module build
  14. BuildRequires: perl(base)
  15. BuildRequires: perl(Cwd)
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. # Module runtime
  18. BuildRequires: gnupg
  19. BuildRequires: perl(constant)
  20. BuildRequires: perl(Digest::SHA)
  21. BuildRequires: perl(Digest::SHA1)
  22. BuildRequires: perl(Exporter)
  23. BuildRequires: perl(ExtUtils::Manifest)
  24. BuildRequires: perl(File::Spec)
  25. BuildRequires: perl(IO::Socket::INET)
  26. BuildRequires: perl(Text::Diff)
  27. # Test suite
  28. BuildRequires: perl(Data::Dumper)
  29. BuildRequires: perl(File::Path)
  30. BuildRequires: perl(Getopt::Long)
  31. BuildRequires: perl(IPC::Run)
  32. BuildRequires: perl(lib)
  33. BuildRequires: perl(Pod::Usage)
  34. BuildRequires: perl(Test::More)
  35. # Module runtime
  36. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  37. Requires: gnupg
  38. Requires: perl(Digest::SHA)
  39. Requires: perl(Digest::SHA1)
  40. Requires: perl(IO::Socket::INET)
  41. Requires: perl(PAR::Dist)
  42. Requires: perl(Text::Diff)
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. %description
  46. This package contains a command line tool and module for checking and creating
  47. SIGNATURE files for Perl CPAN distributions.
  48. %prep
  49. %setup -q -c -n Module-Signature
  50. # Copy up documentation for convenience with %%doc
  51. cp -a Module-Signature-%{version}/{AUTHORS,Changes,README,*.pub} .
  52. # Create a GPG directory for testing, to avoid using ~/.gnupg
  53. mkdir --mode=0700 gnupghome
  54. # Import AKOENIG key so we don't try to download it later
  55. export GNUPGHOME=$(pwd)/gnupghome
  56. gpg --import %{SOURCE1}
  57. %build
  58. export GNUPGHOME=$(pwd)/gnupghome
  59. cd Module-Signature-%{version}
  60. perl Makefile.PL INSTALLDIRS=vendor --skipdeps </dev/null
  61. make %{?_smp_mflags}
  62. cd -
  63. %install
  64. rm -rf %{buildroot}
  65. make -C Module-Signature-%{version} pure_install DESTDIR=%{buildroot}
  66. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  67. %{_fixperms} %{buildroot}
  68. %check
  69. export GNUPGHOME=$(pwd)/gnupghome
  70. make -C Module-Signature-%{version} test TEST_SIGNATURE=1
  71. %clean
  72. rm -rf %{buildroot}
  73. %files
  74. %doc AUTHORS Changes README *.pub
  75. %{_bindir}/cpansign
  76. %{perl_vendorlib}/Module/
  77. %{_mandir}/man1/cpansign.1*
  78. %{_mandir}/man3/Module::Signature.3pm*
  79. %changelog
  80. * Sat Jan 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.73-6
  81. - Initial build for Vine Linux
  82. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.73-5
  83. - Perl 5.20 rebuild
  84. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.73-4
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  86. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.73-3
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  88. * Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 0.73-2
  89. - Perl 5.18 rebuild
  90. * Fri Jun 7 2013 Paul Howarth <paul@city-fan.org> - 0.73-1
  91. - Update to 0.73
  92. - Constrain the user-specified digest name to /^\w+\d+$/
  93. - Only allow loading Digest::* from absolute paths in @INC (CVE-2013-2145)
  94. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.70-2
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  96. * Wed Nov 28 2012 Paul Howarth <paul@city-fan.org> - 0.70-1
  97. - Update to 0.70
  98. - Don't check gpg version if gpg does not exist
  99. * Fri Nov 2 2012 Paul Howarth <paul@city-fan.org> - 0.69-1
  100. - Update to 0.69
  101. - Support for gpg under these alternate names: gpg gpg2 gnupg gnupg2
  102. - This release by AUDREYT -> update source URL
  103. - BR:/R: perl(Text::Diff)
  104. - Include Andreas Koenig's GPG key in the SRPM and import it in %%prep so
  105. that we don't need to get it from a keyserver in %%check
  106. * Thu Nov 1 2012 Petr Pisar <ppisar@redhat.com> - 0.68-7
  107. - Make building non-interactive
  108. - Specify all dependencies
  109. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.68-6
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  111. * Tue Jun 12 2012 Paul Howarth <paul@city-fan.org> - 0.68-5
  112. - BR: perl(constant), perl(Data::Dumper) and perl(lib)
  113. - Don't need to remove empty directories from the buildroot
  114. - Drop %%defattr, redundant since rpm 4.4
  115. * Tue Jun 12 2012 Petr Pisar <ppisar@redhat.com> - 0.68-4
  116. - Perl 5.16 rebuild
  117. * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.68-3
  118. - BR: perl(Exporter) and perl(ExtUtils::Manifest)
  119. - Use %%{_fixperms} macro rather than our own chmod incantation
  120. * Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.68-2
  121. - Perl mass rebuild
  122. * Fri May 13 2011 Paul Howarth <paul@city-fan.org> - 0.68-1
  123. - Update to 0.68
  124. - Fix breakage introduced by 0.67 (CPAN RT#68150)
  125. * Thu Apr 21 2011 Paul Howarth <paul@city-fan.org> - 0.67-3
  126. - Pseudo-merge EPEL-5/EPEL-6/Fedora versions
  127. * Tue Apr 19 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.67-2
  128. - Appease rpmbuild >= 4.9
  129. * Tue Apr 19 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.67-1
  130. - Update to 0.67
  131. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  133. * Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.66-2
  134. - Rebuild to fix problems with vendorarch/lib (#661697)
  135. * Tue Sep 7 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.66-1
  136. - Update to 0.66 (#630714)
  137. * Tue Sep 7 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.65-1
  138. - Update to 0.65 (#630714)
  139. * Wed Jun 30 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.64-2
  140. - Rebuild
  141. * Sun May 9 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.64-1
  142. - Update to 0.64 (#590385)
  143. * Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.63-2
  144. - Mass rebuild with perl-5.12.0
  145. * Fri Apr 23 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.63-1
  146. - Update to 0.63
  147. - Sync with current rpmdevtools spec template
  148. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.61-2
  149. - Rebuild against perl 5.10.1
  150. * Thu Nov 19 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.61-1
  151. - Update to 0.61 (#538780)
  152. * Tue Nov 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.60-1
  153. - Update to 0.60 (#538043); license changed from MIT to CC0
  154. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.55-5
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  156. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.55-4
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  158. * Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.55-3
  159. - Rebuild for new perl
  160. * Tue Apr 17 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.55-2
  161. - BuildRequire perl(ExtUtils::MakeMaker) and perl(Test::More)
  162. * Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.55-1
  163. - 0.55
  164. - Make PAR::Dist dependency a Requires(hint)
  165. * Fri May 12 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.54-1
  166. - 0.54, license changed to MIT
  167. * Wed Feb 1 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.53-1
  168. - 0.53
  169. * Fri Jan 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.52-1
  170. - 0.52
  171. - Run non-live tests during build and make live ones optional, enabled
  172. when building with "--with livetests"
  173. * Mon Jan 2 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.51-1
  174. - 0.51
  175. * Mon Aug 22 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.50-1
  176. - 0.50
  177. * Wed Aug 10 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.45-1
  178. - 0.45
  179. * Thu Apr 7 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.44-2
  180. - Drop Epoch: 0 and 0.fdr. release prefix
  181. * Fri Dec 17 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.44-0.fdr.1
  182. - Update to 0.44
  183. * Sun Nov 21 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.42-0.fdr.1
  184. - Update to 0.42
  185. * Tue Jul 6 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.41-0.fdr.2
  186. - Require perl(Digest::SHA1) (bug 1606)
  187. * Mon Jul 5 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.41-0.fdr.1
  188. - Update to 0.41
  189. * Fri Jul 2 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.40-0.fdr.1
  190. - Update to 0.40
  191. * Fri Jun 18 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.39-0.fdr.1
  192. - Update to 0.39
  193. * Mon May 31 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.4
  194. - Really use pure_install (bug 1606)
  195. - Fix build with older mktemp versions which require a template (bug 1606)
  196. * Mon May 31 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.3
  197. - Fix build in setups which do not generate debug packages (bug 1606)
  198. - Require perl >= 1:5.6.1 for vendor install dir support
  199. - Use pure_install to avoid perllocal.pod workarounds
  200. * Sun Apr 25 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.2
  201. - Require perl(:MODULE_COMPAT_*)
  202. * Sat Mar 27 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.1
  203. - First build