perl-Module-Pluggable-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. # Run optional test
  2. %bcond_with perl_Module_Pluggable_enables_optional_test
  3. Name: perl-Module-Pluggable
  4. Version: 5.2
  5. Release: 11%{?_dist_release}
  6. Summary: Automatically give your module the ability to have plugins
  7. License: GPL+ or Artistic
  8. URL: https://metacpan.org/release/Module-Pluggable
  9. Source0: https://cpan.metacpan.org/authors/id/S/SI/SIMONW/Module-Pluggable-%{version}.tar.gz
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildArch: noarch
  13. BuildRequires: coreutils
  14. BuildRequires: findutils
  15. BuildRequires: make
  16. BuildRequires: perl >= 2:5.26.2
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(File::Spec::Functions)
  19. BuildRequires: perl(strict)
  20. BuildRequires: perl(warnings)
  21. # Run-time:
  22. BuildRequires: perl(Carp)
  23. BuildRequires: perl(deprecate)
  24. BuildRequires: perl(Exporter)
  25. BuildRequires: perl(File::Basename)
  26. BuildRequires: perl(File::Find)
  27. BuildRequires: perl(if)
  28. BuildRequires: perl(vars)
  29. # Recommended run-time:
  30. BuildRequires: perl(Module::Runtime)
  31. # Tests:
  32. BuildRequires: perl(base)
  33. BuildRequires: perl(Data::Dumper)
  34. BuildRequires: perl(FindBin)
  35. BuildRequires: perl(lib)
  36. BuildRequires: perl(Test::More)
  37. # IncTest is a locally overloaded module in t/lib/Text/Abbrev.pm
  38. %if %{with perl_Module_Pluggable_enables_optional_test}
  39. # Optional tests:
  40. BuildRequires: perl(App::FatPacker)
  41. BuildRequires: perl(Cwd)
  42. BuildRequires: perl(File::Copy)
  43. BuildRequires: perl(File::Path)
  44. BuildRequires: perl(File::Temp)
  45. %endif
  46. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  47. Requires: perl(File::Spec::Functions)
  48. Requires: perl(deprecate)
  49. # Recommended run-time:
  50. Recommends: perl(Module::Runtime)
  51. # Filter under-specified dependencies
  52. %global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(File::Spec::Functions\\)$
  53. %description
  54. This package provides a simple but, hopefully, extensible way of having
  55. 'plugins' for your module. Essentially all it does is export a method into
  56. your name space that looks through a search path for .pm files and turn those
  57. into class names. Optionally it instantiates those classes for you.
  58. %prep
  59. %setup -q -n Module-Pluggable-%{version}
  60. find -type f -exec chmod -x {} +
  61. %build
  62. perl Makefile.PL INSTALLDIRS=vendor
  63. make %{?_smp_mflags}
  64. %install
  65. make pure_install DESTDIR=%{buildroot}
  66. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  67. %{_fixperms} %{buildroot}/*
  68. %check
  69. make test
  70. %files
  71. %doc Changes README
  72. %{perl_vendorlib}/*
  73. %{_mandir}/man3/*
  74. %changelog
  75. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.2-11
  76. - initial build for Vine Linux.
  77. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-10
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  79. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-9
  80. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  81. * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2:5.2-8
  82. - Perl 5.28 rebuild
  83. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-7
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  85. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-6
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  87. * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2:5.2-5
  88. - Perl 5.26 rebuild
  89. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-4
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  91. * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2:5.2-3
  92. - Perl 5.24 rebuild
  93. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2:5.2-2
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  95. * Mon Aug 31 2015 Petr Pisar <ppisar@redhat.com> - 2:5.2-1
  96. - 5.2 bump
  97. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:5.10-6
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  99. * Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:5.10-5
  100. - Perl 5.22 re-rebuild of bootstrapped packages
  101. * Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1:5.10-4
  102. - Perl 5.22 rebuild
  103. * Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1:5.10-3
  104. - Perl 5.20 rebuild
  105. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:5.10-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  107. * Mon Jan 06 2014 Petr Pisar <ppisar@redhat.com> - 1:5.10-1
  108. - 5.1 bump
  109. * Mon Jan 06 2014 Petr Pisar <ppisar@redhat.com> - 1:5.00-1
  110. - 5.0 bump
  111. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.80-291
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  113. * Mon Jul 15 2013 Petr Pisar <ppisar@redhat.com> - 1:4.80-290
  114. - Increase release to favour standalone package
  115. * Fri Jul 12 2013 Petr Pisar <ppisar@redhat.com> - 1:4.8-2
  116. - Perl 5.18 rebuild
  117. * Tue May 28 2013 Petr Pisar <ppisar@redhat.com> - 1:4.8-1
  118. - 4.8 bump
  119. * Thu Feb 28 2013 Petr Pisar <ppisar@redhat.com> - 1:4.7-1
  120. - 4.7 bump
  121. * Thu Jan 24 2013 Petr Pisar <ppisar@redhat.com> 1:4.6-1
  122. - Specfile autogenerated by cpanspec 1.78.